locked
Exchange 2010 EMC not starting on Windows 8 RRS feed

  • Question

  • Hi,

    I have installed Latest Windows 8 Server build (8220) on Oracle Virtual box.

    I was able to install Exchange server 2010 successfully, but when I start EMC, It fails with the following error message.

    Searching for the On-premises Exchange server...

    The following error occured while searching for the on-premises Exchange server:

    [machine_name.domain.com] Connecting to remote server <machine_name.domain.com> failed with the following error message: The client cannot connect to the destination specified in the request. Verify that the service on the destination is running and is accepting the requests. Consult the logs and documentation for the WS-Management service running on the destination, most commonly IIS or WinRM. If the destination is WinRM service, run the following command on the destination to analyze and configure the WinRM service:
     "winrm quickconfig". For more information, see the about_Remote_troubleshooting Help topic. It was running the command
    'Discover-ExchangeServer _useWIA $true -SupressError $true - CurrentVersion 'Version 14.1(Build218.15)".

    Can anybody help me resolving this issue?

    Thursday, February 23, 2012 8:34 AM

Answers

All replies

  • Hi Ravi,

    Please follow this..

    http://blogs.dirteam.com/blogs/jorge/archive/2010/06/13/exchange-installation-issue-with-winrm.aspx


    Kottees : My Blog : Please mark it as an answer if it really helps you.

    Thursday, February 23, 2012 8:58 AM
  • Hi,

    I have already followed this steps. Not working.. It was displaying the same error message.

    BTW what was the OS that you faced this problem. I guess it is Win2k8.

    But my problem is on Win 8. I think this problem is specific to Win 8.

    While starting up EMC, in the System tray I  noticed Windows error reporting popup with the message "IIS worker process has stopped working..."

    Probably this could give a clue

    Thursday, February 23, 2012 9:31 AM
  • yes that was win2k8. never tried with windows8:(

    Kottees : My Blog : Please mark it as an answer if it really helps you.

    Thursday, February 23, 2012 9:44 AM
  • Event viewer shows two errors when trying to launch EMC.

    Faulting application name: w3wp.exe, version: 8.0.8220.0, time stamp: 0x4f2397fc
    Faulting module name: webengine.dll, version: 2.0.50727.6111, time stamp: 0x4f14e1bc
    Exception code: 0xc0000005
    Fault offset: 0x00000000000877e5
    Faulting process id: 0x1118
    Faulting application start time: 0x01ccf285d6122dfa
    Faulting application path: c:\windows\system32\inetsrv\w3wp.exe
    Faulting module path: C:\Windows\Microsoft.NET\Framework64\v2.0.50727\webengine.dll
    Report Id: 21efda9b-5e79-11e1-b1d1-08002791e541
    Faulting package full name:
    Faulting package-relative application ID:

    (Process w3wp.exe, PID 4376) "RBAC authorization is unavailable because of an exception that occurred while opening the Web configuration. Exception: System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
       at System.Web.Hosting.UnsafeIISMethods.MgdGetSiteNameFromId(UInt32 siteId, IntPtr& bstrSiteName, Int32& cchSiteName)
       at System.Web.Configuration.ProcessHostConfigUtils.GetSiteNameFromId(UInt32 siteId)
       at System.Web.Configuration.ProcessHostMapPath.System.Web.Configuration.IConfigMapPath.ResolveSiteArgument(String siteArgument, String& siteName, String& siteID)
       at System.Web.Configuration.WebConfigurationHost.GetConfigPaths(IConfigMapPath configMapPath, WebLevel webLevel, VirtualPath virtualPath, String site, String locationSubPath, VirtualPath& appPath, String& appSiteName, String& appSiteID, String& configPath, String& locationConfigPath)
       at System.Web.Configuration.WebConfigurationHost.InitForConfiguration(String& locationSubPath, String& configPath, String& locationConfigPath, IInternalConfigRoot configRoot, Object[] hostInitConfigurationParams)
       at System.Configuration.Configuration..ctor(String locationSubPath, Type typeConfigHost, Object[] hostInitConfigurationParams)
       at System.Configuration.Internal.InternalConfigConfigurationFactory.System.Configuration.Internal.IInternalConfigConfigurationFactory.Create(Type typeConfigHost, Object[] hostInitConfigurationParams)
       at System.Web.Configuration.WebConfigurationHost.OpenConfiguration(WebLevel webLevel, ConfigurationFileMap fileMap, VirtualPath path, String site, String locationSubPath, String server, String userName, String password, IntPtr tokenHandle)
       at System.Web.Configuration.WebConfigurationManager.OpenWebConfiguration(String path, String site)
       at Microsoft.Exchange.Configuration.Authorization.ExchangeAuthorizationPlugin.OpenWebConfig(String host, String vdirPath, String& webSiteName)

    Thursday, February 23, 2012 10:40 AM
  • As you probably know it;s not fully suppotred yet, I wont be able to test until I get my hands on Win 8 in the next few weeks.

    Sukh

    Thursday, February 23, 2012 10:56 AM
  • Hi,

    Exchange Server Supportability Matrix

    http://technet.microsoft.com/en-us/library/ff728623.aspx

    As per the article above, Exchange 2010 is not supported or tested completely with Windows 8 yet.

    We request you to wait for the official communication on the Exchange / Windows 8 supportability.

    Regards..

    • Marked as answer by Terence Yu Friday, March 2, 2012 8:37 AM
    Friday, February 24, 2012 8:53 AM
  • I was able to overcome this problem by installing .Net3.5 Extensibility feature.

    But still I am facing issues configuring server, mailbox  as they are shown unavailable.

    The following excerpts are from the event log.

    • Service MSExchangeMailSubmission. Exchange topology discovery encountered an exception Microsoft.Exchange.Data.Directory.ADTransientException: Could not find any available Domain Controller.
    • The Mailbox Replication service was unable to determine the list of mailbox databases hosted in the local Active Directory site.
      Error: Could not find any available Domain Controller.
    • Process MAD.EXE (PID=860). All Domain Controller Servers in use are not responding: <domain_name>
    • The server {73E709EA-5D93-4B2E-BBB0-99B7938DA9E4} did not register with DCOM within the required timeout.
    • Process STORE.EXE (PID=1724). All Domain Controller Servers in use are not responding: <domain_name>
    • Active Directory Web Services was unable to determine if the computer is a global catalog server.
    • Microsoft Exchange System Attendant failed to read the membership of the universal security group '/dc=com/dc=rewin8/ou=Microsoft Exchange Security Groups/cn=Exchange Servers'; the error code was '800705b4'. The problem might be that the Microsoft Exchange System Attendant does not have permission to read the membership of the group.
    • Active Manager failed to mount database Mailbox Database 0379216413 on server <FQDN>. Error: An Active Manager operation failed with a transient error. Please retry the operation. Error: Database action failed with transient error. Error: A transient error occurred during a database operation. Error: MapiExceptionADUnavailable: Unable to mount database. (hr=0x80004005, ec=2414)

      If this computer is not a member of the group '/dc=com/dc=rewin8/ou=Microsoft Exchange Security Groups/cn=Exchange Servers', you should manually stop all Microsoft Exchange services, run the task 'add-ExchangeServerGroupMember,' and then restart all Microsoft Exchange services.
    • The processing of Group Policy failed. Windows attempted to retrieve new Group Policy settings for this user or computer. Look in the details tab for error code and description. Windows will automatically retry this operation at the next refresh cycle. Computers joined to the domain must have proper name resolution and network connectivity to a domain controller for discovery of new Group Policy objects and settings. An event will be logged when Group Policy is successful.
    • Service MSExchangeMailSubmission. Exchange topology discovery encountered an exception Microsoft.Exchange.Data.Directory.ADTransientException: Could not find any available Domain Controller.


    Monday, March 5, 2012 12:39 PM
  • As Sens said this is not supported as yet. EMS seems to work fine though... but use at your own risk
    Sunday, October 14, 2012 9:58 AM