locked
HELP PLEASE: Windows Update cannot currently check for updates because the service is not running – Win7 Recent RRS feed

  • Question

  • My Environment:

    The Windows Update Service will not work for the last couple weeks.

    I have Windows 7, 32 bit Ultimate

    Some people reporting this kind of problem seem to have it with systems that are not on/connected very much. This system is normally on a lot & connected to the Internet for many days at a time – it is normally only off for ~20-40 hours in a week.

    I saw a long thread on this in mid-2012, but I am having current problems with this in Aug-Oct 2013.

    An MGADiag print out is listed at the end of this, and has more detail on the system

    My Problem:

    I choose windows update from IE, or start menu, and get to the control panel where it says “Windows update cannot currently check for updates because the service is not running. You may need to restart your machine.”  

    I have restarted the machine (many times).

    Step 1:

    I have gone to manage services, and have confirmed that;

    • Background Intelligent Transfer Service - Is started and it is set to 'Automatic (Delayed Start),
    • Windows Update - Is started and it is set to 'Automatic (Delayed Start),

    Step 2:

    I have tried stop/start both services (multiple times – both with & without the benefit of system restarts inbetween ), so see if I could get it to restart.

    These actions have no effect – using the Windows update CP continues to say it will not run since the service is not running (even though it is).

    Step 3:

    I normally have Windows updates set to run automatically, but after reading in another thread here, I decided to try one person’s recommend to force Windows updates to Not be run automatically, save that setting, then go back & change it back to run them automatically. This does have an effect -

    This allowed me to be able to go back to the Windows Update control panel & the update button will push to run updates, it will act like it is seeking update info for <1 second & return with

    Most recently checked for updates: Never

    Updates were installed: Never

    Both of which I know are false – The system has been operational with automatic updates for >2 years…

    I have also selected the “Installed updates” link in the bottom left corner of the Win Updates CP, and I can see updates listed up through 7/11/2013 – from that point on, no more updates appear to have been processed??!

    Step 4:

    Reading posts here, I have seen people say that sometimes Windows Defender seems to be linked – I ran Windows Defender, and so I forced an update with it. Windows Defender tries to perform an update, and after ~2-4 seconds returns and says;

    “The program can't check for definition updates. Error found: 0xc80003f3. The configuration registry key could not be opened.”

    Step 5:

    I have tried to run the Mr Fixit tool to resolve this, but it “finds no problems” – yet when I examine the report from it, there is a clear note in “Issues found” that says “Searching for updates failed” – followed by some odd characters… It also says Windows update encountered an error and gives an error code (see below)

    Windows Update

    Publisher details

    Issues found

    Searching for updates failed

    Detected

    Issues found

    Detection details

    undefined

    Searching for updates failed

    Detected

    Windows Update encountered an error searching for updates online.

    Scan details

    Windows Update encountered an error while searching for updates.

    Error code:

    -939523085

    Detection details

    Network Diagnostics Log

    File Name:

    A3EB51E0-4670-45F9-B98F-3D2E3221ED29.Diagnose.Admin.0.etl

    Other Networking Configuration and Logs

    File Name:

    NetworkConfiguration.cab

    Collection information

    Computer Name:

    XANADU

    Windows Version:

    6.1

    Architecture:

    x86

    Time:

    Thursday, October 10, 2013 10:49:11 PM

    Publisher details

    Windows Network Diagnostics

    Detects problems with network connectivity.

    Package Version:

    1.0

    Publisher:

    Microsoft Windows

    Windows Update

    Troubleshoot problems preventing Windows Update from working correctly.

    Package Version:

    1.0

    Publisher:

    Microsoft Windows

    Windows Update

    Troubleshoot problems preventing Windows Update from working correctly.

    Package Version:

    1.0

    Publisher:

    Microsoft Corporation

    Step 6:

    I have run the MGADiag tool & here is the output:

    Diagnostic Report (1.9.0027.0):

    -----------------------------------------

    Windows Validation Data-->

    Validation Code: 0

    Cached Online Validation Code: 0x0

    Windows Product Key: *****-*****-4H37K-RXPQ6-BHVJ4

    Windows Product Key Hash: 1U1gimDSV20w5WTY5Wj5yt7Xtao=

    Windows Product ID: 00426-067-9119285-86817

    Windows Product ID Type: 5

    Windows License Type: Retail

    Windows OS version: 6.1.7601.2.00010100.1.0.001

    ID: {8E0375DC-328B-4CDA-9F43-0561E0AD8B13}(1)

    Is Admin: Yes

    TestCab: 0x0

    LegitcheckControl ActiveX: Registered, 1.9.42.0

    Signed By: Microsoft

    Product Name: Windows 7 Ultimate

    Architecture: 0x00000000

    Build lab: 7601.win7sp1_gdr.130505-1534

    TTS Error:

    Validation Diagnostic:

    Resolution Status: N/A

    Vista WgaER Data-->

    ThreatID(s): N/A, hr = 0x80070002

    Version: N/A, hr = 0x80070002

    Windows XP Notifications Data-->

    Cached Result: N/A, hr = 0x80070002

    File Exists: No

    Version: N/A, hr = 0x80070002

    WgaTray.exe Signed By: N/A, hr = 0x80070002

    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Notifications Data-->

    Cached Result: N/A, hr = 0x80070002

    Version: 2.0.48.0

    OGAExec.exe Signed By: Microsoft

    OGAAddin.dll Signed By: Microsoft

    OGA Data-->

    Office Status: 100 Genuine

    Microsoft Office SharePoint Designer 2007 - 100 Genuine

    OGA Version: Registered, 2.0.48.0

    Signed By: Microsoft

    Office Diagnostics: B4D0AA8B-604-645_B4D0AA8B-604-645_B4D0AA8B-604-645_B4D0AA8B-604-645_025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

    Browser Data-->

    Proxy settings: N/A

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)

    Default Browser: C:\Program Files\Google\Chrome\Application\chrome.exe

    Download signed ActiveX controls: Prompt

    Download unsigned ActiveX controls: Disabled

    Run ActiveX controls and plug-ins: Allowed

    Initialize and script ActiveX controls not marked as safe: Disabled

    Allow scripting of Internet Explorer Webbrowser control: Disabled

    Active scripting: Allowed

    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->

    Office Details: <GenuineResults><MachineData><UGUID>{8E0375DC-328B-4CDA-9F43-0561E0AD8B13}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010100.1.0.001</OS><Architecture>x32</Architecture><PKey>*****-*****-*****-*****-BHVJ4</PKey><PID>00426-067-9119285-86817</PID><PIDType>5</PIDType><SID>S-1-5-21-2256667741-22164857-386030605</SID><SYSTEM><Manufacturer>System manufacturer</Manufacturer><Model>P5Q-E</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>1003   </Version><SMBIOSVersion major="2" minor="5"/><Date>20080709000000.000000+000</Date></BIOS><HWID>81443707018400F8</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Pacific Standard Time(GMT-08:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM/><GANotification><File Name="OGAAddin.dll" Version="2.0.48.0"/></GANotification></MachineData><Software><Office><Result>100</Result><Products><Product GUID="{90120000-0017-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office SharePoint Designer 2007</Name><Ver>12</Ver><Val>27A3A27F3C05EBA</Val><Hash>71y6zj0MhwUg3MQHb11WN39NEAc=</Hash><Pid>89394-861-7746765-63810</Pid><PidType>8</PidType></Product></Products><Applications><App Id="17" Version="12" Result="100"/></Applications></Office></Software></GenuineResults> 

    Spsys.log Content: 0x80070002

    Licensing Data-->

    Software licensing service version: 6.1.7601.17514

    Name: Windows(R) 7, Ultimate edition

    Description: Windows Operating System - Windows(R) 7, RETAIL channel

    Activation ID: a0cde89c-3304-4157-b61c-c8ad785d1fad

    Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f

    Extended PID: 00426-00172-067-911928-00-1033-7600.0000-1762010

    Partial Product Key: BHVJ4

    License Status: Licensed

    Remaining Windows rearm count: 5

    Trusted time: 10/10/2013 11:03:25 PM

    Windows Activation Technologies-->

    HrOffline: 0x00000000

    HrOnline: 0x00000000

    HealthStatus: 0x0000000000000000

    Event Time Stamp: 9:23:2013 04:43

    ActiveX: Registered, Version: 7.1.7600.16395

    Admin Service: Registered, Version: 7.1.7600.16395

    HealthStatus Bitmask Output:

    HWID Data-->

    HWID Hash Current: QgAAAAQABAABAAEAAgAEAAAAAgABAAEA6GE2yBU/PwjqpqcPRryMJoQ0aGX4TPatd/asKZqImAO+pP+iojAWFUbK

    OEM Activation 1.0 Data-->

    N/A

    OEM Activation 2.0 Data-->

    BIOS valid for OA 2.0: yes, but no SLIC table

    Windows marker version: N/A

    OEMID and OEMTableID Consistent: N/A

    BIOS Information:

      ACPI Table Name           OEMID Value     OEMTableID Value

      APIC                                    A_M_I_                               OEMAPIC

      FACP                                   A_M_I_                               OEMFACP

      HPET                                    A_M_I_                               OEMHPET

      MCFG                                 A_M_I_                               OEMMCFG

      OEMB                                 A_M_I_                               AMI_OEM

      OSFR                                   A_M_I_                               OEMOSFR

      SSDT                                    DpgPmm                             CpuPm

    Friday, October 11, 2013 7:23 AM

Answers

All replies