none
MAP toolkit 9.5 not finding all SQL Server instances. RRS feed

  • Question

  • Hi,

    Here's my issue.

    Remote server

    • Microsoft SQL Server 2008 R2 Enterprise Edition (64-bit)
    • Windows 2008R2 Enterprise

    MAP / Local Server

    • Microsoft SQL Server  Server 2014 Express Edition  (x64)
    • Microsoft Windows Server 2012 R2 Datacenter

    Remote server has 5 SQL Server Instances running on it:

    • INST1 - Disabled
    • INST2 - Enabled
    • DEV1 - Enabled
    • DEV2 - Enabled
    • DEV2008_1 – Enabled

    When I run the MAP toolkit 9.5.8.0 from the MAP server, the SQL inventory reports lists only 2 instances (INST1 and INST2) on the server. Why is the report missing some instances?

    MAP optons

    Senario

    • SQL Server
    • SQL Server with Database Details

    Discovery Methods

    • Use Active Directory Domain Services (AD DS)

    Other notes:

    • SQL Browser is running on remote computer
    • Account use to connect to remote computer has local admin on the remote server.

    Hopefully someone can help me otherwise I can’t use the MAP toolkit with confidence.

    Thanks

    Manish


    • Edited by Manish Man Thursday, January 26, 2017 10:58 AM
    • Moved by Olaf HelperMVP Saturday, February 18, 2017 8:10 AM Moved from "Database Engine" to a more related forum for a better response
    Tuesday, January 24, 2017 12:29 PM

All replies

  • The MAP tool has to be run by a domain administrator. Also, there has to be (TCP/IP) ports open on firewall of SQL Servers/instances behind a firewall, otherwise, the MAP tool will not find them.

    On the 'Discovery Methods' page, choose 'Use Active Directory Domain Services (AD DS) AND 'Use Windows networking protocol' as 'methods to use to discovery computers'.

    Hope that helps,


    Phil Streiff, MCDBA, MCITP, MCSA

    Tuesday, January 24, 2017 12:57 PM
  • HI Phil,

    Many thanks for your tips but still no luck.

    - I've run the MAP tool kit as domain admin

    - TCP/IP Ports open for File and Printer Sharing, Remote Administration (RPC) in Windows Firewall Inbound Rules.

    - Selected the Discovery Methods advised.

    The report has been re-run and still only 2/5 instances listed.

    Thanks

    manish

    Tuesday, January 24, 2017 2:06 PM
  • Here's some troubleshooting steps you can try on the remote instances:

    • Open SQL Server Configuration Manager
    • Select SQL Server Network Configuration
    • Chose your instance of a SQL Server
    • Make sure that TCP/IP protocol is enabled
    • Right click TCP/IP protocol
    • Select properties
    • Click IP addresses tab
    • Scroll down to IP4. The IP address of the server should be here. Set active to yes and enabled to yes. Ensure a TCP port is assigned (1433 is default, but other port # is acceptable)
    • Scroll down to IPAll. Set TCP port to assigned port #
    • Make an inbound firewall rule for assigned port # if required
    • open sql server management studio, right click server instance, properties->connections-> allow remote connections. Security-> SQL Server and Windows Authentication mode
    • restart sql server service
    • restart sql server browser

    If you still have issues, check with the MAP Toolkit team for troubleshooting support:
    Using the MAP Toolkit to Discover SQL Server Across the Enterprise

    [Please mark as answer if this post helps you]

    Hope that helps,


    Phil Streiff, MCDBA, MCITP, MCSA

    • Edited by philfactor Tuesday, January 24, 2017 2:26 PM
    Tuesday, January 24, 2017 2:20 PM
  • Hi Manish,

    Since this issue is more related to MAP toolkit, I would suggest you post it in MAP forum for better response.

    If you have any other questions, please let me know.

    Regards,
    Lin

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, January 25, 2017 2:36 AM
  • Thanks Lin. I've now posted in the appropriate forum.
    Thursday, January 26, 2017 10:58 AM
  • Phil. Sadly, the firewall suggestions didn't work.

    I'm going to reinstall MAPS on a different server and re-run.

    Thanks

    Manish

    Thursday, January 26, 2017 11:01 AM