none
Can't access folder or permissions in Windows 7 but I can from XP or Server 2003

    Question

  • Windows 7 Pro 64-bit.

    Trying to access a folder on via a CIFS share on a Netapp file server.

    On my Windows 7 box I get the "You don't have permission to access \\file path.

    If rt-click > properties on the folder > Security Tab I get the "You don't have permission to view or edit this object's permission settings."

    Clearly I do since I am a member of the File Administrators group and a Domain Admin and an Enterprise Admin.

    If I login to an XP or Server 2003 host, I have full access to the folder, the files and can update any and all permissions.  So clearly something is different about my Win 7 host.  I've even tried opening the Windows File Explorer as an Admin, but that made no difference.

    What gives?  How can I fix this? 

    Thank you,

    TedOsh

     


    • Edited by tedosh Thursday, October 20, 2011 3:08 PM
    Tuesday, October 18, 2011 3:20 PM

Answers

  • I finally figured this out.  Sorry, I forgot to post the solution a while back.  Basically I don't know the real reason why this occurred.  I was able to solve this by installing and running CCleaner.  This went through the system and cleaned up a bunch of little know cache's that I wasn't aware of.  After that I was able to view and update the permissions on the Security tab of all my Files and Folders that were being accessed via a CIFS share on my Netapps.  I don't know which item that was cleaned was responsible for causing this problem in the first place.

    Good Luck.


    • Marked as answer by tedosh Tuesday, January 31, 2012 6:52 PM
    • Edited by tedosh Tuesday, January 31, 2012 6:53 PM
    Tuesday, January 31, 2012 6:52 PM

All replies

  • Hi,

     

    Please check the following settings:

     

    1. In windows 7, try Secpol.msc in start box and open Local security policy.

    2. Expand "Local Policies" and select "Security Options"

    3. Locate "Network Security: LAN Manager Authentication Level" in the list and double-click it.

    4. Change the setting from "Send NTMLv2 response only" to "Send LM & NTLM - use NTLMv2 session if negotiated"

    5. Network Security: Minimum session security for NTLM SSP Based (including secure RPC) Clients

    6. Change the setting from "require 128 bit" to unchecked (No Minimum)

    7. Click OK, and exit.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by bvsmette Wednesday, March 19, 2014 7:05 PM
    Thursday, October 20, 2011 3:33 AM
    Moderator
  • Thank you for responding.

    First, the subject of this thread should be "Can't access folder..."  not "Can access folder..."  (I've updated it.)

    Second, I tried your suggestion but it did not work.

    The "Network Security: LAN Manager Authentication Level" was already set to "Send NTMLv2 response only" to "Send LM & NTLM - use NTLMv2 session if negotiated".

    I changed the setting for "Network Security: Minimum session security for NTLM SSP Based (including secure RPC) Clients" to No Minimum, but that did not help either. 

    There is another Admin here that has a Win 7 host but does not have these issues.  I don't know what the difference is between our two boxes that I can't administer file permissions from mine.  This is really annoying as I have to login to a 2003 Term server to do this work.

    I'm open to any other suggestions to help trouble shoot this issue.

    Thank you,

    TedOsh


    • Edited by tedosh Thursday, October 20, 2011 3:08 PM
    Thursday, October 20, 2011 2:38 PM
  • Still looking for some help with this one.  Anyone?

     

    Can't access a CIFS share from my Windows 7 host, but can from an XP or 2003 host.  Getting Access denied based on permissions.  Other admins in my group can access the CIFS share from their Win 7 host.  All Win 7 builds from the same image.  This has got us stumped.

    Thank you,

    -TedOsh

    Friday, October 21, 2011 1:38 PM
  •  

    Hi,

     

    Sorry for the late response, I am looking into this issue, and I would involve someone who is familiar with this kind of issue to help you deal with it together.

     

    This would be some delays. Thank you for your understanding.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, October 24, 2011 8:42 AM
    Moderator
  • Do you have Win7 SP1 yet on the box being used?

    Are you accessing the share using IP or name?

    Paste the entire error and the error code / screenshot.

    What type of kerberos encryption is used on the NAS if any?

     

    Also check the netapp KBs mentioned in this post, if you have access: http://communities.netapp.com/message/35655

    Check if disabling SMB 2.0 resolves the issue.

     

     

     


    Sumesh P - Microsoft Online Community Support
    Monday, October 24, 2011 3:00 PM
    Moderator
  • Now we are getting somewhere...

    Additional Info: If I log into another Win 7 workstation, I don't have a problem.  Appears to be my workstation.

     

    Sumesh - Thank you for your reply.  I tried using the IP address instead of the hostname from my workstation and I did not have a problem.  It appears to be working correctly.  I have access to the folders and the permissions.

    (\\hostname vs. \\10.1.1.1)

    I read the post you mentioned, and it sounds like I have a similar issue, but their fix was to simply to use the IP in their script.  Although it appears that using the IP will work for me, I'm much more interested in getting to the bottom of this issues and fixing it.  I do not want to have to rely on remembering the IP address.

    Here is the exact scenario-

    Open the Windows explorer > Type in address (Ex: \\myfiler).  After the list of shares appear, I double-click on one of the shares to open it and get the following error:

    Network Error
    Windows cannot access \\myfiler\folderShare
    You do not have permissions to access \\myfiler\folderShare.
    Contact your network administrator to request access.

    If I Rt-click on the folder share and go to Properties > Security tab I get the following error:

    Object Name: \\myfiler\folderShare
    
    You do not have permissions to view or edit this object's permission settings.

    The fact that I can access the folders from another Win 7 workstation leads me to think it has something to do with my host.  Could it have something to do with my host object in AD which is causing Kerberos to fail?

     

    Tuesday, October 25, 2011 6:29 PM
  • The fact that it fails only for your workstation makes it more difficult to troubleshoot.

    Can you take a network trace from the working and non working box and upload it. I could compare to see what is different/failing.

     


    Sumesh P - Microsoft Online Community Support
    Wednesday, October 26, 2011 5:32 AM
    Moderator
  • Hi I have the same problem Got a file server on Windows 2003. This server has 2 IP addresses on one network card. When accessing it VIA the one IP, it works fine. But accesing it via the other IP, I get to the folders, but can't access the folders (access denied) I've got this problem on 9 Win7 Laptops and on 2 Windows 2008 servers
    Tuesday, November 29, 2011 11:40 AM
  • I wish I knew myself.  I too have the same problem.  I have read most all of the responses on here, and they either don't apply, or there is no resolution.

    I have also had many other issues with Windows 7 Premium.  This software is ABSOLUTELY JUNK.  You can't tell me Microsoft doesn't know about this DEFECTIVE AND NON WORKING PRODUCT.

    Come on Microsoft, get off your a** and fix this problem.  You have wasted enough of your customers time.

    I would love to see a class action law suit filed against Microsoft, I really would.

    That's my opinion.

    tsab1

    Monday, January 16, 2012 5:16 PM
  • I finally figured this out.  Sorry, I forgot to post the solution a while back.  Basically I don't know the real reason why this occurred.  I was able to solve this by installing and running CCleaner.  This went through the system and cleaned up a bunch of little know cache's that I wasn't aware of.  After that I was able to view and update the permissions on the Security tab of all my Files and Folders that were being accessed via a CIFS share on my Netapps.  I don't know which item that was cleaned was responsible for causing this problem in the first place.

    Good Luck.


    • Marked as answer by tedosh Tuesday, January 31, 2012 6:52 PM
    • Edited by tedosh Tuesday, January 31, 2012 6:53 PM
    Tuesday, January 31, 2012 6:52 PM
  • After going mildly insane, I found a solution that worked for me. I won't promise it will solve everyone's problem, but it may help some of you.

    The problem is that when Win7 'shares' a folder, it DOES NOT add permissions for anyone to actually DO anything with the folder. So the folder will be visible in Network, but users will get the "You do not have permission" message if they try to access it.

    To fix this, pop up Properties for the folder you're trying to share, go to the Security tab (next to Sharing), click Edit, then Add, then type in Everyone in the big "Enter the object names" box. Then in the previous dialog, select Everyone in the top list and tick all the boxes under the Allow column in the bottom list. (You might have to exit Properties and come back again to enable this.) Now 'everyone' on the LAN should be able to access the shared folder without a password.

    You'd think the "Advanced" Sharing dialog would take care of this, but that would be much too simple...

    • Proposed as answer by BluePriest Saturday, July 7, 2012 9:00 PM
    • Unproposed as answer by BluePriest Saturday, July 7, 2012 9:01 PM
    Friday, June 22, 2012 8:29 PM
  • I sort of figured this out. Perhaps the info I gave will help someone come to a better solution.

    Right click on the file

    Go to properties

    Secutiry

    Advanced

    Owner

    Edit

    Chose yourself (or administrators)

    Close out

    Right click the file again

    Sharing

    Specific people

    Add

    Everyone. 

    You can now use that one file.

    This is the problem I am running into though. That only allows that one file, or subfolder to be viewed. anything inside of it, you have to go through the process again. There has to be some way to make it so that you can do a universal change for EVERYTHING (btw, I am making sure apply this change to subfolders and files is checked.) Hope this helps someone find a good starting place. 

    • Proposed as answer by BluePriest Saturday, July 7, 2012 9:00 PM
    Saturday, July 7, 2012 8:57 PM
  • Thank You..

    it works..

    Wednesday, December 31, 2014 6:51 AM

  • You can now use that one file.

    This is the problem I am running into though. That only allows that one file, or subfolder to be viewed. anything inside of it, you have to go through the process again. There has to be some way to make it so that you can do a universal change for EVERYTHING



    Tuesday, May 9, 2017 10:57 AM