none
DPM 2010 backup on tape fails RRS feed

  • Question

  • hi,

    I have installed DPM 2010 with disk for short term retention and tape for long term retention for Exchange 2010 databases.

    I have only 4 databases, out of which 3 database tape are successfull and 1 fails, with this error, though disk backup is working fine,with only One Protection Group.

    "Failed to perform the operation since the tape free tape is not available in Stand Alone Drive Tape Library Hewlett Packard LTO Ultrium-2 drive (ID 24050)"


    Regards, Kiran B.
    Sunday, September 19, 2010 1:30 PM

Answers

  • Hi,

    Go ahead and add the key anyways, it will not hurt anything.

    You can also try this registry entry:

    Save the below in notepad then save as BufferQ.REG on the DPM server.
    Right-click BufferQ.REG and choose the "merge" option.


    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent]
    "BufferQueueSize"=dword:00000002

    If that adding the above two registry keys do not help, please read this thread for other troubleshooting ideas including using mct-x64.exe utility to test filling a tape.

    http://social.technet.microsoft.com/Forums/en-US/dpmtapebackuprecovery/thread/e718e8e6-c0d6-496e-9407-ea1ccf51bb98

     

     


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Sunday, September 19, 2010 4:43 PM
    Moderator

All replies

  • Hi,

    Please add this registry key and try the backup again:

    http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=110&prodSeriesId=254838&prodTypeId=12169&prodSeriesId=254838&objectID=c01655150

     

    How much data is written to the tape before the backup job fails ?  If the tape really is full, then you can adjust the timeout that DPM will wait for a new tape.  During a tape backup if a tape becomes full and there are no other tapes marked free, Free (contains data) or expired in the library, DPM will raise an alert to prompt for another free tape to continue backup. It will wait for 1 hour by default before failing the job.

     

    This prompting timeout can be configured by the registry entry “PromptingTimeOut” under “HKLM\Software\Microsoft\Microsoft Data Protection Manager\1.0\Prompting”

    PromptingTimeOut:REG_Dword:43200000  (dec) = 12hrs


    The Formula is   (#hrs * 1000 * 60 * 60)

    1HR =  1*1000*60*60 =  3600000  decimal


    So for each hour to wait, multiply by 3600000.

    8hrs = 28800000  decimal

     

     


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Sunday, September 19, 2010 3:04 PM
    Moderator
  • Hi Mike,

    thanks for the quick response...

    tape is of 400 gb only 160 gb of data is written.

    also the link is talking about lto3 coz, we are using LTO2


    Regards, Kiran B.
    Sunday, September 19, 2010 3:56 PM
  • Hi,

    Go ahead and add the key anyways, it will not hurt anything.

    You can also try this registry entry:

    Save the below in notepad then save as BufferQ.REG on the DPM server.
    Right-click BufferQ.REG and choose the "merge" option.


    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent]
    "BufferQueueSize"=dword:00000002

    If that adding the above two registry keys do not help, please read this thread for other troubleshooting ideas including using mct-x64.exe utility to test filling a tape.

    http://social.technet.microsoft.com/Forums/en-US/dpmtapebackuprecovery/thread/e718e8e6-c0d6-496e-9407-ea1ccf51bb98

     

     


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Sunday, September 19, 2010 4:43 PM
    Moderator
  • Hi Kiran, 

    I am proposing the above as answer. feel free to reopen the thread, if the solution doesnt works for you.

     

    thanks,

    Parag Agrawal 

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, September 20, 2010 9:30 AM
    Moderator