locked
Color dialog prevents third digit input in RGB text boxes ? RRS feed

  • Question

  • Hello,

    Running windows 7 Pro 64bit.
    GUI - classic theme, 108 dpi.

    I was allways using some solid custom color for my background. So I tried to select it using Personalize.... custom color dialog. It's standard color dialog present on all windows versions. One of the ways to enter exact color is 3 text boxes(Red Green Blue) with value ranges 0-255. If I try to enter third digit it beeps and input is denied - similar bahaviour if I would try to enter out of range value like 256. But it denies whatever third digit ! It's imposible to enter 100 and so on !  This behaviuor is common to all apps using color dialog - not only background change.

    Is this a bug ?
    How do I resolve this ?

    thanks
    Vilius
    Friday, February 12, 2010 6:14 AM

All replies

  • Hi,

    On my PC, it works fine. I can customize it with value ranges 0-255. This is not a bug.

    What is the model of your display card? Make sure all the drivers are up to date and compatible with Win7.

    At this point, in case it is caused due to corrupt user profile, create a new user profile as a test.





    Friday, February 12, 2010 9:52 AM
  • Hi,

    I believe issue shows only on certain circumstances - can you confirm that your color dialog works ok using classic theme and 108 dpi ?

    V
    Friday, February 12, 2010 10:23 AM
  • Yes, I still can ajust the num as I want with classic theme and 108 dpi
    Thursday, February 18, 2010 3:27 AM
  • Hi,

    As this issue occur randomly, I think certain third party software running background may cause conflict. The next time this issue reoccurs, you can try clean boot to troubleshoot this issue.

    This method will help us determine if this issue is caused by a loading program or service. Refer to http://support.microsoft.com/kb/929135
    ===============
    1. Click the Start Button and type "msconfig" (without quotation marks) in the Search Box and press Enter.
    2. Click Continue to verify the permission.
    3. Select the Services tab in the open window. Check the “Hide all Microsoft Services” option and click Disable All.
    4. Switch to the Startup tab and click Disable All.
    5. Click OK to save the settings and select Restart when prompted.
    6. Check whether or not the issue still occurs.

    Note: Temporarily disabling the Startup Group only prevents the startup programs from loading at startup. This shouldn't adversely affect the system or other programs. We can still manually run these programs later. 

    Friday, February 19, 2010 3:02 AM
  • It is a bug Vilius, and it's been around since Windows 2000! If your DPI is set to anything other than the standard (96), the common dialog color picker will only allow 2 digits to be entered manually. And the most annoying thing is that it would be a really simple fix for Microsoft: the entry boxes just need to be made wider. I got around this on my last XP machine by using a resource hacker to widen the boxes and booted to a recovery CD to replace the system file. I couldn't tell you whether that method would work on a W7 machine though.

    See here:
    http://www.tech-recipes.com/rx/3409/fix-windows-xp-choose-color-dialog-only-allows-2-digits-not-3/
    • Edited by Antagony1960 Friday, February 26, 2010 4:15 PM Added link
    Friday, February 26, 2010 4:09 PM