locked
SFB Server-side conversation history RRS feed

  • Question

  • Hi all,

    so then I successfully did an in place upgrade to SFB2015. All went well, but some few questions regarding Server-side conversation history.

    On the mobile client(Android only tested so far) this function does not work. If I chat in mobile client it doesn't show up in conversation history and on desktop client it is not shown in recent either.

    How is this function supposed to work, should it be updated on both Recent AND Conversation history in Outlook on both desktop and mobile client?

    On the mobile client, does it work with built in ActiveSync client or does it have to be Outlook app?

    As of now I have tested both ways(mobile and desktop) and they still don't sync. On mobile I use built in activesync and latest SFB client.

    On desktop I use latest patch of Office2016.

    what about MAC users, will it work there with latest Office version?

    thanks!


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Sunday, January 24, 2016 9:55 AM

Answers

  • Then its confirmed from MS. It is a known bug in latest Mobile client (IOS,Android and Windows mobile).

    This is only if you have mailbox in Exchange Online and SFB homed on-prem. Mobile client will get an update with fix early March.

    After all these troubleshooting!


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    • Marked as answer by Off2work Tuesday, February 23, 2016 2:21 PM
    Tuesday, February 23, 2016 2:21 PM

All replies

  • Hi Off2work,

     

    The process of configuring SSCH.

    1. Configuring Skype for Business Server 2015 to be a Partner Application for Exchange 2013

    C:\Program Files\Microsoft\Exchange Server\V15\Scripts\Configure-EnterprisePartnerApplication.ps1 -AuthMetaDataUrl 'https://Lync.domain.com/metadata/json/1' -ApplicationType Lync

        

    After configuring the partner application it is recommended that you stop and restart Internet Information Services (IIS) on your Exchange mailbox and client access servers.

    IISReset

     

    2. Configuring Exchange 2013 to be a Partner Application for Skype for Business Server 2015

    New-CsPartnerApplication -Identity Exchange -ApplicationTrustLevel Full -MetadataUrl "https://autodiscover.domain.com/autodiscover/metadata/json/1"

     

    3. Configuring Exchange Autodiscover Url.

    Get-ClientAccessServer | Set-ClientAccessServer -AutoDiscoverInternalUri "https://autodiscover.domain.com/autodiscover/autodiscover.xml"

    Set-CsOAuthConfiguration -Identity Global -ExchangeAutodiscoverUrl "https://autodiscover.domain.com/autodiscover/autodiscover.svc"

    Verify replication status and restart SFB services.

    4. Test Exchange Connectivity to ensure it configure and working correctly.

    Test-CsExStorageConnectivity -SipUri LyncUser1@domain.com


     

    5. Enable Server Side Conversation History

    Set-ConversationHistoryConfiguration -EnableServerConversationHistory $true -Verbose

    Set-CsClient -Identity Global -EnableServerConversationHistory $true -DisableSavingIM $false -Verbose

     

    6. Configuring Mobile Policy.

    Set-CsMobilityPolicy –AllowSaveIMHistory $true

     

     

    Please note that, in order to leverage this feature, users must be homed on Skype for Business Server 2015 and users must have a mailbox homed on Exchange 2013 or later version (either on premise or online).

    Moreover, make sure all your servers are up-to-date.

     

     

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    • Edited by Eric_YangK Sunday, January 24, 2016 1:50 PM
    • Proposed as answer by Liinus Sunday, January 24, 2016 3:28 PM
    Sunday, January 24, 2016 1:18 PM
  • Hi Eric and thanks for reply.

    step 1-6 checked and it was already configured.

    I guess you mean set-csconversationhistoryconfiguration and set-csclientpolicy instead?

    I forgot to mention that we have all our mailboxes in Exchange Online, does it require different configuration maybe?

    thanks!

    EDIT:

    I got error wen run test-csexstorageconnectivity. Googled the error and I came here: http://blog.schertz.name/2015/09/exchange-and-skype-for-business-integration/

    Followed his steps, but all is good on our side and everything is according to him. Further down he says if get error "code=50043," then he redirects to another link saying I'm not member of RTCUniversalUserAdmins which offcourse I am.

    I then login to OWA to check if IM works (worked before in place upgrade to SFB2015) and now I get error: Theres a problem with instant messaging. Please try again later.

    I guess this is related to trusted application in SFB.

    During migration, I migrated both mail servers from 2013 pool  to SFB2015 pool. Now I have deleted them and added them back without any help.

    Where can I troubleshoot next?

    Thanks!


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work


    • Edited by Off2work Sunday, January 24, 2016 9:30 PM added
    Sunday, January 24, 2016 8:42 PM
  • So I went the hard way and removed trust between SFB and Exchange 2013. Then I started from scratch and re-created the trust (both ways).

    Still I have same issue, Test-CsExStorageConnectivity -SipUri LyncUser1@domain.com failed with error 50043 or so. Google says its wrong autodiscover, which is wrong since I can browse both metadata/json/1 without any certificate issue either.

    What more can I do to troubleshoot further? Already opened ticket with MS support,but they haven't responded yet.

    thanks! 


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Tuesday, January 26, 2016 11:29 PM
  • Hi Off2work,

    Have you performed  step 3 ?

    3. Configuring Exchange Autodiscover Url.

    Get-ClientAccessServer | Set-ClientAccessServer -AutoDiscoverInternalUri "https://autodiscover.domain.com/autodiscover/autodiscover.xml"

    Set-CsOAuthConfiguration -Identity Global -ExchangeAutodiscoverUrl "https://autodiscover.domain.com/autodiscover/autodiscover.svc"

     

    Verify replication status and restart SFB services.

     

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    • Edited by Eric_YangK Wednesday, January 27, 2016 1:30 AM
    Wednesday, January 27, 2016 1:29 AM
  • Yes it has been done. They can also be browsed without any error.

    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Wednesday, January 27, 2016 9:34 AM
  • Is there a way to verify that the default OAuth certificate is still valid? Other than the there is OK check mark next to it and that it is not expired.

    I want to renew it, but not sure if it will cause any more damage to the environment.

    Thanks!


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work


    • Edited by Off2work Wednesday, January 27, 2016 10:54 AM Edit
    Wednesday, January 27, 2016 10:53 AM
  • Hi Off2work,

    As for IM in OWA, please check if you have configured these settings.

    https://technet.microsoft.com/en-us/library/hh533880.aspx?f=255&MSPPError=-2147217396

    You can run "Get-CsCertificate" command to get the details of the certificate.

    Get-CsCertificate -Type OAuthTokenIssuer

    And since you have Skype for Business on premises and Exchange Online, it seems you have to obtain a security token from a third-party token server.

    From https://technet.microsoft.com/en-us/library/jj204817.aspx

    "For the Office 365 version of Skype for Business Server to communicate with its Exchange counterpart, Skype for Business Server 2015 must first obtain a security token from the authorization server. Skype for Business Server then uses that security token to identify itself to Exchange. The Office 365 version of Exchange must go through the same process in order to communicate with Skype for Business Server 2015.

    However, for on-premises server-to-server authentication between two Microsoft servers there is no need to use a third-party token server. Server products such as Skype for Business Server 2015 and Exchange 2013 have a built-in token server that can be used for authentication purposes with other Microsoft servers (such as SharePoint Server) that support server-to-server authentication. For example, Skype for Business Server 2015 can issue and sign a security token by itself, then use that token to communicate with Exchange 2013. In a case like this, there is no need for a third-party token server."

     

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, January 27, 2016 2:09 PM
  • Hi Eric and thanks for your followup!

    Yes steps in the link you provided have been done before, since it all was working well before in place upgrade.

    Even after hand I check that its still there. I have even re-created Hostingprovider without any help. Oauth token is there as well, since this is one of the requirements during 2013 server deployment. Here I also re-created the OAuth token and checked that it is replicated to all FrontEnd servers but still no help.

    Off course whole Skype AND Exchange  environment have been rebooted without any help.

    At the moment I'm stuck at the part (like from beginning of the issue) that Test-CsExStorageConnectivity fails with error 50043. Yes also tested on multiple accounts with same error.

    According to the internet, it says autodiscover url is wrong. This I have checked many times, and both urls can be browsed from both servers without any error (not even certificate error).

    Last nite I went thru all the steps you provided, removed everything and re-created everything from scratch. Offcourse this did not help either.

    Compared all settings to my HomeLab, and only difference is that Test-CsExStorageConnectivity is success and Server side conversation history is working :D

    I have a case with Microsoft, they also have checked thru alle these settings, but they don't focus on the issue regarding to Test-CsExStorageConnectivity failing. In the last mail I asked them if this fails, can still serverside conversation still work?

    I'm looking thru this article (since IM in OWA also stopped working after in place upgrade): https://technet.microsoft.com/en-us/library/jj688055.aspx?f=255&MSPPError=-2147217396

    "Note, too that the value assigned to IMServerName is the fully qualified domain name of the Skype for Business Server pool where you created the trusted application pool for Outlook Web App.

    The certificate that you use for Outlook Web App must be a certificate that is trusted by Skype for Business Server. One way to ensure that the certificate will be trusted by both Skype for Business Server and Exchange is to use your internal certificate authority to create a certificate on the mailbox server, making sure that the server FQDN is used for the subject name and that this FQDN appears in the certificate alternate name field. After the certificate has been created it can then be imported to your backend servers. The net result is that the same certificate is used for two purposes: 1) communication between Exchange unified messaging and Skype for Business Server; and, 2) the integration between Outlook Web App and Skype for Business Server."

    Here we use 3rd part certificate from GoDaddy and it does not have FQDN of the mail server in subject or SAN name.

    Will be my last try tomorrow, but not sure this will resolve Test-CsExStorageConnectivity issue I'm having.


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Wednesday, January 27, 2016 7:27 PM
  • I have no done another test and if I create local mailbox with Skype account Test-CsExStorageConnectivity is the success.

    It only fails if mailbox is in the Cloud.

    So Microsoft support threw in the towel and said they cannot do anything since this is Exchange Online issue!

    I told them why have this worked before until we did in place upgrade, they could not answer and just closed the case!

    Its a shame Microsoft play this ping pong show with their customers. I don't understand why Lync/Skype support don't know how to configure this with Exchange online?

    I have contacted Exchange Online support, and I'm certain they will tell me to contact Skype support.

    I am really disappointed over Microsoft ! Now I have only TechNet and google to help me out.


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Thursday, January 28, 2016 7:07 PM
  • Hi Eric,

    now I think I'm on tosomething. Today when I started Outlook it asked me to acceptcertificate for mail.domain.com/.../autodiscover.xml<o:p></o:p>

    On top it was related to a test Group I created in Office365. This is a In Cloud Only Group,so it is not synced back to On-prem AD or Exchange. Prior creating this test group I have never got any popup to accept certificate.<o:p></o:p>

    On our Exchange server our autodiscover is set to use autodiscover.domain.com and NOTmail.domain.com.<o:p></o:p>

    If I run
    Get-IntraOrganizationConfiguration, I get :<o:p></o:p>

    OnlineDiscoveryEndpoint
                        :<o:p></o:p>

    OnlineTargetAddress
                         
      :<o:p></o:p>

    OnPremiseTargetAddresses
                       : {}<o:p></o:p>

    OnPremiseDiscoveryEndpoint
                     : mail.domain.com/.../autodiscover.svc<o:p></o:p>

    OnPremiseWebServiceEndpoint
                    : mail.domain.com/.../Exchange.asmx<o:p></o:p>

    DeploymentIsCompleteIOCReady
                   : True<o:p></o:p>

    HasNonIOCReadyExchangeCASServerVersions
        : False<o:p></o:p>

    HasNonIOCReadyExchangeMailboxServerVersions
    : False<o:p></o:p>

    Could this be
    the reason Test-CsExStorageConnectivity -SipUri user@domain.com
    fails for Exchange Online users and not On-prem mailbox users?<o:p></o:p>

    If we change it to use autodiscover on both values, will it cause any issues?<o:p></o:p>


    One step closer!


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Friday, January 29, 2016 5:43 PM
  • Hi Off2work,

    Check this, perhaps it would be useful.

    https://ahandyblog.wordpress.com/2015/12/02/configure-lyncsfb-with-office-365-for-server-to-server-authentication/

     

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Sunday, January 31, 2016 8:07 AM
  • Hi Eric and thanks for reply. Did a walkthrough of the guide, but sad to say it is still not working.

    CS-Oauthserver was already correct, so I recreated partner application to use oauth server.

    Still I get LS storage service error 32054 in event ID when I run test-csexstorageconnectivity of my Exchange online user. Local mailbox works fine.

    Strange part is that event ID still pointed to

    https://autodiscover.domain.com/autodiscover/autodiscover.svc

    , even it should use oauthserver instead.

    If I run get-csoauthconfiguration I see ExchangeAutodiscoverUrl is

    https://mail.domain.com/autodiscover/autodiscover.svc

    Which is same setting on both my exchange servers.

    Then I run Set-csoauthconfiguration -ExchangeAutodiscoverUrl $null and confirmed it has no value. Then run test-csexstorageconnectivity and it is still failing with Online mailboxes. Only local mailbox is working fine.

    Which  ExchangeAutodiscoverUrl in Set-csoauthconfiguration should be used for Exchange online mailboxes?

    At least I got IM In OWA to work, just had to recreate everything but create as pool with multiple servers instead.

    At least I learned a lot during this troubleshooting ! :D


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Sunday, January 31, 2016 6:45 PM
  • Hi again Eric,

    so I played hard and did a SFB hybrid thru powershell (since it failed using wizard from SFB control panel).

    I migrated my account to SFB Online and now serverside conversation history (also recent items) is working on mobile client.

    Test-csexstorageconnectivity still fails, but Serverside conversation history is working.

    Users with Exchange Online mailbox and Skype On-prem it is not working

    Users with Exchange On-prem and SFB Onm-prem it is working.

    Doesn't seem like Exchange Online is working well with SFB On-prem!


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Monday, February 1, 2016 1:56 PM
  • Have you figured this out yet? I am having the same issue between my SfB on premise and Exchange Online. I'm not running the most current cumulative updates for SfB yet, but I'm not sure if that would even help.
    Thursday, February 4, 2016 4:04 AM
  • Hi,

    no still working on the issue. On-prem mailbox and on-prem skype works.

    Online mailbox and online skype works.

    Online Mailbox and on-prem skype is no go. The other way is no go either.

    Latest CU wont help, and it might cause Hybrid config wizard from SKype control panel to fail.

    Created case with SFB support, but they say nothing they can do since it works if both mailbox and Skype is on-prem!

    Shame on them. Havent got time to troubleshoot this lately, cause my work pile is piling up. Will have more look at it in the weekend and get back if any success!


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Friday, February 5, 2016 9:00 AM
  • Update from MS tech is that this is known issue for IOS clients. They are working on a fix in future update.

    Windows and Android still waiting for status


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Monday, February 22, 2016 2:44 PM
  • Then its confirmed from MS. It is a known bug in latest Mobile client (IOS,Android and Windows mobile).

    This is only if you have mailbox in Exchange Online and SFB homed on-prem. Mobile client will get an update with fix early March.

    After all these troubleshooting!


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    • Marked as answer by Off2work Tuesday, February 23, 2016 2:21 PM
    Tuesday, February 23, 2016 2:21 PM
  • FYI Eric,

    Then its confirmed from MS. It is a known bug in latest Mobile client (IOS,Android and Windows mobile).

    This is only if you have mailbox in Exchange Online and SFB homed on-prem. Mobile client will get an update with fix early March.

    After all these troubleshooting! :D


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Tuesday, February 23, 2016 2:22 PM
  • Hello,

    Did you ever solve your issue implementing Server Side Conversation History in this hybrid scenario ?

    Because I confirm this is a working scenario. I have a customer running SfB on-prem and Exchange Online through Office 365 and I make it work like a charm on both Android and iPhone :)

    Although I faced a small problem related to the SMTP address of the user on Active Directory. I solve it manually and I wrote a blog article about that.

    But this is for sure : Test-CsExStorageConnectivity MUST result in "Test passed". Without this, SSCH won't work.

    Wednesday, October 19, 2016 2:04 PM
  • Hi Jaafar and thanks for your reply.

    For us it is still not working in hybrid (Mailbox online, SFB on-premise). If both SFB and mailbox is on-premise it works. If both online it works.

    I have read your post, but test account has both sip and smtp in proxyaddress field.

    If you run get-partnerapplication on your exchange server, is Lyncenterprose one has Useauthserver set to true?

    Which mobile client and os did you test on and the version?

    thanks!


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Thursday, October 20, 2016 8:43 AM