locked
WSUS 10 on Server 2016 & SQL Server 2008 Compatibility Level RRS feed

  • Question

  • I'm running WSUS version 10.0.14393.0 on Windows Server 2016.  The WSUS database is on a remote SQL Server 2016 cluster. 

    Our database administrator indicates that the compatibility level for the WSUS database (SUSDB) was set to "SQL Server 2008 (100)" during the WSUS installation.  This compatibility level is the oldest supported setting in SQL Server 2016.  The Data Migration Assistant analysis indicates there is old style JOIN syntax in a few stored procedures, which is outdated and non-ANSI compliant code.

    I'd like to change the compatibility level for SUSDB to something newer, but this deprecated syntax is preventing us from doing this (I think, at least).  Has anybody found a way to update the syntax?  Should I just ignore the stored procedures that use the deprecated syntax and simply update the compatibility level?

    Thursday, May 4, 2017 6:30 PM

All replies