locked
Samsung Vista GDI driver install crashes Win 7 RRS feed

  • Question

  • I have a nice Samsung ML4500. Not that new, but then I don't use my printer very much. But it is useful at times. 

    So... I have the Vista ML4500 GDI driver installation package for it. I run it by right clicking in compatibility mode.

    I've done this three times now. The first two times, it crashed my machine dead as soon as the Samsung splash screen appeared. Video broke up, screen blanked and then only a hard reset fixed it.

    Third time, despite same compatibility mode operation, the Samsung installer just tells me that the driver is incompatible with this version of windows.

    Unfortunately, since it's a prepacked installation in an exe file, I can't get at any of the real files, inf, sys etc to see if I can by pass the installer's front end.

    I've also tried the Vista GDI drivers for other similiar models, which give me similar results.

     

    If anyone has any ideas on how to resolve this, other than approaching Samsung which I think is likely to prove unproductive, I'd love to hear from them!

     

    Edit: now, from another post, realised how I can unpack the driver set from the installer. I've done this, but the raw setup.exe still crashes win 7...  I've now also tried the right click on the inf file in the Vista 64 subdir of the install package, but it tells me this method of installation is unsupported.

    Wednesday, January 28, 2009 9:30 AM

Answers

  • I thought I would update this thread, because I have fixed this problem though in a rather peculiar manner.

    The INF file in the GDI Vista 64 directory would not install on a right click, 'installation method unsupported' as I noted before.

    So I experimented by installing a non-existent local ML series printer on my networked laptop running XP.

    Then I told Win 7 to find this on my network. It found it and eventually decided it didn't have any drivers. Then I used 'Have disk' to point back at the INF file that Win 7 had told me it couldn't use. It used it and installed the network printer. Then I changed this back to use LPT1 instead of the network location....And it works now. I don't understand why Win 7 told me on a right click of the INF that it couldn't do the install, when it clearly actually could, and has.  Probably permissions somewhere?

    At any rate, I now have a working ML4500 printer, so that is great!

    Wednesday, January 28, 2009 4:49 PM