locked
Open File on FTP Site Shows Wrong Link with Windows 7 RRS feed

  • Question

  • I have a client I installed Windows 7 Pro 64 bit.  She is complaining that when she is in her FTP site through Explorer and she opens a file on the FTP site, she is getting some file:///c:.... link showing in her browser not the original link of the file from the ftp site.

    This seems to be an issue in Windows 7 only because when this is done on Windows Vista or XP, she gets the original link showing of the file through the browser.

    Does anyone have this issue with the interface of Windows 7.  I know because I tested it with the different versions IE's on Windows 7 and it does the same thing.  I went to Vista and XP and it works differently.


    Bryan
    Tuesday, April 19, 2011 2:56 PM

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    Please refer to this blog to check on the registry values.

     

    Best Regards

    Magon Liu

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, April 20, 2011 9:30 AM
  • Thanks so much... I'm going to try this on the client and let you know if it works.  Thanks.
    Bryan
    Wednesday, April 20, 2011 4:58 PM
  • I went ahead and tried the suggestion from the blog but what I found is that the file now is opened in the default program it's supposed to open in.  It doesn't open in iexplorer like before.  I need to be able to open the file, have it open in iexplorer and then be able to copy the url.  As stated before the url is wrong when it is opened.  It's showing a c location not the original ftp location like it used to in Vista.
    Bryan
    Thursday, April 21, 2011 12:32 AM
  • Hi,

    Please make sure you are running Windows 7 SP1.

    Regards,

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, April 22, 2011 12:32 PM
  • Hi,

     

     

    How is it going? I would appreciate it if you could drop me a note to let me know the status of the issue. If you have any questions or concerns, please feel free to let me know. I am happy to be of further assistance.  :)

     

    Best Regards

    Magon Liu

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, April 26, 2011 10:42 AM
  • Magon,

     

    I went ahead and checked the Service packs and found that the system is on SP1 for Windows 7.  The status is the same.  As described, the files are being open in a browser with a C location vs the ftp location.  I've confirmed this to be the behavior on all Windows 7 machines I've played with.  I looked on about 4 of them.  Al the vista machines are working as designed and show the url link of the ftp site.  This is regardless of the browser they are using.  I strongly believe it is a Windows 7 behavior.


    Bryan
    Tuesday, April 26, 2011 2:11 PM
  • Hi,

    Have you found this issue on another Windows 7 operating system?

    Please try the following to check the result:

    1.  Start Internet Explorer. 
    2.  Click Tools , and then click Internet Options . 
    3.  Click the Advanced tab. 
    4.  Under Browsing , Click to select the Enable FTP folder view, check box, and then click OK . 
    5.  In Windows Explorer, enter the URL of the FTP site, and then press ENTER . 

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, April 27, 2011 6:50 AM
  • Hi,

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios. If the issue still persists, please feel free to  reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

    BTW,  we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.

     

    Best Regards

    Magon Liu

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, May 6, 2011 2:52 AM
  • Yes,

     

    I have found that this is consitent throughout multiple windows 7 machines.  Open an ftp site on vista and then open it on windows 7 through Explorer.  Double click on a .jpg file and you'll see the difference.  Look at the URL location in the browser.  At this point, I think we're shooting in dark.  There has been a change to the way Microsoft is conducting opening files on sites where they do not want to use the original site location at the URL as they did in previous operating systems.  And yes I've done the change as you specified and there is still the issue.


    Bryan
    Friday, May 6, 2011 4:39 AM
  • Previously, you could save back to the location because the URL was referenced properly.  Now you same to a temp file somewhere.

    Bryan
    Friday, May 6, 2011 4:41 AM
  • No answer...
    Bryan
    Friday, May 6, 2011 4:42 AM
  • Hi Bryan,

    Is derosnec's workaround acceptable?

    @derosnec, thank you for your detailed explanation.

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, May 9, 2011 3:04 AM