none
SQL 2012 Compatibility Level for FIMSynchronizationService db RRS feed

  • Question

  • I note that FIM 2010 R2 deploys its SQL database to a 2012 SQL server in 2008 compatibility level.  A customer is asking if the level can be upgraded to 2012.  I am unable to find any documentation to say if this is supported or unsupported, and am curious as to why the database isn't installed to 2012 level by default anyway.  

    This post on the Server & Cloud blog lists supported platforms, but doesn't mention compatibility level.

    Can anyone please advise?  Thanks.


    Bob Bradley (FIMBob @ TheFIMTeam.com) ... now using FIM Event Broker for just-in-time delivery of FIM 2010 policy via the sync engine, and continuous compliance for FIM

    Thursday, September 18, 2014 3:24 AM

Answers

  • Thanks to Andreas from the FIM product group who has just advised the following (paraphrased):

    "Yes, it is supported to change the compatibility level. It is set to 2008 (used to be 2005 in FIM2010) and is believed to have been like this since MIIS2003.  The compatibility level is set to the lowest we can support."


    Bob Bradley (FIMBob @ TheFIMTeam.com) ... now using FIM Event Broker for just-in-time delivery of FIM 2010 policy via the sync engine, and continuous compliance for FIM

    • Marked as answer by UNIFYBobMVP Tuesday, September 23, 2014 12:27 AM
    Tuesday, September 23, 2014 12:27 AM