none
Upgraded to IE9 and now it's forcing SSL when not needed and causes site to timeout loading. RRS feed

  • Question

  • I've found that when our users take a laptop home, connect to our corporate network (which requires SSL) everything works fine. However, if they bring this device back to work and connect it will timeout. A network trace shows that IE is requesting 443 traffic, the problem is that we do not have SSL enabled on our internal site AND the url we are using in IE is simply http:// .

    The fix so far is to reset IE settings, including "Delete Personal Settings". Further research shows that this reset is working because there is a file in the temporary internet files \ Content.IE5 \ XXXX \ site_domain_com[1] that needs to be removed. This file is literally has the underscores and is empty, as in zero bytes.  It seems IE is using this file as a "connection reference" and will not connect to this site without SSL until this file is deleted. I can manually type the correct url in IE and it will time out even though the site is up and working fine. If I simply delete this file and refresh the page it loads fine.

    I have noticed that if I have my default page http://SITE and launch IE in this "failed" state you can actually see the "https://SITE" appear for about 1 second and then switch back to "http://" and time out. Again a wire trace shows this behavior as well, IE "thinks" no matter what I do us SSL on this domain period because that's what was used before as we have this file in the temp files path.

    Is there a way to tell IE to actually use http:// on a site that last connected via https://. This is causing users to call in tickets as they get to work and access our internal site until the temp files are deleted and then it will happen again if they connect from offsite and are forced over to SSL, creating this file and then not able to get in when back on our network.

    Thanks for any help!

    Tuesday, March 4, 2014 1:16 PM

Answers

  • Delete browser history options, Ctrl+Shift+Delete

    Uncheck the top box and anything else you want to save cookies.../ Delete.

    Unchecking the top box will delete that information making ie pull up the wrong preference,

    Then Alt+TO check the box to delete browser history on exit/ Apply and Okay.


    • Edited by ThrashZone Tuesday, March 4, 2014 4:20 PM
    • Marked as answer by JdoubleUs Wednesday, March 5, 2014 12:26 PM
    Tuesday, March 4, 2014 4:19 PM

All replies

  • Delete browser history options, Ctrl+Shift+Delete

    Uncheck the top box and anything else you want to save cookies.../ Delete.

    Unchecking the top box will delete that information making ie pull up the wrong preference,

    Then Alt+TO check the box to delete browser history on exit/ Apply and Okay.


    • Edited by ThrashZone Tuesday, March 4, 2014 4:20 PM
    • Marked as answer by JdoubleUs Wednesday, March 5, 2014 12:26 PM
    Tuesday, March 4, 2014 4:19 PM
  • Thanks ThrashZone! I fear I know the answer, but is there anyway to limit the delete on exit to a select domain or site? What you are saying works, but it's kind of using a big sledge hammer to get the job done.  I'm not sure we want to have ALL our history wiped out but we may not have any further options I suppose. Also I'm assuming this can all be set via GPO, I'll look into that next.
    Tuesday, March 4, 2014 5:07 PM
  • None that I know of,

    The top section has always been a problematic cache of garbage,

    In ie10 and 11 Microsoft added a new section to delete browser history settings named Cache and databases which a user can uncheck the option but it doesn't seem to help any but I still uncheck it to keep the garbage from piling up so there is less conflicts collected,

    Thanks for the update,

    I'm sure a more experienced user will appear sooner or later that can help out,

    Cheers.

    These are not History they are only Premature preferences that ie pulls out it's bum :)



    • Edited by ThrashZone Tuesday, March 4, 2014 5:35 PM
    Tuesday, March 4, 2014 5:31 PM