locked
Handling permissions in master page webpart RRS feed

  • Question

  • Hi,

     

    I  have a webpart included in the master page.. The webpart is not visible to the users with the read permission. The webpart which i add does not have any inbuilt permissions.  Can any suggest a better solution to this problem. 

     

     


    - Padmaraj.
    Monday, December 13, 2010 5:38 PM

Answers

  • Hi Padmaraj,

    Please try to add Target Audiences for this web part.

    Open the page with SPD > double click the web part. The set Target Audiences for the web part under Advanced option.

    Hope it could help.


    Best regards. Emir
    • Marked as answer by Lily Wu Friday, December 24, 2010 1:24 AM
    Wednesday, December 15, 2010 5:45 AM
  • Have you checked-in and published your page? The page might still be in "edit" mode, visible by you.
    Living the SharePoint dream...
    • Marked as answer by Lily Wu Friday, December 24, 2010 1:24 AM
    Wednesday, December 15, 2010 2:25 PM

All replies

  • Hi Padmaraj,

    Please try to add Target Audiences for this web part.

    Open the page with SPD > double click the web part. The set Target Audiences for the web part under Advanced option.

    Hope it could help.


    Best regards. Emir
    • Marked as answer by Lily Wu Friday, December 24, 2010 1:24 AM
    Wednesday, December 15, 2010 5:45 AM
  • Have you checked-in and published your page? The page might still be in "edit" mode, visible by you.
    Living the SharePoint dream...
    • Marked as answer by Lily Wu Friday, December 24, 2010 1:24 AM
    Wednesday, December 15, 2010 2:25 PM