Remote Desktop can't connect to the remote computer RRS feed

  • Question

  • Not sure if its just a computer issue.  

    We have set up a Dell Poweredge T310 Windows 2008 R2 with terminal server and two per device terminal server license.  We have static'ed the ip of the server and forwarded the port 3389 on the router and set up with a dyndns account. 

    On any number of computers from multiple locations with both Win7 and Xp I have connected with Remote Desktop no problem. 

    With one particular Win7 laptop we only get the "Remote Desktop can't connect to the remote computer" error. 

    Could this be a licensing or config issue on the server?  Would I get this error at all if it was a server licensing or config error?  It seems to me if its only one particular laptop having the issues it must be the laptop right?

    I have tried turning off the laptops Windows firewall, but it made no difference.  I would guess there is something like a firewall on the laptop blocking, but I can't figure it out. 

    Monday, January 24, 2011 6:33 PM


All replies

  • Hi,

    Can you reach the RDS server from the laptop? (i.e. using ping ip or ping fqdn)
    Can you telnet the RDS server from the laptop? (i.e. telnet ip 3389 of telnet fqdn 3389)
    If you are using a DNS name to connect, can the laptop resolve it (using nslookup)
    Does the eventlog on the RDS server state anything while trying to logon?
    How is the RD license server set-up?
    Have you tried connecting using the laptop from different locations?

    Kind regards,
    Freek Berson

    Monday, January 24, 2011 7:17 PM
  • Hi if you can connect from different clients with both win 7 and win xp, then it should not be a server problem, it seems more that you have problems on the specific laptop client side,as proposed by Freek you should find out if you have dns resolving issues, or routing problems, you could try with two win 7 clients side by side and figure out the different in configurations. First try with nslookup to see if you can resolve the server name, then try to telnet (from command prompt: telnet IPOFTHESERVER:3389) with this steps you should figure out where the problem is. Icecore
    Monday, January 24, 2011 9:36 PM
  • I'm afraid I don't have access to the laptop at this point but I did ping the fqdn with it this morning with no problems. 

    The user was not able to connect from another location over the weekend.

    Is the message "Remote Desktop can't connect to the remote computer" a possible result of a licensing issue?

    I see a warning in Server Manager->Roles->Remote Desktop Services

    "The Remote Desktop license server "GEC-FS01" does not have any Remote Desktop Services client access licenses (RDS CALs) installed and registered with the Microsoft Clearinghouse for product "Windows Server 2008 or Windows Server 2008 R2 : Per Device CAL (TS, RDS or VDI)". Therefore, the Remote Desktop license server cannot issue RDS CALs of the type "Windows Server 2008 or Windows Server 2008 R2 : Per Device CAL (TS, RDS or VDI)" to the Remote Desktop Session Host server "GEC-FS01". To resolve this problem, install additional RDS CALs as required."

    If I go to Licensing Diagnosis->Licensing Diagnosis Information:  The Remote Desktop Session Host server is in Per Device licensing mode, but license server gec-fs01 does not have any Windows Server 2008 or Windows Server 2008 R2 Per Device RDS CALs installed.

    If I go to Licensing Diagnosis->License Server Configuration Details it shows RDS CAL Type: Per User,  Installed: 2, Available: 2

    It sounds like there is a mismatch in that it is expecting device license even though I installed user license.  Am I right?  How do I make it right?



    Monday, January 24, 2011 10:57 PM
  • Hi,



    As only one special machine can not connect to the RDS server, I conclude that there is an issue on your client machine. I would like to recommend the following article to do some general troubleshoot to find out the root cause.


    How to resolve the issue “Remote Desktop Disconnected” or “Unable to Connect to Remote Desktop (Terminal Server)”


    Meanwhile, if this issue is caused by the RDS license, you may find the related event log on the server side. For your convenience, there is an article describes a few license issues on the Terminal Server.


    Remote Desktop Services Client Access License (RDS CAL) Availability






    • Marked as answer by Alan Zhu Friday, January 28, 2011 2:29 AM
    Tuesday, January 25, 2011 8:36 AM
  • Thank you for the articles I will look at those today. 

    Fyi, I changed it to per user mode so that it matches the terminal server license.

    Tuesday, January 25, 2011 2:07 PM