locked
Username ????? RRS feed

  • Question

  • I am using windows vista and have come across an odd problem.

     

    When I try to map a server hard drive from my windows XP system I provide a username and password and as expected I gain access to the server without issue.

     

    When I try the same procedure with my Vista system I again provide a username and password and it refuses to log me on.

    My username in Nick and then the password. The return is Kitchen\Nick. The computer seems to add the network ID name to the username. This of course does not marry up to the serever and so the lod in attempt is rejected.

     

    I have tried changing the network ID but the underlying problem seems to be that vista insists on putting a back slash between the network ID name and my user name. Unfortunatelythe server will not accomodate any thing other than numbers and letters.

     

    I would appreciate any help you can offer

    Wednesday, August 1, 2007 8:33 AM

All replies

  • Windows has always done the MACHINENAME\USER thing behind the scenes, it's just the way local accounts work. I don't think that is causing the issue you are seeing.

     

    Are you, by any chance, trying to map to the default NT administrative shares, i.e. C$, D$ etc? I believe those no longer work outside of a Domain environment, so you'll need to create explicit shared folders and make sure that both the share and NTFS permissions allow the appropriate users to access it.

     

    Wednesday, August 1, 2007 2:32 PM
  • I am trying to map a network drive.

    I have set up an account on the network drive of "Nick", when you put that account name and password into the windows mapping process the system returns the account name field as Kitchen\Nick (the computers network ID name is Kitchen) and so the user name does not match the account set up on the network drive ?

     

    Thursday, August 2, 2007 8:14 AM
  • As I said, the username thing is misleading. NT based operating systems always treat your username as being of the form AUTHORITY\USERNAME, where authority is the name of the Domain or Computer that will authenticate you. Since you're connecting to a non-domain joined computer called KITCHEN with an account called Nick it will be translated behind the scenes as KITCHEN\Nick by both XP and Vista. This will not cause it to fail.

     

    This means that the most likely cause is still Permissions somewhere along the way (either Share or NTFS). Since you can connect from XP, my guess is that one or the other of those is only allowing access to the Administrators group and Vista's token filtering is causing this to fail. Does the problem persist if you explicitly grant Nick access?

    Thursday, August 2, 2007 8:24 AM
  •  

    I have not used a domain on the network set up apart from "MSHOME". I have tried removing all accounts from the network drive and permiting full access to "Nick" and again I get the same result.

    Where can I look at the shares permisions on Vista perhaps the issue is there ?

     

    Regards

    Thursday, August 2, 2007 1:03 PM
  • It's on the share tab on the properties of the folder being shared, at least on this machine. Roughly the same place it was on XP with Simple File Sharing turned off.

     

    Just a thought though, you said you removed accounts on the network drive - Is this a NAS box of some kind?

    Monday, August 6, 2007 8:06 PM