none
WIN32 API stops showing "pop up" edit dialog RRS feed

  • Question

  • I have a Win32 API windows program that displays a txt file that contains a French document.  I can click on a word and the program will read a dictionary file, open an edit window and display the English definition, type, and tense.  After several requests the program stops displaying the results. In fact, any mouse clicks appear to have no results (including clicking the tool bar and the scroll bar). A right mouse button click should cause a MessageBox to appear but does not. 
    In tracing my program I see that the program is behaving as though it is working but no windows pop up nor does any displayed text appear.
    I reuse the edit window and simply resize it and move it around, (rather than deleting it and recreating it for each definition), so I tried creating it when needed and deleting it when done, but no change.
    I also create a global font on startup and apply it when needed so I tried it without the font but again no change. 
    When I compile with CodeBlocks the program stops displaying after about 45 requests. When I compile with DevCpp the problem occurs after about 20 requests. I’ve also monitored the GlobalMemoryStatus but there appears to be lots of memory so I can’t put it down to a memory leak. It’s almost as if I’ve run out of some windows structure but I don’t know what?
    The program is ~1300 lines so I don’t know if there is a subset that might illustrate the cause but will post selected code blocks if I know what might help.
      Anyone have any suggestions?
    Saturday, October 29, 2016 5:45 PM