none
DCOM Events on secondary DPM RRS feed

  • Question

  • Hi,

    I get 2 DCOM events 10009 every half hour on our secondary dpm since we changed our network. The change of the network did not affect connectivity to primary DPM, but our Hyper-V Cluster is no more reachable from secondary dpm.

    The 2 Events say that Cluster node 1 & 2 of the Hyper-V cluster is unreachable.

    The 2 cluster nodes are part of the protection group of primary DPM, which is the only protection group on our secondary DPM.

    In DPM console I see a warning for each Cluster node: Agent unreachable (ID 3122).

    I never connected the agents on the Cluster nodes with secondary dpm Server. The only connected agent is the primary DPM server.

    I tried the Remove-ProductionServer.ps1-script, but I get this error:

    There is failure while removing production server
    C:\Program Files\Microsoft System Center
    2012\DPM\DPM\bin\Remove-ProductionServer.ps1 : Der geschützte Computer
    iller.stwa.local, der auf diesem DPM-Server über aktiven oder inaktiven Schutz
    verfügt, konnte nicht entfernt werden.
    In Zeile:1 Zeichen:1
    + Remove-ProductionServer.ps1
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorExcep
       tion
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio
       n,Remove-ProductionServer.ps1

    Delete any active protection for this protected computer and then retry the operation.

    I also edited dpm-db on secondary dpm, but nothing changed:
    - table dbo.tbl_AM_ClusterDetail set "Deleted" to True (1)

    How can I get rid of the DCOM events?

    Thank you very much for help!!!

    Tuesday, April 29, 2014 6:25 AM

All replies

  • Hmm... I think I figured it out.

    Found this: http://technet.microsoft.com/en-us/library/jj656645.aspx
    According to this, there must be a connection from secondary DPM server to the Hyper-V cluster.

    This is how our infrastructure looks like:

    By changing our network config the red connection isnt anymore.

    What's strange to me is that all backups on secondary DPM are working fine. So the only problem are the DCOM events logged every half hour...

    Tuesday, April 29, 2014 7:22 AM