none
R Open Installation "Unknown Error" RRS feed

  • Question

  • Hi all,

    I currently have been teaching myself R using the version from CRAN and R Studio.

    I now have gotten to a point where i need to use RevoScaleR. I am trying to download R Client and configure that with RStudio, seems like a simple process so i figured I wouldn't have any issues but to the contrary, i am having many. 

    First, it says on the webpage that when you download R Client that R Open will automatically be installed as well. Great, but that hasn't been the case. When i download the R Client package it does not let me choose the file location; whatever, i see where it was downloaded to. I open R Studio and it asks for an existing installation of R. I go to the file where R Client should be located and there's nothing there. 

    Second strategy is to download R Open first, and then download R Client after. I run a local  search for "R Client" and a few text files come up and i delete them to prep for a clean install. I install R Open where it allows me to choose a path and install. I start the install and it immediately stop and says "Unknown Error." Every time, unless... I try again and uncheck the "MKL" box. With that box unchecked I install R Open and then can also install R Client on top of. Problem solved!

    Unfortunately, no. I open R Studio and configure it point it to the R open/R Client's installation point: D:\R\bin\x64. R Studio opens and i get a warning in the console:

    Warning message:
    In normalizePath(path.expand(path), winslash, mustWork) :
      path[1]="D:\R\/R_SERVER": The system cannot find the file specified

    I have literally no clue what the above means besides it's obviously not working correctly. Just for fun(this hasn't been fun) I try to install RevoScaleR and get the same problem I had before I tried to install R Open/R Client:

    "Warning in install.packages :
      package ‘RevoScaleR’ is not available (for R version 3.4.2)"

    This, is well, an issue. If anyone has any insight please help. My experience is limited on R but after some light searching on the forums I couldn't really find any useful information other than a few people had similar issue back in the spring of 2017. 

    EDIT: after tinkering around some more, i still cant get R Open to install without unchecking the MLK box. I deleted all previous R related programs from CRAN and then tried to download both R Open and R Client again. In the R Client installation process I can no longer click on the directory and it is installing it to a folder i deleted inside my HDD. One time it actually downloaded and put the previously deleted folder back into my HDD (idk how that can happen?) but i wasn't able to run any application. Other attempts simply did not download anything after the installation had said it had been completed. 

    Ive made 3 attempts with different fields of tech support through Microsoft and none of them have helped at all.

    • Edited by okSteve Friday, December 29, 2017 9:47 PM
    Friday, December 29, 2017 6:57 PM