locked
Access Requests link missing! RRS feed

  • Question

  • Greetz!

    I'm running sharepoint 2007 Enterprise and would like to let my users request access (reqacc.aspx) to sites rather than getting the access denied (accessdenied.aspx) page. Normally one would follow these steps to turn this on:

    

    1) Go To Site Settings ->Modify All Site Settings 2) Click on Advanced Permissions under User and Permission 3)List Settings -> Access Requests 4) Set the email ID and activate the Allow Request for access

    However on my sites and lists there is no Access Requests link under the Settings link! I have not been able to find anything about how to actually make this available to my users, although i did see one vague mention that an administrator would need to make a change to the settings to make it available.

    After some more research i discovered that the requestaccessenabled property is read only. I was able to set requestaccessemail which one post said would do the trick of setting enabled to true but it hasn't done the trick. Perhaps because email isn't set up on this dev box?

    Thanks!


    Love them all...regardless. - Buddha


    Monday, January 14, 2013 6:32 PM

Answers

  • Mystery solved!

    I went to /_layouts/setrqacc.aspx and was given the error message "This server is not configured to send email". This is pretty compelling that SharePoint 2007 will not let you setup access requests if the email notifying the admin of the request can't be sent. I set up SMTP on the server, set the Outgoing and Incoming e-mail settings in central admin and the setrqacc.aspx page became available! Now I have the link available to my users to set access requests.

    Tuesday, January 15, 2013 12:23 PM

All replies

  • Hi KansasCoder,

    Did you check code of logon.aspx page ? you could check the source code of logon.aspx in 12\TEMPLATE\LAYOUTS folder for more information.

    Also What permission you have on the site ?


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/ | Posting is provided "AS IS" with no warranties, and confers no rights Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Monday, January 14, 2013 10:57 PM
  • Hi Pratik,

    Thanks for your response. I am Farm Admin and Site Collection Admin on the site. I'm not sure I undesrtand the logon page advice? I am automatically athenticated to the site. The page to request access isn't being displayed because the requestaccessenabled property is set to false. So instead of the reqacc.aspx page being displayed, the site displayse the accessdenied.aspx. The only way to do this is to get requestaccessenabled to be true, which is what seetig the email is supposed to do. It appears, however, that this way of forcing the value to be true doesn't work if email is enabled on the farm, which it isn't on ours because it's a test server and exists off the domain. I can't verify with certainty that this is the case but it appears to be.

    Is there something in logon.aspx that would force the requestaccessenabled property to switch on?

    Thanks again for your response.

    Monday, January 14, 2013 11:40 PM
  • Mystery solved!

    I went to /_layouts/setrqacc.aspx and was given the error message "This server is not configured to send email". This is pretty compelling that SharePoint 2007 will not let you setup access requests if the email notifying the admin of the request can't be sent. I set up SMTP on the server, set the Outgoing and Incoming e-mail settings in central admin and the setrqacc.aspx page became available! Now I have the link available to my users to set access requests.

    Tuesday, January 15, 2013 12:23 PM