none
Pushing file to desktop failes using computer configuration\prefrences\windows settings\files RRS feed

  • Question

  • Question,

    I want to take files from a shared folder and have the files pushed to the logon users desktop.  I need this to apply to the computer, not the user since the same user account is logged into multiple machines. Apparently simple yet I have not found an answer.  I don't want to publish or install an executable, all I want to do is copy files to users desktops.  Is this even possible without scripting?

    I tried the following in computer configuration\prefrences\windows settings\files

    Action Create

    Source file \\10.10.62.92\share\Antivirus\msftAVx64.msi

    Destination file(this is confusing how can a files destination be another file?  Does this meamn folder?  What am I missing) anyway,

    Destination File  %ALLUSERSPROFILE%\Desktop

    ItemLevel Targeting set for the labmachines OU

    After creating the triangle is green for the setting

    Next I removed all users from the security filtering and added 3 specific computers since I've not found a means to add an OU to security filtering

    I then verified the link to the domain controller and enabled enforcement.

    gpupdate /force

    Reboot the targeted systems

    Result, fail on all clients.

    Group policy object did not apply because it failed with error code 0x80070005 Access is denied, the error was suppressed

    Nothing in the server event logs.

    I am administering a W2008 server in a lab enviornment managing XP, Vista and W7 machines.

    I was able to successfully "publish" (which I don't want to do) with user configuration???

     

    Thank You

     

     


    Profuse thanks
    Thursday, April 29, 2010 5:10 PM

Answers

All replies

  • Hi,

     Since the policy is a computer policy, you need to make sure that the computer object has permissions to the source share and source files.

     

    As an alternate approach, since it sounds you only want to apply this to user logins on some computers, you can create a GPO for the user that copies the files to the desktop and then use item level targeting to restrict the policy based on the computer being in an OU.

     

    thanks,

    Guy

    Thursday, April 29, 2010 5:47 PM
  • Hi,

    Please change the Destination File to " %ALLUSERSPROFILE%\Desktop\msftavx64.msi". It needs to contain the filename.

    For your reference:

    Group Policy Preference "File" not working!
    http://social.technet.microsoft.com/Forums/en/winserverGP/thread/e9b917a0-c684-452b-a652-f11d8bb62aa7

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, May 4, 2010 9:43 AM
    Moderator