locked
Trace Log generating huge file with "ManagedObjectFactory failed to GetObject." RRS feed

  • Question

  • Hello,

    I have MOSS 2007 installed with two Front-end server, have problem from the day when I turn on "Diagnostic logging > Trace Log " from SharePoint Administration.

     

    My setting for Trace log is  like this

     

    Category = All

     

    Least critical event to report to the event log = None

     

    Least critical event to report to the trace log = Unexpected

     

    Trace logs stored at "f\Program Files\Microsoft Office Servers\12.0\Logs" on both server.

    In One front-end server everything is fine,

    On WFE Server 1 It generate regular file between 25000 kb to 35000 kb

    On WFE Server 2 it get generated 4GB to 9GB file everyday between 11:00 pm to 1:20 am.

     

    And today it’s going crazy, it still generating trace logs with 4 to 5 GB.

     

    I am investigating from last 3 to 4 days and here is the detail for it.

     

    Some process is activated after 11:00 pm everyday.

    The process is w3wp.exe  login Used s_msspspool.

     

    Process belong to pools “PortalAppPools

     

    Pools belong to site “Portal” web site [SharePoint site].

     

    See Logs

     

    10/02/2009 00:43:37.38          w3wp.exe (0x2354)                                0x2388  Windows SharePoint Services      General                         6u0k         Unexpected       ERROR: ManagedObjectFactory failed to GetObject. HR=0x80131530, ObjectType=1           

    10/02/2009 00:43:37.38          w3wp.exe (0x2354)                                0x2388  Windows SharePoint Services      General                         6u0k         Unexpected       ERROR: ManagedObjectFactory failed to GetObject. HR=0x80131530, ObjectType=1           

    10/02/2009 00:43:37.38          w3wp.exe (0x2354)                                0x1900  Windows SharePoint Services      General                         6u0k         Unexpected       ERROR: ManagedObjectFactory failed to GetObject. HR=0x80131530, ObjectType=1           

    10/02/2009 00:43:37.38          w3wp.exe (0x2354)                                0x226C Windows SharePoint Services      General                         6u0k         Unexpected       ERROR: ManagedObjectFactory failed to GetObject. HR=0x80131530, ObjectType=1          

     

    I check all my services and application there is no such kind of process going that time, it seems something inside in SharePoint going crazy.

    Please suggest what can be done.Also if any additional information is needed, then please let me know.

     

    Friday, October 2, 2009 2:28 PM

All replies

  • is there anything on  event viewer in application section during that time on that particular WFE?
    thanks.
    Aniket
    Friday, October 2, 2009 6:17 PM
  • You can use "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Bin\>STSADM -O setlogginglevel -defaut" to set the diagnostic level to the factory defaults.
    Sunday, October 4, 2009 1:26 AM
  • Hi Ankit R Shah,

     

    I agree with Anand. You can use the command line to configure diagnostic logging to default settings to avoid the log file grow too big. For the error message, please check your SharePoint function to see if there is any symptom. Without any symptom it’s hard to tell the cause of this error as it’s too general.

     

    For more information, please refer to:

    Configure diagnostic logging

    http://technet.microsoft.com/en-us/library/cc288004.aspx

    http://stsadm.blogspot.com/2008/06/trace-log-settings.html

    http://social.technet.microsoft.com/Forums/en-US/sharepointadmin/thread/82e3b319-05b2-46a5-ac77-6cd4ed2ce27c 

     

    Hope this helps.

     

    Lu Zou

    Monday, October 5, 2009 7:04 AM
  •   

    Thanks everyone,

    about
    configure diagnostic logging, right now I am logging only "Unexpected" Errors in Trace logs, it works fine till 11 pm, after that it occupied 100% CPU usage by SharePoint Process, and start to fill Trace log with 5 to 9 GB data in one file.

    I try all setting in Trace logs, and it stop filling data only when i turn it off - Set to None -.

    My company has Premium support with Microsoft so I already open CASEID with it, and till yet we identifiy that, we have this issue only when the crawling get started at 11:00 pm, why it generating issue don’t know yet… stay tuned..

    to go upto Crawl setting go to Central Administration >> SSP >> Search Administration > Content sources > Edit Content Source.

    Tuesday, October 6, 2009 5:17 PM
  • Hi

    Did you track root couse of that problem ? We have started to encounter the some issue : at 1:00pm out w3wp process goes crezy eat entire memory and start rejecting all connection to the server :(

    BR



    Mariusz Gorzoch
    Blog : http://mariusz.gorzoch.pl
    Twitter : http://twitter.com/MariuszGorzoch
    Facebook: http://www.facebook.com/mariusz.gorzoch
    Thursday, November 25, 2010 12:57 PM
  • Hello,

    Did you get any solution for this?

    Even i am facing similar error having logs:

    0000 High Virus scan took 224953 ms (get thread: 0 ms; scan: 224953 ms; clean: 0 ms)

    6u0k Unexpected ERROR: ManagedObjectFactory failed to GetObject. HR=0x80131530, ObjectType=7

    b2vw High Could not get SPSqlClient object from managed object factory. 0x80131530

    cmj3 High NULL SqlClient interface.  Database Id = {06321ED9-351D-4ECC-8177-116009C0D715}.  ExternalSqlClient=0. 0x80131530

    8kh7 High Cannot complete this action.  Please try again.

    tkau Unexpected System.Web.HttpException: Request timed out. 

    We have Anti-Virus scan enabled and cannot be ruled out. Please let me know in case of any suggestions.

    Monday, February 22, 2016 7:20 PM