none
smtp with copiers

    Question

  • I am currently running an Exchange 2013 environment on two separate servers. I have the Mailbox and Client Role on one and I have an Edge Server on the other. Previously I just had one server with all roles combined but I decided to give the Edge server a try. Since installing this edge server I can no longer get my copiers to relay mail to the outside. They will send messages to my LAN all day long but they will not mail to the outside Internet. I have added recieve connectors under mail flow but still they will not mail to the outside Internet. Has anybody else had this problem or does anybody have any idea what I should check next?

    Thank you.

    Wednesday, August 23, 2017 12:57 AM

Answers

  • First, I would like to thank you for the replies on my question. I have found what my problem was. To answer the above question first, yes my Edge Server was subscribed correctly. The messages on the copiers were being submitted to the Exchange Server and not the Edge Server. The problem was in the "Receive Connectors" Front End Transport Rule that I had created. I needed a few check marks underneath the security setting. Once I checked "Externally Secured" "Exchange Server" and "Anonymous User" The service began to work. I will attach a screen shot to show the settings I used. Again, thank you for the replies and help.

    • Marked as answer by ParaGuy Wednesday, September 6, 2017 6:50 PM
    Wednesday, September 6, 2017 6:13 PM

All replies

  • Where have you pointed the copiers?  They should still point to the Mailbox server and not the Edge server.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Wednesday, August 23, 2017 1:56 AM
    Moderator
  • Hi,

    Thanks for contacting our forum. Do you subscribed your Edge server correctly after you've installed this Edge server?

    Yes, the messages generated by the copiers should still be submitted to the mailbox server and be route to the Edge server then will be relay to external.

    Do you see any error on Exchange server queue or Event log? For message queue, please run the command to get the detailed error message:

    Get-queue | fl name, *last*

    This receive connector should have the right permission for the copiers:

    • Create/configure a service account for the copier to use.
    • Create a new Receive connector with the Usage value 'Custom', and don't assign any permission groups to the connector.
    • Specify the IP address(es) of the copiers as the only remote IP addresses that are allowed to use this Receive connector.
    • Use the Add-AdPermission cmdlet to add the ms-Exch-SMTP-Submit permission to the Receive connector for the service account.

    It's recommended to check the message tracking log to see if this messages from copiers go through with the received connector via the command below:

    Get-MessageTrackingLog –ResultSize Unlimited –Start "08/16/2017 2:30PM" –End “08/17/2017 3:30PM" –Sender "copiers@contoso.com"  -MessageSubject "subject"| fl >c:\MTL.txt

    Hope it helps.


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Thursday, August 24, 2017 5:42 AM
    Moderator
  • First, I would like to thank you for the replies on my question. I have found what my problem was. To answer the above question first, yes my Edge Server was subscribed correctly. The messages on the copiers were being submitted to the Exchange Server and not the Edge Server. The problem was in the "Receive Connectors" Front End Transport Rule that I had created. I needed a few check marks underneath the security setting. Once I checked "Externally Secured" "Exchange Server" and "Anonymous User" The service began to work. I will attach a screen shot to show the settings I used. Again, thank you for the replies and help.

    • Marked as answer by ParaGuy Wednesday, September 6, 2017 6:50 PM
    Wednesday, September 6, 2017 6:13 PM
  • Thanks for your kindly sharing!

    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 7, 2017 4:37 AM
    Moderator