none
There is a compatibility range mismatch between the Web server and database and connections to the data have been blocked to due to this incompatibility

    Question

  • We created a new SP 2013 environment for migration and installed SP1 and June 2016 CU a couple of months ago. It all worked fine for last 2 months after we migrated, however when we now try to connect to your Content type HUB from site collections on different database, we are getting an error:

    "There is a compatibility range mismatch between the Web server and database "Portal_Content", and connections to the data have been blocked to due to this incompatibility. This can happen when a content database has not been upgraded to be within the compatibility range of the Web server, or if the database has been upgraded to a higher level than the web server. The Web server and the database must be upgraded to the same version and build level to return to compatibility range."

    We checked a few things, database schema versions of both databases, both DB's(hub and other site collection ) are on the same version. This issue does not happen on our other environments( test and prod). The configuration database version (15.0.4833.1000), SP1, CU are all matching with our problematic environment but works fine.

    We tried running PSCONFIG but it fails at step 5, throwing below error message:

    10.00% : Failed to upgrade SharePoint Products.

    An exception of type Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException was thrown.  Additional exception information: T
    e upgrade command is invalid or a failure has been encountered.
    Failed to upgrade SharePoint Products.

    Total number of configuration settings run: 5
    Total number of successful configuration settings: 4
    Total number of unsuccessful configuration settings: 1
    Successfully stopped the configuration of SharePoint Products.
    Configuration of SharePoint Products failed.  Configuration must be performed before you use SharePoint Products.  For further details, see the diagn
    stic log located at C:\wwwlogs\ULS\PSCDiagnostics_3_2_2017_15_56_4_434_1175347363.log and the application event log.

    Any thoughts are appreciated.

    Wednesday, March 15, 2017 2:50 PM

All replies

  • Which account did you use to run the PSCONFIG command under?  Also, check database mappings: is the farm service account and farm administration account mapped as dbowner of farm databases?
    Wednesday, March 15, 2017 4:48 PM
  • I used admin account to run the PSCONFIG and it has the dbo rights on the config database.

    Service account has rights only to app pools on the config database, not dbo

    Wednesday, March 15, 2017 5:14 PM
  • In the server Application logs, do you find error event 5586? and is it recurring?

    Are you using any third party monitoring tool, such as DocAve?

    What accounts have access to the farm config database? farm admin and farm service?  And are both these mapped as dbowner?

    Map farm service as dbowner to Port Content db and the retry config operation.


    Wednesday, March 15, 2017 5:21 PM
  • Yes Stephen, we see numerous 5586 events on that server and it is reoccurring. It is reported for different users and different DB's. One of which is our DB where our content type hub resides, failing with exception for NT AUTHORITY\IUSR.

    Unknown SQL Exception 262 occurred. Additional error information from SQL Server is included below.
    CREATE TABLE permission denied in database 'Portal_Content'.

    We use a 3rd party monitoring tool on this env and that account has DBowner rights as well on the config DB. Other accounts granted to farm config DB as dbowner are: admin, farm, search, service, app pool accounts.

    Do you mean grant dbowner rights to Portal Content DB? The one where our hub resides?

    Wednesday, March 15, 2017 5:47 PM
  • Did all of this happen before you patched or after?  Also, does your third party monitoring tool have its own service account?

    Wednesday, March 15, 2017 6:41 PM
  • We installed SP1 and CU at the time of farm creation. All worked fine for 2 months, now issues arised. Yes, our 3rd party monitoring tool has its own service account.
    Wednesday, March 15, 2017 7:01 PM
  • Check that the third party monitoring tool service account is mapped as dbowner to all farm databases, including Portal_Content. If any are missing, add them.  Then re-attempt PSCONFIG - or just wait for the event messages to stop - that'll depend on how often your monitoring tool reaches out to your farm.  If they stop, you got your answer.



    Wednesday, March 15, 2017 8:06 PM
  • Thanks Stephan. The issue was DB rights. The app pool accounts were missing rights on the DB in question. We were able to resolve the issue by granting rights to DB. Appreciate your assistance.
    Thursday, March 23, 2017 4:19 PM
  • Which app pools?  The ones to your content web apps, CA web app, or the one to your monitoring tool?
    Thursday, March 23, 2017 5:55 PM
  • The app pool running the web application from which are trying to connect to the other web application to pull/read the Content types. Destination app pool did not have rights to read from source web app/DB.
    Thursday, March 23, 2017 6:34 PM