locked
network problem - win 7 RRS feed

  • Question

  • Greetings!

    We have a problem with mapping network shares on WIN 7 platform. Our server is 2003 with sp2, client has WIN7 Enterprise x86. On our DC server we have setup a log-in script for this client to do this:

    net use p: /delete
    net use z: /delete
    REM connect shares
    net use p: \\server\d
    net use z: \\server\e

    PROBLEM: After client restarts his pc and logs in the domain the mapping for network drives does not work. User has to manually click on the mapped drives in windows explorer to achieve that. This mapping thing on XP machines worked like a charm but on win7 it does not.

    PLZ HELP.


    event viewer on this client pc also saids:

    The processing of Group Policy failed because of lack of network connectivity to a domain controller. This may be a transient condition. A success message would be generated once the machine gets connected to the domain controller and Group Policy has succesfully processed. If you do not see a success message for several hours, then contact your administrator.

     


    EventData


        SupportInfo1 1
        SupportInfo2 1254
        ProcessingMode 2
        ProcessingTimeInMilliseconds 1638
        ErrorCode 1222
        ErrorDescription The network is not present or not started.


    bostjanc
    Monday, November 8, 2010 6:33 AM

Answers

  • Hi bostjanc,

     

    Thanks for update.

     

    Please also check if this issue would still persist with follow the solution in the article below to modify system settings on fileserver .

     

    Mapped Drive Connection to Network Share May Be Lost

    http://support.microsoft.com/kb/297684

     

    Thanks.

     

    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, November 16, 2010 12:13 PM

All replies

  • Hi bostjanc,

    Thanks for posting here.

     

    What if manually perform this scrip when client logon to windows 7 computer ?

    Could you verify if other policy settings are correctly applied ?

    Please try disable UAC (User Account Control) on windows 7 client and try again.

     

    User Account Control

    http://windows.microsoft.com/en-US/windows7/products/features/user-account-control

     

    Meanwhile, please try to configure the EnableLinkedConnections registry value on windows 7 host and check this is issue persist:

     

    1.       Click Start, type regedit in the Start Search box, and then press ENTER.

    2.       Locate and then right-click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

    3.       Point to New, and then click DWORD Value.

    4.       Type EnableLinkedConnections, and then press ENTER.

    5.       Right-click EnableLinkedConnections, and then click Modify.

    6.       In the Value data box, type 1, and then click OK.

    7.       Exit Registry Editor, and then restart the computer.

     

    According the error message that this issue might relate with incorrect network connectivity, please also try the solution in the article below:

     

    Event ID 1129 — Group Policy Preprocessing (Networking)

    http://technet.microsoft.com/en-us/library/dd392556(WS.10).aspx

     

    Thanks.

     

    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by B_C_R Thursday, November 11, 2010 7:25 AM
    • Unmarked as answer by B_C_R Monday, November 15, 2010 9:02 AM
    Tuesday, November 9, 2010 6:06 AM
  • Greetings!

     

    1.       Click Start, type regedit in the Start Search box, and then press ENTER.

    2.       Locate and then right-click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

    3.       Point to New, and then click DWORD Value.

    4.       Type EnableLinkedConnections, and then press ENTER.

    5.       Right-click EnableLinkedConnections, and then click Modify.

    6.       In the Value data box, type 1, and then click OK.

    7.       Exit Registry Editor, and then restart the computer.

    SOLVED THE PROBLEM. Thank you very much.


    bostjanc
    Thursday, November 11, 2010 7:25 AM
  • A user saids that making that registry entry did not solve the problem :(

     


    bostjanc
    Monday, November 15, 2010 9:02 AM
  • Hi bostjanc,

     

    Thanks for update.

     

    Please make sure the network connectivity and name resolution between this issue clients ,DC and fileserver is working correctly .

    And please also post the event id that relate this issue on this client computer here.

    After that please verify if it worked on this issue computer by manually perform script when logon .

     

    How may users were still encountered this issue after modify registry value?

     

    Thanks.

     

    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, November 16, 2010 3:33 AM
  • I don't know if I have explain the problem correctly.

    A user has a login script which mappes the drives. The problem is that mapped drives do exists, but they are disconnected. User must manually click them in explorer just to refresh the connection.


    bostjanc
    Tuesday, November 16, 2010 8:01 AM
  • Hi bostjanc,

     

    Thanks for update.

     

    Please also check if this issue would still persist with follow the solution in the article below to modify system settings on fileserver .

     

    Mapped Drive Connection to Network Share May Be Lost

    http://support.microsoft.com/kb/297684

     

    Thanks.

     

    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, November 16, 2010 12:13 PM
  • Must this be done on server or client's computer?
    bostjanc
    Wednesday, November 17, 2010 1:41 PM
  • Hi,

    According the article, this should be done on the shared network computer. In your case, it's fileserver.

    Thanks.

    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, November 18, 2010 4:32 AM
  • Ok... one more question ... does this policy changes affect right away or does the system need a reboot? usually changes in local machine registry needs a reboot?
    bostjanc
    Thursday, November 18, 2010 2:29 PM
  • Hi Bostjan,

     

    Thanks for update.

     

    Yes , rebooting will help to make changes take effect.

    If you decide to use modify registry method, please remember backup registry first before you perform modification.

     

    Thanks.

     

    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, November 19, 2010 1:52 AM