none
windows aero theme RRS feed

  • Question

  • About a month ago I downloaded a software to delete couple viruses, but it did something with themes. My aero themes are grayed out and even thought I have recovered files which were deleted (theme service was among them), I can't even turn on theme service, It says ''Failed to read description. Error 127". I tried force enabling theme service, but it doesn't work. Sfc / scannow doesn't work either...
    Sunday, January 29, 2017 8:06 PM

Answers

  • Start "Desktop Window Manager Service"

    Then run this on elevated cmd prompt 

    rundll32.exe Dwmapi.dll,DwmEnableComposition


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, January 30, 2017 12:36 AM
    Moderator
  • Hi Yulaukira,

    If you have used the sfc command, we could try modify the registry to check. Please refer to the link below to follow the steps in the link below.

    http://windows7themes.net/en-us/windows-7-themes-service-will-not-start/

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Also we could use the command to force enable the theme service, if the issue still insists, we could try create a new user account to check.

    Hope it will be helpful to you


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 30, 2017 2:38 AM
    Moderator

All replies

  • Start "Desktop Window Manager Service"

    Then run this on elevated cmd prompt 

    rundll32.exe Dwmapi.dll,DwmEnableComposition


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, January 30, 2017 12:36 AM
    Moderator
  • Hi Yulaukira,

    If you have used the sfc command, we could try modify the registry to check. Please refer to the link below to follow the steps in the link below.

    http://windows7themes.net/en-us/windows-7-themes-service-will-not-start/

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Also we could use the command to force enable the theme service, if the issue still insists, we could try create a new user account to check.

    Hope it will be helpful to you


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 30, 2017 2:38 AM
    Moderator
  • Hi Yulaukira,

    Haven't received your message a few days, was your issue resolved?
    I am proposing previous helpful replies as "Answered". Please feel free to try it and let me know the result. If the reply is helpful, please remember to mark it as answer which can help other community members who have same questions and find the helpful reply quickly.
    Best regards,
    Carl


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, February 8, 2017 6:57 AM
    Moderator