none
MDT 8450 and a restart break auto logon

    Question

  • Good day everyone.

    Does anyone have any idea how to incorporate a restart in a task sequence
    without breaking the autologon?

    Situation:

    Using a MDT task sequence to create a Windows 10 Enterprise (version 1709)
    image, I encounter the following:

    During the task sequence i deploy Microsoft.NET Framework 4.7.2 as an application. 
    I suppressed the reboot during the installation.
    On the properties of the application I have the 
    checkbox 'Reboot the computer after installing this application'
    enabled.

    However, after the image vm reboots, it no longer uses the autologon set by MDT.
    I also tried not enabling the reboot checkbox on the application, and instead
    using the reboot computer step in the task sequence. This also breaks auto logon.

    If I manually enter the admin password the task sequence continues to run.
    When I disable the step to install .NET Framework 4.7.2, and do not need
    the reboot, the task sequence run fine.

    If I choose to install .NET Framework, without a reboot further actions fail
    due to a pending reboot. But the task sequence does run on.

    I know that Windows 10 version 1803 has been released, and that this release 
    already has .NET Framework 4.7.2.  

    However, we can not move to Windows 10 v1803 yet.

    The VM does not join the domain.

    my MDT build environment
    Hyper-V running on Windows 10 Enterprise, version 1803

    MDT Server VM
    Hyper-V VM, generation 2.
    The VM is connected to a private virtual switch.
    OS: Windows Server 2016 with Desktop Experiance
    Roles installed (for PXE boot):
    * DNS
    * DHCP
    * WDS (Stand-alone mode)
    Installed software:
    * Microsoft Deployment Toolkit build 8450
    * Windows ADK for Windows 10 version 1803
    * SQL Server 2012 Express (MDT DB)

    Image VM
    Hyper-V VM, generation 1.
    The VM is connected to the same virtual switch as the MDT VM.


    • Edited by Alchro Wednesday, June 6, 2018 9:28 AM added information that the VM does not join a domain.
    Wednesday, June 6, 2018 9:15 AM

All replies

  • Hi,

    have you tried to add "Restart Computer" Steps located in Add>General after Installation of .net framework? 


    Friday, June 8, 2018 4:11 AM
  • Yes. It seems it does not matter how I let MDT handle the restart, either via the Restart Computer task sequence step or via the Reboot the computer after installing this application checkbox.

    Both methods cause the machine to stay on the logon screen after the restart.
    Friday, June 8, 2018 12:34 PM
  • Yeah Correct. just asked you for the confirmation.

    Add the Below AutoLogon Registry in Task Sequence before restart phase. let me know the result.

    cmd /c REG ADD HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v MSAOptional /t REG_DWORD /d 1 /f

    Saturday, June 9, 2018 7:05 AM
  • Okay, I will try that.

    Update: I am still trying with the timing in the task MDT task sequence, but so far it still does not seem to make a lot of difference. I have inserted the run command line step before the first Restart Computer step in the task sequence.

    • Edited by Alchro Monday, June 11, 2018 9:48 AM added first test results
    Monday, June 11, 2018 6:58 AM
  • Update:I have inserted the run command line step before the first Restart Computer step in the task sequence.

    Hey, Don't add the Run Command Line Before First Restart Phase. Add After "STATE RESTORE" Phase of Task Sequence where you've added the custom steps to perform actions with Restart 
    Monday, June 11, 2018 4:46 PM
  • I did add that one, but it does not seem the change the behaviour.

    So now I am on the point of testing with some other variables, like the MDT environment / deployment share and task sequence.

    I can't shake the feeling that the LTICleanup script is somehow getting called to early during the task sequence (if I incorporate a restart).

    Friday, June 15, 2018 10:07 AM
  • Just a thought...can you add an exception code to the install and not do a reboot until the Finish Action?
    Since you stated: "If I choose to install .NET Framework, without a reboot further actions fail
    due to a pending reboot. But the task sequence does run on."

    Try installing it with a suppress and add an exception code and see if that helps.

    Wednesday, June 20, 2018 7:36 PM