Remote Desktop App - "Always On Top" after Fall Creators Update RRS feed

  • Question

  • We use remote desktop app to connect to an old access DB - after installing Fall Creators Update - the windows is stuck at "always on top", user can't click on other screens to go back and forth.  Only work around is to minimize the screen each time they want to use another app - which is kind of a pain for the engineer as they are looking for spec data to use in AutoCAD - and bit extra work to go between apps now.  Any workaround?  There is no options in Remote Desktop that I can see to turn this off.  Thanks!
    Thursday, October 26, 2017 1:04 PM

All replies

  • Hi,

    I found a similar case may give you some ideas, please refer to the link:

    Remote Desktop Connection Fails After Fall Creators Update Installed


    Best Regards,


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Tony_Tao Tuesday, October 31, 2017 8:19 AM
    Friday, October 27, 2017 2:25 AM
  • my issue wasn't that the connection failed - it was just using Remote App - the screen would do stay on top - and users couldn't flip around to other apps.  Only work around was just to have them do full desktop remote - then open the app and resize the screen to just what was needed for the particular app.  Pain in the butt for something that used to work so well.  Hoping in upcoming releases this is fixed. 
    Tuesday, October 31, 2017 6:32 PM
  • Hang loose Peggy, trying to get an idea if this is an RDP bug or a Windows 10 bug.  Bottom line it's not the same as the link Tony is pointing to.
    Wednesday, November 8, 2017 12:53 AM
  • I don't know if this exactly solved my issue but it might help, it's hard to say exactly what helped (running this Windows 10 version: 1709 (10.0.16299.125) (December 12, 2017)):

    Try disconnecting and reconnecting the RDP (Remote Desktop) sessions that seem to be "Always On Top".

    Monday, December 18, 2017 9:29 AM
  • Thanks Anton, this helped me!

    This sounds non-intuitive, but I went to Options - Local Resources and then disabled Remote audio and Printers redirection, and the RDP window wouldn't stay on top anymore. 

    [added] P.S. after a period of time, the RDP window stays on top again :(
    Tuesday, December 19, 2017 7:38 AM
  • No problem Alexey!
    If you're pressing Ctrl+Alt+Home to switch from RDP to other windows, then pressing the Windows button might help, then switching/Alt+Tab to another window. Tried today with disconnecting and reconnecting and it worked again to get rid of "Always On Top". We'll see if it holds.

    Have a nice day!
    Tuesday, December 19, 2017 9:16 AM
  • This is absolutely a bug. I have what sounds like the same problem with certain applications published via RDS. Because we are a software vendor, our development staff did determine the catalyst (or one of the catalysts) was the function that hides a window. When we do that, the focus becomes locked on one of the remoteapp windows and you cannot switch to any other applications unless you minimize/maximize the window that has the stuck focus.

    Happens in 1709, any previous version of Windows 10 or older versions of Windows work as expected.

    I opened a case with Microsoft, but unfortunately it was shot down and closed due to the fact that I couldn't make the behavior happen with any standard applications (Notepad/WordPad/Office).

    Jay Schwegler

    Tuesday, January 2, 2018 7:22 PM
  • Jay?  What's the case number you opened with support?  Also could you email me privately at sbradcpa-at-PacBell.net as I want to get more info from you.
    Wednesday, January 3, 2018 5:29 PM
  • I am actually having this exact issue, and the only workaround I was able to come up with... sort of depends on what happened during your update and you have to play around in system32 in order to "fix it."

    What we did, basically, was grab a copy from .old and replace the existing mstsc.exe with the old one... which isn't a great workaround but it does work... if you still have a copy in the old folder, otherwise you're going to have to find another computer with a good old copy. Also, it doesn't actually fix the problem but just slaps a bandage on it.  

    Friday, January 12, 2018 9:39 PM
  • Apologies, I didn't see your thread. I sent you a direct email.

    Jay Schwegler

    Wednesday, January 17, 2018 9:05 PM
  • Interesting, I actually tried to do that with the mstsc.exe from a copy of 1703, however I got an error about that version of mstsc.exe not being compatible with the protocol version so I gave up.

    Jay Schwegler

    Wednesday, January 17, 2018 9:07 PM
  • Same problem here. Even after update: KB4056890 still the same problem.

    Friday, February 2, 2018 9:01 AM
  • I am also seeing this issue, agreed it only occurred since 1709 feature update on Win10 Pro. I have no work around, currently this issue is effecting a whole department. Has anyone tried using Win10 Education 1709? I wonder if this is Pro only. Could really do with MS acknowledging this is an issue at least. If anyone comes up with a workaround I would love to hear it.

    Thursday, March 1, 2018 12:14 PM
  • Can you email me at sbradcpa-at-PacBell.net (change the -at- to @) so we can get a test user set up and see what's going on?  I would need someone to set up a test account with and steps to repro.  Also can you install the RS4 insider edition (the next release coming out) and see if it repros there? 
    Thursday, March 1, 2018 4:39 PM
  • I'm wondering if this thread is related to the same overall problem. This problem in general has to do with Focus and window z-order which is what the following post is about. Apparently a fix is due out soon for the below, it might have an affect on our problem.


    Jay Schwegler

    Thursday, March 15, 2018 3:46 PM
  • Been annoyed with this bug for some time, but this totally did the trick! 

    Thursday, April 19, 2018 1:23 PM
  • I can confirm, that this is desktop OS problem, not TServer.
    The same RDA were tested with Win7. All was OK.
    My successful temporary fix is returning user stations 1709 back of mstsc.exe and mstscax.dll to 1703, version 10.0.15063.0.
    I know, this is not a solution, but it helps me to heal the pain.
    This also solved the "new improvement" of impossiblity to copy-paste from/to RDA.
    Now RDA users can work flawlessly again, until next second Tuesday...
    Thursday, May 17, 2018 8:23 PM
  • This appears to have worked for me too, with the following to make it permanent;

    - Open the Remote Desktop Connection desktop app

    - Set the options to disable audio and printers

    - SAVE the new default settings

    - close the application

    Thursday, April 18, 2019 1:05 AM
  • Thanks. This trick worked for me and I'm using Windows 10 version 1809 (OS Build 17763.437)
    Tuesday, April 23, 2019 8:09 AM
  • This appears to have worked for me too, with the following to make it permanent;

    - Open the Remote Desktop Connection desktop app

    - Set the options to disable audio and printers

    - SAVE the new default settings

    - close the application

    Unfortunately, this doesn't fix anything.

    Initially, the Alt+Tab works between RDP window and windows running on the host computer. However, after you minimise the RDP window and restore it for the first time, Alt+Tab no longer brings windows running on the host in front of the RDP window. They receive the keyboard focus fine, but they stay behind RDP window.

    It looks like a full-screen RDP window is marked as "Always-on-top" when restoring from minimised state.

    The issue can be reproduced by:

    1. Configuring Remote Desktop Connection application to set the remote desktop size to "Full Screen" and selecting Windows key combinations to apply "On this computer".
    2. Connecting to a remote computer.
    3. Minimising Remote Desktop Connection window.
    4. Restoring Remote Desktop Connection window.
    5. Alt+Tab no longer restores Z-order of other application windows running on the host computer. (You need to have at least one application started on the host computer to test switching with Alt+Tab). Mind that Alt+Tab-selected application does receive the keyboard focus thou.

    • Edited by Rozi Wednesday, April 24, 2019 9:08 AM
    Wednesday, April 24, 2019 9:07 AM
  • this helped me too, thank you
    Wednesday, September 18, 2019 10:56 AM
  • I can confirm that on my machine when it returns from a minimized state it comes back 'broke'.

    I cannot believe how annoying this is and how much it impacts my daily work flow!

    Wish there was a fix for this.

    Sunday, December 22, 2019 4:48 PM
  • Can confirm that this is still happening on Windows 10 1909.  The instant I minimize and restore an rdp window it becomes "always on top".  I can get it back to regular behaviour by popping it out of full screen and back, but this only lasts until I minimize it.  Super annoying for any user who frequently switches between remote and local workloads, especially when working from home with a tiny tablet PC as the second monitor.
    • Proposed as answer by footeo1 Wednesday, July 29, 2020 1:39 PM
    • Unproposed as answer by footeo1 Wednesday, July 29, 2020 1:40 PM
    Tuesday, April 7, 2020 4:59 PM
  • On a complete whim I edited my default rdp file with a text editor and changed the setting "videoplaybackmode:i:1" to "videoplaybackmode:i:0" to disable this setting and my rdp window no longer appears always on top.  I hope this works for those of you that are still having this problem (I was with 1909).
    • Edited by footeo1 Wednesday, July 29, 2020 1:44 PM
    • Proposed as answer by Rozi Thursday, July 30, 2020 1:49 PM
    • Unproposed as answer by Rozi Thursday, July 30, 2020 8:56 PM
    Wednesday, July 29, 2020 1:43 PM
  • On a complete whim I edited my default rdp file with a text editor and changed the setting "videoplaybackmode:i:1" to "videoplaybackmode:i:0" to disable this setting and my rdp window no longer appears always on top.  I hope this works for those of you that are still having this problem (I was with 1909).
    Unfortunately, the problem came back after a while. Double checked the videoplaybackmode was still 0.
    Thursday, July 30, 2020 8:59 PM
  •  Can confirm problem still exists. Used Alt+Tab and was able to get stuff to appear over RDC, but as previously mentioned by another, it will re-top itself if you minimize and return to fullscreen. Using Windows 10 Education Update 2004.
    Saturday, August 8, 2020 5:51 AM