locked
Computer Waking Up at Night RRS feed

  • Question

  • Hi there,
    Have a problem with the desktop waking up at least once every 10 days or so.
    Checked all the necessary problem areas: powercfg /devicequery wake_armed returns NONE.
    Wake computer options are all off for Scheduled Maintenance, Power/Multimedia, Ethernet.

    Noticed the WindowsUpdate entry under Task Scheduler has "Wake the computer to run this task" checked.
    Unchecking  and OK (even without unchecking) on the properties dialog box will stall for a few seconds. Then there is an alert "task scheduler service is not available." This was restarted through the scheduler by (successfully) changing the conditions for that on the TaskScheduler entry.
    I suspect that Windows Update is waking the computer but the above doesn't constitute sufficient proof. Nevertheless, the irksome side-effect is that the OS doesn't appear to employ it's configured power saver options after being woken. So it can stay on for hours (or days) without turning off. (Bear in mind the Power Saver conditions work when the computer is manually started.)
    Any suggestions?


    A natural, B flat, C sharp, D compile

    Monday, July 28, 2014 11:11 AM

Answers

  • Do you have the option of replacing Windows' out-of-box anti-malware software with something better? Windows Defender is automatically disabled when a 3rd party package is installed.

    I use Avast! antivirus myself, but if you choose to go with that make sure you choose Custom Install, and disable most or all of the items in the center column.  It's a bunch of extra fluffware that's not needed - what is important are the three shields in the left column.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    • Marked as answer by LaurieSt Sunday, September 28, 2014 9:19 AM
    Friday, September 26, 2014 12:41 AM
  • Hi,

    The computer can be wake up by a windows update plan,  or a scan plan by an anti-virus software, check whether you have any other anti-virus software running on your system. In Windows 8.1 Windows defender is built in you can modify the scan time just as the screenshot below:

    Besides, I suggest to create a new power plan to resolve this:

    Yes. You can create and customize your own power plan to override the default one to solve this:

    1.Open Power Options by swiping in from the right edge of the screen, tapping Search, entering Power options in the search box, and tapping or clicking Power options.

    2.Tap or click Create a power plan and follow the instructions.

    3.Go to Sleep tab, then choose Allow wake timers to “disable” just as the screenshot below:


    Regards


    Wade Liu
    TechNet Community Support

    Tuesday, August 5, 2014 9:24 AM

All replies

  • Hello.

    Does powercfg /lastwake show any details?

    Can you look at the system event log in event viewer?

    Look for Power-Troubleshooter events, event ID 1

    Check the details of those events to see if they give more information


    Thanks, Darrell Gorter [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, July 28, 2014 5:24 PM
  • Hi Darrell,
    Thanks for your interest: powercfg /lastwake gives:

    wake history count -1
    wake history [0]
    wake source count - 0
    

    The most recent logged events are as follows:

      Logged: 20/07/2014 4:54:11 AM
      SleepTime 2014-07-19T16:08:53.347518800Z 
      WakeTime 2014-07-19T18:54:07.975792300Z 
      SleepDuration 5148 
      WakeDuration 489 
      DriverInitDuration 431 
      BiosInitDuration 0 
      HiberWriteDuration 3162 
      HiberReadDuration 3779 
      HiberPagesWritten 166486 
      Attributes 16401 
      TargetState 5 
      EffectiveState 5 
      WakeSourceType 0 
      WakeSourceTextLength 0 
      WakeSourceText  
      WakeTimerOwnerLength 0 
      WakeTimerContextLength 0 
      NoMultiStageResumeReason 0 
      WakeTimerOwner  
      WakeTimerContext  
    

      Logged: 28/07/2014 4:01:26 AM
      SleepTime 2014-07-27T16:25:02.085474900Z 
      WakeTime 2014-07-27T18:01:23.010360200Z 
      SleepDuration 3154 
      WakeDuration 510 
      DriverInitDuration 445 
      BiosInitDuration 0 
      HiberWriteDuration 4076 
      HiberReadDuration 4873 
      HiberPagesWritten 214406 
      Attributes 16401 
      TargetState 5 
      EffectiveState 5 
      WakeSourceType 0 
      WakeSourceTextLength 0 
      WakeSourceText  
      WakeTimerOwnerLength 0 
      WakeTimerContextLength 0 
      NoMultiStageResumeReason 0 
      WakeTimerOwner  
      WakeTimerContext  
    

    Looking at the Windows System Logs, the first thing of interest in the second wake-up was the following logged at 4:01:26 AM.

    The system time has changed to ‎2014‎-‎07‎-‎27T18:01:22.500000000Z from ‎2014‎-‎07‎-‎27T16:25:06.322889900Z.
    
    Change Reason: System time synchronized with the hardware clock. 
    There are 0x1 boot options on this system.
    The boot type was 0x2.
    
    ---(usual boot up messages)---
    The system has returned from a low power state.
    Sleep Time: ‎2014‎-‎07‎-‎27T16:25:02.085474900Z
    Wake Time: ‎2014‎-‎07‎-‎27T18:01:23.010360200Z
    Wake Source: Unknown
    Reset to device, \Device\RaidPort1, was issued.
    

    Was the computer woken to adjust the clock? The BIOS doesn't cater for system clock changes.
    As a matter of interest, what do the values of Sleep Time and Wake Time actually represent?
    Is it total wake/sleep since last boot? In the above scenario the system was put to sleep at 2:25:04 AM, sleep for only 90 mins.


    A natural, B flat, C sharp, D compile

    Tuesday, July 29, 2014 10:26 AM
  • Hello,

    What is on the general tab of the Event ID 1 for Power Troubleshooter

    I don't see the wakesourcetext filed filled out in your events

    It should not wake to change sync the time with the system time.


    Thanks, Darrell Gorter [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, July 30, 2014 1:33 AM
  • On the general tab of the Event ID 1 for Power Troubleshooter:

    The system has returned from a low power state.
    
    Sleep Time: ‎2014‎-‎07‎-‎27T16:25:02.085474900Z
    Wake Time: ‎2014‎-‎07‎-‎27T18:01:23.010360200Z
    
    Wake Source: Unknown

    This message is no different from turning the box on manually. Having a closer look at the logging reveals the system time changes every day or so anyway. Not a reason for the power up.

    Well, other than the supernatural, it may be a power spike. Running from a very old UPS/battery- time to upgrade perhaps. Checked the detailed UPS logs for that time: no different to any other power on. Will let you know if the logs reveal anything more specific in the future.

    Thanks again for your interest.


    A natural, B flat, C sharp, D compile

    Wednesday, July 30, 2014 10:11 AM
  • Hi DarrellIt powered up again at 3:20 this morning (GMT + 10). The thing of note here was that 10 mins after the power up there were these kind of activities:

    The access history in hive \SystemRoot\System32\Config\RegBack\SYSTEM was cleared updating 11922 keys and creating 1011 modified pages.

    The Power Saver plan: "Put the computer to sleep" after 30 mins probably happens: at least the monitor blacks out- the fans are still running (the disks were on "never" I've changed that to 28 but then doesn't the processer require the disks turned on for hibernate anyway?).

    Hybrid sleep is turned on - try that at off?

    Allow wake timers has always been disabled.

    In Advanced settings, the computer is set to hibernate after 60 mins. Doesn't happen unless the machine has been powered up by, and used by yours truly. The Computer just stays on idle for hours. The problem then, perhaps, is to ensure it hibernates after the 60 mins has elapsed regardless of how the machine was started..

    Thanks again,

    Laurie


    A natural, B flat, C sharp, D compile


    • Edited by LaurieSt Tuesday, August 5, 2014 6:39 AM
    Tuesday, August 5, 2014 6:28 AM
  • HI 

    Check BIOS also Disable Wake on LAN and see

    Tuesday, August 5, 2014 6:31 AM
  • Hi,

    The computer can be wake up by a windows update plan,  or a scan plan by an anti-virus software, check whether you have any other anti-virus software running on your system. In Windows 8.1 Windows defender is built in you can modify the scan time just as the screenshot below:

    Besides, I suggest to create a new power plan to resolve this:

    Yes. You can create and customize your own power plan to override the default one to solve this:

    1.Open Power Options by swiping in from the right edge of the screen, tapping Search, entering Power options in the search box, and tapping or clicking Power options.

    2.Tap or click Create a power plan and follow the instructions.

    3.Go to Sleep tab, then choose Allow wake timers to “disable” just as the screenshot below:


    Regards


    Wade Liu
    TechNet Community Support

    Tuesday, August 5, 2014 9:24 AM
  • Hi Wade,

    Yes, it's been woken for a virus scan, according to the last scan report on the defender page. It says: "Last scan: Today at 3:20 AM (quick scan). Presumably this was the time it completed.

    But my Defender for 8.1 is missing your "Scheduled scan" and "Default action" LH list options. Does this mean I cannot directly control the scan times through the program.

    And (more importantly) shouldn't there be an option (or at least a registry setting) that if a computer is woken for a scan, it should either shut down or hibernate when the scan completes?

    Thanks for your interest.


    A natural, B flat, C sharp, D compile

    Tuesday, August 5, 2014 10:02 AM
  • Hi LaurieSt,

    Just as talked in the previous post, have you tried to create a new power plan to check the result? You can create and customize your own power plan to override the default one and disable the sleep mode.

    Regards


    Wade Liu
    TechNet Community Support

    Friday, August 8, 2014 1:57 AM
  • Okay thanks Wade_Liu, I'll give it a go.

    Up till now I simply modified the Advanced settings in the "Power Saver" (which will now be carried through to the custom plan.) Do you suspect that, even though I had previously changed some values for the "Power Saver" scheme, some of these values are ignored by the OS, merely because they conflict with the "inbuilt" default power templates?

    Will let you know if there is any difference.


    A natural, B flat, C sharp, D compile

    Friday, August 8, 2014 10:03 AM
  • Hullo again, Wade,

    The computer was woken again at 3:52 a.m. for a scan that completed at 4:02 a.m.

    Again, the PC did not shut down until it was hibernated at 8:00 a.m..

    The logon Impersonation level was Impersonate: %%1833

    Not happening so often now, but still searching for a solution with the power scheme- and why is the scheduled scan tab on the Defender page shown above missing on this machine? Might there be an update to Defender available for this platform?

    Thanks for any helpers.


    A natural, B flat, C sharp, D compile


    • Edited by LaurieSt Thursday, September 25, 2014 10:50 AM minor
    Thursday, September 25, 2014 10:37 AM
  • Do you have the option of replacing Windows' out-of-box anti-malware software with something better? Windows Defender is automatically disabled when a 3rd party package is installed.

    I use Avast! antivirus myself, but if you choose to go with that make sure you choose Custom Install, and disable most or all of the items in the center column.  It's a bunch of extra fluffware that's not needed - what is important are the three shields in the left column.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    • Marked as answer by LaurieSt Sunday, September 28, 2014 9:19 AM
    Friday, September 26, 2014 12:41 AM
  • Thanks for the heads up on that. Perhaps the Defender malware/firewall component isn't up to scratch as it appears some of my WAB in WLM has been hacked anyway.

    MSE (now deprecated?) seemed to work a little better.


    A natural, B flat, C sharp, D compile


    Edit: Doing a disk cleanup, especially Windows Update appears to make a difference. The scanning schedule was queried here.
    • Edited by LaurieSt Sunday, October 4, 2015 1:55 AM updated
    Friday, September 26, 2014 11:32 AM