locked
NPS Server in domain but not registered in Active Directory RRS feed

  • Question

  • Hi Everyone,

    I have 1 Radius client which I pointed to my NPS server which is joined in my AD domain.
    It runs server 2016 x64 UK with NPS.

    I added the radius client and also configured a network policy and a connection request policy.

    All works well, however, I didn't register it in Active Directory by right clicking in the NPS console on NPS and click "Register in Active Directory".

    According to microsoft resources I read on the internet this is required.
    However, even without registering it, it is still authentication my domain users correctly.

    Can anyone inform me why this behaviour is occuring ( I would expect, since it is not registed in Active Directory ), it is unable to query user information.

    Thanks in advance.

    Regards,

    André


    Andre

    Sunday, January 7, 2018 12:34 PM

All replies


  • Hi ,

    Did you use ADUC to register NPS or run the command of netsh ras add registered server?

    As far as I know,NPS servers must be registered in Active Directory so that they have permission to read the dial-in properties of user accounts during the authorization process. 

    Please check if the NPS server was added in the RAS and IAS Servers group.

    Best Regards,

    Candy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 8, 2018 3:37 AM
  • Hi ,

    Just want to confirm the current situations.

    Please feel free to let us know if you need further assistance.                   

    Best Regards,

    Candy



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 10, 2018 9:12 AM
  • Hi ,

    Did you have any updates?

    Best Regards,

    Candy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, January 12, 2018 9:37 AM