none
MSExchange Extensibility 1050 - execution time of agent 'Journal Agent' exceeded RRS feed

  • Question

  • Full Description:

    The execution time of agent 'Journal Agent' exceeded 90000 milliseconds while handling event 'OnRoutedMessage' for message with InternetMessageId: 'Not Available'. This is an unusual amount of time for an agent to process a single event. However, Transport will continue processing this message.

    This event has been occurring periodically on all HUB servers and mail delivery is slowed when it occurs.  Eventually the issues goe away (typically after 30 minutes or so).  It is not a problem related to dcomcnfg settings or MSExchange Transport Service 'log on' settings (as mentioned with other transport related agents).  Since this is a built-in agent, it will not return from the Get-TransportAgent cmdlet.  Would increasing the log level of MSExchangeTransport\Agents assist in assessing the causes of these delays (or perhaps MSExchangeTransport\Routing)? 


    Monday, July 30, 2012 5:28 PM

All replies

  • Check you sufficient RAM on your HUB server ?

    is that the only hub server you have this issue ?

    This occurs mostly of a performance issue on the hub.

    -

    We can disable journaling to verify .

    -

    You can also Check for Disk errors ?

    Disable AV and check ?


    Satheshwaran Manoharan | Exchange 2003/2007/2010 | Blog:http://www.careexchange.in | Please mark it as an answer if it really helps you

    Monday, July 30, 2012 9:32 PM
  • Hi Jerry,

    Any updates?


    Frank Wang

    TechNet Community Support

    Tuesday, July 31, 2012 9:16 AM
  • Sorry, I forgot I had posted this question online.

    Yes was have 3 HUB-CAS servers that have experienced such issues.  It doesn't happen every day, but generally once every one to two weeks.

    Those servers have 16GB of RAM each.  This problem has occurred a few times that is likely during high traffic moments.


    Monday, August 13, 2012 6:42 PM
  • Wouldn't you know, it happened again today.

    There are other MSExchange Extensibility entries with other agents such as 'Mailbox Rules Agent' and 'Conversations Processing Agent', although 95%+ are 'Journal Agent'.  These messages occur on all the HUB-CAS servers over a 30 minute period, and then they go away.  During this time system performance is slow and users call in complaining of no or very slow response from their Outlook client.

    The problem may be disk related, since the CAS servers all have ESE (ID:508) entries related to performance, stating 'likely due to faulty hardware' and one of the mailbox servers posting 'ExchangeStoreDB' error entries related to the databases it was hosting.  However, after the 20-30 minute period is over, all goes back to normal.



    Tuesday, August 14, 2012 2:50 PM
  • Hi All,

    Is there any other solution for this issue? it happened during the maintenance also while switching all databases to other servers.

    Suddenly queue count increased rapidly and it will take more to reduce. Uninstalled AV & upgraded the RAM.

    CAS & MBX servers are in the same box.

    It would be great help if there is any solutions

    Thanks & Regards,

    James Daniel


    James Danie

    Saturday, May 9, 2015 8:01 AM