none
IE10 compatibility mode problem RRS feed

  • Question

  • When I open gmail with IE10 I got a warning that I'm using Compatibility view and also if I browse http://html5test.com/ I got a real low score of 142,

    I've checked in menu Tools->Compatibility View Settings and compatibility mode is not enabled.

    Anyone has an idea of what is happening?

    Gian Maria.


    Ricci Gian Maria. (http://www.codewrecks.com)

    Tuesday, February 19, 2013 2:39 PM

All replies

  • Tools>Compatibility View Settings, check "Include updated website lists from Microsoft"

    If you've been using the Developer tool to change the userAgent string... (and closed the tab without first closing the developer tool) close all open IE windows and restart IE.


    Rob^_^

    Tuesday, February 19, 2013 11:32 PM
  • The reason was the following:

    I found some entries (fiddler and other couple of program) in

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION

    that for some reason forced my IE in IE8 compatibility. The strange stuff is that such registry key is used to change the level of emulation for software that actually uses Web Browser Control, and it should not suppose to be read by IE.

    Once those key were removed, IE started to work correctly again.

    Gian Maria.


    Ricci Gian Maria. (http://www.codewrecks.com)

    Wednesday, February 20, 2013 8:20 PM
  • the values under that key are for the names of the services (exe, dll's) that are allowed to use it....

    by default iexplore.exe is not in there...

    you may have broken something else by deleting the key.


    Rob^_^

    Friday, February 22, 2013 12:39 AM
  • Just for the record this is happening to me too, I did not check the registry key but I can tell you that mostly I like IE 10 and I have installed it on 2 machines already and both throw this error.
    Wednesday, February 27, 2013 4:57 PM
  • I, too, am experiencing the problem with Gmail and Google+.  Google.com is not listed in my list of compatibility view sites but still thinks it is.  I have tried all fixes suggested but none have worked.  I am using IE10 in Windows 7 Pro 64-bit.  This problem began as soon as I upgraded from IE9 to IE10.  I do have the FEATURE_BROWSER_EMULATION key in my registry but have not deleted it. It lists three modules:  prevhost.exe, sllauncher.exe and winzip64.exe.  I use WinZip so would not want to break it.   It would be really nice to be able to fix this problem.   While I can keep dismissing the message (very annoying) in Gmail and parts of Google+, I can't load my Google+ notifications at all because there is no "dismiss" capability.  Any suggestions would be greatly appreciated.
    Wednesday, May 1, 2013 2:10 AM