none
RWA Problem - Can Connect with WAN IP only & "domain name not setup" RRS feed

  • Question

  • This is a new setup of SBSe, so never used RWA before on it yet. We think we have done all necessary steps:

    - Created "A Record" pointing to Static WAN IP(proviced by ISP) on router - it is called remote.mydomainname.com -verified it is correct

    - Ensured ports 80 & 443 are not blocked by ISP

    - Purchased SSL Cert for: remote.mydomainname.com  -verifed it is in IIS bound to port 443

    - Ran wizard and received successful message: You can access your server at: https://remote.mydomainname.com

    Two things:

    1. When open RWA from Dashboard it shows Red X at top, shows "The domain name is not set up."  However, in the middle of the screen under Domain Name it shows "The domain is setup manually". It does show router IP (WAN Address)

    2. Cannot access server using: https://remote.mydomainname.com   However can access it, with Certificate error, at https://WANIPADDRESS.com

    What could be wrong?

    Thanks!

    Wednesday, March 7, 2012 9:48 PM

Answers

  • Can you access the site with UPnP enabled?

    It sounds to me like you do not have a 'trusted' certificate installed- as that is what generates the errors, and the RDP Gateway error.


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Monday, March 12, 2012 9:19 PM
    Moderator

All replies

  • Can you access it by local IP directly from the server?

    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Thursday, March 8, 2012 9:35 AM
    Moderator
  • Do you mean, while at the server, type https://LANIP

    If not, what do you want me to try and where from?

    Thanks

    Thursday, March 8, 2012 1:04 PM
  • yes from the server, and also try from a client?

    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Thursday, March 8, 2012 2:43 PM
    Moderator
  • I am not sure when I 'll get back to the client to try this,but for further troubleshooting when I am there, what if I cannot access the server via the local IP-- either at the server itself, or from the client?

    And...what if I can access it?

    Just curious as to why you proposed this idea...thanks!

    Friday, March 9, 2012 2:38 AM
  • Hi,

    In order to verify whether the RWA setup properly on the server side or not, I think you could visit the URL on your server side to verify whether the RWA could be accessed or not.

    On the server side, please enter the following URL in the IE browser on your server side to verify the issue:

    http://localhost:65510/remote
    https://localhost:65515/remote

    http://servername:65510/remote
    https://servername:65515/remote

    http://remote.mydomainname.com:65510/remote
    https://remote.mydomainname.com:65515/remote

    Then let me know each URL returned result.

    At the same time, if you have enabled the firewall, please make sure the port is opened.

    Regards,
    James


    James Xiong

    TechNet Community Support

    Friday, March 9, 2012 7:40 AM
    Moderator
  • To me it sounds like the ports are not open on the router.

    So if you can access it internally, that proves the site works, then it is just a case of making it work from outside.


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Friday, March 9, 2012 10:24 AM
    Moderator
  • Robert - I have UPnP enabled on my router-Linksys E4200v2. Do I also have to manually add ports 80 & 443 to the port forwarding section on the router interface as well?If so, I did not do that.
    Friday, March 9, 2012 2:20 PM
  • porbar

    I've had an issue where UPnP on my Cisco RV220W would "un-configure" itself and lose the port forwarding.  I had to disable UPnP and set the forwarded ports manually to resolve the issue.

    You do not need to manually forward ports if UPnP is functioning properly, but it may be worth trying the manual setup and disabling UPnP to further isolate the issue.

    Friday, March 9, 2012 3:28 PM
  • I would not use UPnP personally, my advice is to disable it and manually configure the router, then tell SBSe you are manually controlling the router.

    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Saturday, March 10, 2012 11:06 AM
    Moderator
  • While I haven't used the 4200, I did set up the Linksys 3000 and had to disable UPnp and manually open the ports to work. In general, I've never had much luck with uPnp and just manually configure as a matter of course
    Saturday, March 10, 2012 11:52 PM
  • Ok- from both Server & client, I get:

    The SBS logon with a Certificate error -- when I click on the error, it shows "mismatched address". When I view the Certificate, it shows Issued to: remote.domainname.com

    If I continue with the login, and then attemt to connect to an available computer, I get error the "Remote Desktop Gateway server address requested and the certificate subject name do not match"

    Any ideas?

    Monday, March 12, 2012 5:40 PM
  • For each, whether UPnp is enabled or disabled (manual port forwarding):

    1. Get "HTTP Error 403.4-Forbidden. THe page you are trying to access is secured with SSL

    2. Get SBS Logon, with Certificate error - Mismatched address.

    3. Same as #1

    4. Get SBS Logon, WITHOUT Certificate error. BUT cannot connect to a client PC without Remote Desktop Gateway Server error. Teh certificate shows remote.domainname.com

    5. Times out..nothing but white screen -Page cannot be displayed

    6. Times out..nothing but white screen - Page cannot be displayed

    I think my certificate is screwed up??  Or the bindings in Default Web Site?  There is a question mark next to Deafult WebSite and it shows "This site has multiple bindings"

    Whenever i do a Repair on RWA, it sets the bindings for 443 to my server's name - not remote.domainname.com

    I am at a loss here....I wish I could see a successful RWA.

    Monday, March 12, 2012 5:53 PM
  • If I disable UPnP and manually port forward, RWA shows router as "unknown" and bark with a port forwarding error. If I then choose "I will setup my router manually", then I don't get the bark but it still shows as unknown.

    If I enable UPnP and do not manully forward, the router shows as in RWA as Cisco with my WAN IP.

    Which is better?

    Monday, March 12, 2012 6:22 PM
  • Can you access the site with UPnP enabled?

    It sounds to me like you do not have a 'trusted' certificate installed- as that is what generates the errors, and the RDP Gateway error.


    Robert Pearman SBS MVP (2011) | www.titlerequired.com | www.itauthority.co.uk

    Monday, March 12, 2012 9:19 PM
    Moderator
  • Hi,

    Any Update?

    James


    James Xiong

    TechNet Community Support

    Thursday, March 22, 2012 7:44 AM
    Moderator
  • I have set up a few with a linksys 3000 and the best approach is to disable UPnP, manually forward ports 80 and 443.

    Follow this link to use existing certificate http://blogs.technet.com/b/sbs/archive/2011/08/04/how-to-install-your-existing-certificate-into-sbs-essentials.aspx 

    All should be OK. If not, I'd re-request your SSL certificate and follow the above link again. Here is the link on how to make the request from GoDaddy.

    http://support.godaddy.com/help/article/4801

    Hope this helps.


    • Edited by PeterSil Friday, March 23, 2012 2:56 AM
    Friday, March 23, 2012 2:55 AM