locked
Recent Files Not Updating for Excel (Taskbar) RRS feed

  • Question

  • I noticed my recent files suddenly have not been updating for Excel on the taskbar. I had contacted Dell Support recently for other issues and one time they did run an update to Windows 10, so that might have been a cause of this. I did a test on Word and it seems to be working OK; problem seems to limited to Excel.

    I was having trouble finding a solution for this problem anywhere. Long story short: I went to the recent files list in the taskbar, right clicked and deleted the files that were there. And now my most recent files are showing again. Pretty bizarre but this did work for me. Hopefully, it sticks. I wanted to put this out there for others who may be having the same problem. It could be as simple as doing this.

    Monday, September 7, 2020 4:33 AM

All replies

  • Can you check what value is there ?

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced

    then check the JumpListItems_Maximum

    • Proposed as answer by Balal Ahmad Monday, September 7, 2020 5:42 AM
    Monday, September 7, 2020 5:40 AM
  • After first fiddling with this, I set this back to be the same as Word. I looked for what you are showing above in my Registry Editor but it is not there.


    • Edited by MightyMCP Monday, September 7, 2020 3:59 PM
    Monday, September 7, 2020 3:57 PM
  • So, my Recent files were missing again - but then I turned OneDrive back on and the list reappeared. Very strange. It should appear no matter what. Obviously, some sort of glitch.

    • Edited by MightyMCP Monday, September 7, 2020 6:01 PM
    Monday, September 7, 2020 4:19 PM
  • if you didn't find just go ahead and create DWORD (32-bit) "JumpListItems_Maximum"

    and put 20 in decimal

    Tuesday, September 8, 2020 4:46 AM