none
Outlook remember deleted contacts on exchange 2007. RRS feed

  • Question

  • Hello, 

    I have an issue with Outlook 2010 and Exchange 2007 i hope someone can help me resolve.

    Outlook client is connecting to the Exchange server with cached profile.

    Several contactobjects on the exchangeserver have been removed. ex. "john@gmail.com". While the contact was there, no problem at all mailing to him. now the contact is deleted from the exchangeserver but we still need to email him. The only difference is that john@gmail.com isnt on the addresslist anymore, but still has a gmail account.

    When mailing him from within outlook, his mail is being resolved as an old internal exchange address john.k@company.intra and a nondelivery report is returned.

    I know for sure that the contact is deleted, several days ago and servers are replicated. I can email him from the OWA(same account as outlookclient). Therefore i think that the problem is on the client.

    I also ha a very bad solution. I can delete the folder AppData\Local\Microsoft\Outlook\Offline Address Books and after that i can mail the client. But we have 300users and i cant delete every users folders every time a contact is removed from the server.

    I hope some of you has an idea.

    Best Regards

    JM

    Thursday, April 7, 2011 7:54 PM

Answers

  • When you start to type john@... into the To: field does his name show in the autocomplete section?  Maybe try deleting it from there and then typing his email address in manually.
    • Marked as answer by Gavin-Zhang Friday, April 15, 2011 6:25 AM
    Thursday, April 7, 2011 8:10 PM
  • Hi Snigah,

    Above gave a method to resolve the issue.
    The issue caused by the NK2 file which cache the recipients information that ever be used.
    Some information for you:
    http://support.microsoft.com/kb/287623

    Regards!
    Gavin
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Gavin-Zhang Friday, April 15, 2011 6:25 AM
    Tuesday, April 12, 2011 10:05 AM

All replies

  • When you start to type john@... into the To: field does his name show in the autocomplete section?  Maybe try deleting it from there and then typing his email address in manually.
    • Marked as answer by Gavin-Zhang Friday, April 15, 2011 6:25 AM
    Thursday, April 7, 2011 8:10 PM
  • Hi Snigah,

    Above gave a method to resolve the issue.
    The issue caused by the NK2 file which cache the recipients information that ever be used.
    Some information for you:
    http://support.microsoft.com/kb/287623

    Regards!
    Gavin
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Gavin-Zhang Friday, April 15, 2011 6:25 AM
    Tuesday, April 12, 2011 10:05 AM