locked
Opening Package for upgrade Windows Installer Error. RRS feed

  • Question

  • I'm having an issue only when using open package for upgrade inside the sequencer.  When i try to run any .msi i get the following error:  The windows installer service could not be accessed.  This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed.  Contact your support personnel for assistance.  I noticed that the windows installer is stopped.  When i try to start it through the management console i get a message stating the windows installer service on the local computer started and stopped.   As soon as i click "stop monitoring" on the installation wizard, i am able to start/stop the windows installer service.  msiexec.exe and associated dlls has been captured and added to the VFS.  I also tried pointing the windows installer to the msiexec.exe in the VFS.  Any thought/suggestions would be greatly appreciated.

    Thanks in advance.
    Friday, May 15, 2009 7:16 PM

All replies

  • Hello,

    Any specific error messages? Anything in system / application log?

    If you make a new sequence and apply the patch - does that work?

    /Znack
    Saturday, May 16, 2009 11:48 PM
  • hi neville99,

    you can also try http://support.microsoft.com/?scid=kb%3Ben-us%3B324516&x=16&y=6 before you start sequencing.

    grz

    Roelk
    The Difficult takes time, the impossible just a little longer.
    Monday, May 18, 2009 2:07 PM
  • I will guess that you are sequencing on Vista with UAC enabled.  I wouldn't worry about the problem.  It seems that when the sequencer tries to shut down the service, it takes too long to shut down, generating the error dialog.  If you wish to avoid the dialog, shut down the service prior to the pressing "start monitoring" using the windows services manager.

    Monday, May 18, 2009 2:45 PM
    Moderator
  • If you created the package with an older version prior to App-V 4.5 (like 4.1 or 4.2) it might be the case that MSI executables are part of the package itself and may cause issues.

    Referenced here: http://blogs.technet.com/softgrid/archive/2009/03/03/potential-issue-upgrading-a-package-sequenced-on-softgrid-4-2-with-the-app-v-4-5-sequencer.aspx
    (App-V Blog: Potential issue upgrading a package sequenced on SoftGrid 4.2 with the App-V 4.5 Sequencer)


    Falko
    Tuesday, May 19, 2009 5:50 AM
    Moderator
  • I'd like to thank everyone for their posts.

    znack - there are no error messages in the event viewer other than the .msi has failed to install.  If i start a new package i can install the .msi.  I would rather do an upgrade because the previous admins who sequenced the app don't want to touch it, and the group involved in supporting the app also would rather do an upgrade.

    roelk - I tried most of the things in that link.  since the msiexec and associated dlls are captured into the old package i thought perhaps if i changed the the windows installer service to look at the VFS, change the path in the sequencer to point to the VFS, change the path in the registry for the windows installer to the VFS and then do a regsvr32 on the msiexec dlls, that might work but in my case it did not.  I think my understanding in this area is limited.  I'm not even sure if it even makes sense to try this but I did anyway because at this point i'm grasping at straws.

    Tim - i am running the sequencer on an xp virtual machine.  I tried what you suggested anyway, stopping the windows installer service before i click "begin monitoring", i then ran the .msi and it said it could not contact the windows installer service.  I could not manually start the service either.

    Kirk_tn - i did see the link and tried it again, however i still get the same error message upon following the instructions.  Once i hit "stop monitoring" i even re-saved the msiexec.exe and associated files back into the VFS, i saved the package again, closed the sequencer, reopened the package for upgrade, when i click on start monitoring, and then the .msi i get the same error again.  I was thinking to install the old sequencer to see if it would work.  Thoughts on that?


    thanks for the posts everyone.  I welcome any additional ideas.
    Tuesday, May 19, 2009 6:56 PM
  • Maybe it is this...

    When the original package was created, an opportunity to capture some of the windows installer dlls ocurred.  We normally take these, so that if the application needs to do a self repair it will have the same version available.  Perhaps these dlls are interfering - your inability to manually start the msi service in monitoring mode is quite telling.  So try opening the package for upgrade.  Look for those dlls in the Files tab of the "Sequence Editor" and remove them.  Also remove the mapping entries in the Virtual File System tab.  Then run the wizard and try.

    If this solves the problem please post back here.  It would be interesting to know!

    Wednesday, May 20, 2009 9:54 AM
    Moderator
  • Tim, I tried doing what you suggested.  I followed this link: http://blogs.technet.com/softgrid/archive/2009/03/03/potential-issue-upgrading-a-package-sequenced-on-softgrid-4-2-with-the-app-v-4-5-sequencer.aspx

    after i remove the files and restart the sequencer, i get the same windows installer error.  I also uninstalled windows installer 3.1, thinking perhaps the package was sequenced w/ an older installer, but the results were the same.

    If you have any other thoughts let me know.

    Thanks
    Thursday, May 21, 2009 6:52 PM