none
Reinstalled Printer prints garbage. How do I fix this? RRS feed

  • Question

  • Hi

    Baffled!!

    Hardware - 2 windows 7 PCs (IBM R60 & Tosh Tecra M10) on a simple home workgroup network.
    One aging Laserjet 6P/MP Postscript connected to one of them (Tosh) via a USB->Parallel port connector.

    All was working fine and has been for many months. And then a print job failed. It was hard to get rid of the job so I ended up deleting the print queue on the Tosh (stopping spooler and deleting files (from spool\printers) and resintalling the printer on the Tosh.

    Win7 does not find the printer automatically so I have to pick a port. Im told I have 3 USB printer ports - how do I know which one to usel does it matter and I thoguht they were supposed to go away when not used? Anyway I pick one and yes I can print but only garbage - loads of small 9pt - looks like line printer font) characters with osme overprinting

    Hmm so a few checks
    = Printer self-test works fine and reports no problems
    = Printer test print works fine.
    - Print test page from windows 7 is garbage - lines of small (6pt?) random characters, some overprinting - basically garbage.
    - In desparation, I dug out an old XP laptop with an actual parallel port plugged in the printer (which had the printer installed on iun a few years back) and it  printed perfectly first time.


    I have deleted printers from devices and printers (also printers and printer drivers from print management), rebooted and reinstalled printers and drivers until I am sick of it.
    I have tried LPT1 and the USB port
    I have tried installing the printer on a different computer (the one that normally accesses it via the network)

    So I suspoect a problem with the printer drivers. I have tried to ensiure fresh drivers were downloaded but I am not clear whether I managed to achieve this. In fact I suspect not.

    How do I fix this?

    So, how do I download a fresh set of drivers?
    If I can do that, is it sufficient to delete all printers; delete all drivers; reboot and reinstall all printers?
    And what do I have to do to ensure windows uses the fresh set of drivers - assuming I can download them

    Thanks for any suggestions


           
    Wednesday, February 5, 2014 11:48 AM

All replies

  • Hi,

    Since all drivers in Windows update are produced from manufacturer and then after passing the Windows Logo Program testing, then they can be distribute onto update, that should be little delayed. I suggest we download the latest driver applied to Windows 7 from manufacturer site.

    Before installing the driver, is suggest you open Control Panel\All Control Panel Items\Programs and Features and delete the printer driver that is already installed.

    You can temporarily disable security software and Windows Firewall service to test this issue. If the issue still persists, let’s check the Spooler dependency services in registry.

    a. Click Start , type regedit in the Search box, and then press ENTER.
    b. Locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Spooler

    c. Right-click Spooler, click Export, Save a backup file on your desktop.

    NOTE: If an unexpected issue be encountered after modifying registry, please double click the file to restore the backup .

    d. In the details pane, if the DependOnService value shows values of RPCSS and other key, right-click DependOnService, and then click Modify.
    e. In the Value data box, delete other key, and then click OK.
    f. Exit Registry Editor.

    Please restart the computer to test this issue again.

    Meanwhile, I would like to share the following link with you to check the issue:
     
    Fix printer problems
     
    http://windows.microsoft.com/en-us/windows/printer-problems-in-windows-help#fix-printer-problems=windows-7&v1h=win8tab1&v2h=win7tab4&v3h=winvistatab1&v4h=winxptab1

    Print Spooler Crash Troubleshooting Steps

    http://blogs.technet.com/b/perfguru/archive/2008/08/06/print-spooler-crash-troubleshooting-steps.aspx

    I also would like to suggest you contact HP directly to consult the issue. In this way, your issue can be fixed efficiently.

    Hope it helps.

    Regards,

    Blair Deng


    Blair Deng
    TechNet Community Support



    Thursday, February 6, 2014 6:08 AM
    Moderator
  • Thanks for the reply.

    The registry key contains RPCSS http so I should change this to just RPCSS?

    re the MS link - I've found and done all that. The concern was that perhaps the drivers stored on my machine were corrupt and reloading just reloaded corrupt drivers. But I think not now as the problem has occurred on two separate machines (win 7) and works on an old XP machine (but I think that a coincidence - the XP machine has a real parallel port; the two Win 7 machines are either going through a docking station or a USB -> Parallel connector) I am now suspecting (despite earlier thoughts) a broken/damaged/whatever USB->Parallel cable. New one due Fri or Sat.

    The Technet reference. The print spooler is fine because another printer (wireless) prints OK from the machine.

    Thursday, February 6, 2014 5:16 PM
  • Hi,

    Thank you for your update.

    Since the print spooler is fine, we can eliminate the cause.

    At this stage, I think, you'd better contact HP directly to consult the issue. I see lots of discussion over there related to your problem. In this way, your issue can be fixed efficiently.

    Regards,

    Blair Deng


    Blair Deng
    TechNet Community Support

    Tuesday, February 11, 2014 9:05 AM
    Moderator