Power Pivot and Power Query Not Showing Up Simultaneously in Excel 2016 RRS feed

  • Question

  • Having problems getting Power Pivot and Power Query to show up simultaneously in Excel 2016 (Microsoft Office 365 ProPlus on Windows 7 Professional).

    Each had shown up individually, but not together in my ribbon, but I wanted both. I went to the excel help and followed the below instructions. Now I cannot even get Power Query or Power Pivot to appear. Not sure of next steps, but am thinking that deleting the below items from regedit has caused this.

    Any thoughts on next steps would be greatly appreciated as even my IT Director isn't sure what should be done.

    Troubleshooting: Power Pivot ribbon disappears

    If the previous steps do not restore the Power Pivot ribbon, or if the ribbon disappears when you close and reopen Excel, try the following:

    1. Close Excel.

    2. Point to Start > Run and then type regedit.

    3. In Registry Editor, expand HKEY_CURRENT_USER > Software > Microsoft > Office > 15.0User Settings.

    4. Right-click PowerPivotExcelAddin and then click Delete.

    5. Scroll back up to the top of Registry Editor.

    6. Expand HKEY_CURRENT_USER > Software > Microsoft > Office > Excel > Addins.

    7. Right-click PowerPivotExcelClientAddIn.NativeEntry.1 and then click Delete.

    8. Close Registry Editor.

    9. Open Excel.

    10. Enable the add-in using the steps at the top of this article.

    Tuesday, March 8, 2016 4:21 PM


  • Hi,

    Based on your description, you're using Excel 2016 and in your environment Power Query and Power Pivot cannot be enable at the same time in Ribbon, is my understanding correct?

    First as far as I know Power Query is a hard build-in in Excel 2016 and named New Query on DATA tab. You don't need to enable it manually. Did it works fine in your environment.

    So your problem is related to Power Pivot in your Excel, first please try this method:

    1. Open Excel and select File->Options->Addins->Manage COM addins.
    2. Put a checkmark in the box for the PowerPivot for Excel addin and click OK.

    If that doesn't work, then:

    1. In Excel and select File->Options->Addins->Manage and select Disabled items in the dropdown.
    2. Click Go and then select: Microsoft.AnalysisServices.Modeler.FieldList.Addin.Integration
    3. Close and reopen Excel.

    Then if my understanding incorrect, please provide more information about your issue and I'm glad to help you.


    Emi Zhang
    TechNet Community Support

    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact

    Wednesday, March 9, 2016 9:42 AM