none
MDT requires specific license key, reboots afterwards RRS feed

  • Question

  • Hello,

    A very bizarre thing is happening at one of my customer's sites. They have MDT 2012 Update 1 running on a Windows Server 2008 SP2 64-bit. There is one deployment share with one task sequence. Today I created a new task sequence and the following issue occurs:

    In the Product Key page of the deployment wizard, the wizard requires entering a specific product key and doesn't let me choose No product key is required, nor does it let me enter a MAK key (it will only type in the Use a specific product key field):

    Since I don't have a valid OEM key I can use just to get passed this screen I tried entering a generic KMS key from this page:

    http://technet.microsoft.com/en-us/library/jj612867.aspx

    However the system then reboots. It seems to ignore the next steps in the task sequence.

    Does anyone know how I can fix this? Is the issue with the task sequence, the boot image or something else?

    Thanks in advance.

    Friday, November 15, 2013 2:15 AM

Answers

  • Hi and thanks so much for the prompt response. Apologies I haven't replied sooner - didn't receive en email alert.

    (Feel free to skip to the last line which contains the answer :) )

    As to your questions, allow me to reply:

    1. I was surprised as well, especially since I have MDT 2012 U1 working perfectly in so many different environments. But yes, I tried the mouse and keyboard with the reported results.

    2. I can't remember now, but it is possible that it was updated from 2010 or 2012 to 2012 U1.

    3. The reason I'm displaying the Product Key page is because (last time I checked) it isn't possible to specify SkipProductKey=Yes without also specifying a valid product key and at this stage I don't have a valid product key for the customer (still only setting up the environment, product keys have yet to arrive).

    However, I found what the issue was (hint: human stupidity): I specified SkipTaskSequence=YES but didn't specify "TaskSequenceID=". Specifying "TaskSequenceID=" with the appropriate value resolved my issue completely! Thanks again for your assistance, hopefully this will help someone in the future.


    • Marked as answer by turmoil Monday, November 18, 2013 5:52 AM
    • Edited by turmoil Monday, November 18, 2013 5:52 AM
    Monday, November 18, 2013 5:52 AM

All replies

  • There is something missing here.

    1. There is no code in MDT 2012/2013 that will *disable* the "NO Product Key is Required" radio button. So your description of the problem is confusing to me. How can you not not select it? Did you try using the mouse? did you try using the tab key?

    2. Perhaps this deployment share was upgraded (not cleanly) from a previous version of MDT?

    2. Why are you displaying the Product Key page to begin with? Why don't you just set SkipPRoductKey=Yes in your CS.ini file? Why are you skiping the task sequence page, but not this page?


    Keith Garner - keithga.wordpress.com

    Friday, November 15, 2013 4:30 AM
    Moderator
  • Hi and thanks so much for the prompt response. Apologies I haven't replied sooner - didn't receive en email alert.

    (Feel free to skip to the last line which contains the answer :) )

    As to your questions, allow me to reply:

    1. I was surprised as well, especially since I have MDT 2012 U1 working perfectly in so many different environments. But yes, I tried the mouse and keyboard with the reported results.

    2. I can't remember now, but it is possible that it was updated from 2010 or 2012 to 2012 U1.

    3. The reason I'm displaying the Product Key page is because (last time I checked) it isn't possible to specify SkipProductKey=Yes without also specifying a valid product key and at this stage I don't have a valid product key for the customer (still only setting up the environment, product keys have yet to arrive).

    However, I found what the issue was (hint: human stupidity): I specified SkipTaskSequence=YES but didn't specify "TaskSequenceID=". Specifying "TaskSequenceID=" with the appropriate value resolved my issue completely! Thanks again for your assistance, hopefully this will help someone in the future.


    • Marked as answer by turmoil Monday, November 18, 2013 5:52 AM
    • Edited by turmoil Monday, November 18, 2013 5:52 AM
    Monday, November 18, 2013 5:52 AM