none
Sign into PowerQuery Organization Account using ADFS Credential RRS feed

  • Question

  • Each time that I attempt to sign into PowerQuery via the "Sign In" button on the "Organization" area of the ribbon, I am prompted to enter my credentials in a standard page. Once I place my email address in, the page attempts to bounce back to our ADFS instance, but fails and merely displays a white screen.

    When I use a cloud identity (non-ADFS) this process works fine, so I suspect the problem with the PowerQuery code not redirecting properlty. Given that ADFS works just fine for every other service we utilize (Exchange Online, SharePoint Online, CRM Online, Project Online, etc.) this bug means that we simply cannot use PowerQuery.

    Monday, July 28, 2014 7:45 PM

Answers

All replies

  • Any ideas for this issue?

    Thank you!


    Ed Price, Azure & Power BI Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Saturday, August 2, 2014 2:27 AM
    Owner
  • We've had a few other people hit this. It looks like IE is trying to popup a credentials dialog but the settings on the embedded browser control prevent that. We're not yet sure what the correct solution is, but the issue was just diagnosed three days ago.

    There's no known workaround :(.

    Sunday, August 3, 2014 2:36 PM
  • We recently deployed ADFS for our Office 365 services and was faced with the issue of a blank login screen in Power Query when trying to access an OData feed from CRM Online or SharePoint Online. Adding all the service URLs to IE's Intranet Zone resolved the issue and passed through my credentials correctly to ADFS and then back to Power Query. This means the authentication dialog works because there is no credentials popup needed between the services (due to how the zone settings in IE are configured by default).

    I understand that this is a different feature than the "Sign In" button on the Power Query ribbon, since I'm only specifying the organization account in the query properties. We don't have a Power BI subscription tied to our Office 365 account, but when I click on the "Sign In" button it still appears that PQ is able to correctly authenticate with ADFS, pass the credentials to Power BI, then return the message that Power BI is not enabled, meaning that at least no blank screens are shown to me in this scenario.


    Jukka Niiranen - My blog: Surviving CRM - Follow @jukkan on Twitter

    Wednesday, August 13, 2014 2:07 PM
  • @Jukka Niiranen

    I am also facing a similar issue.

    I am trying to fetch data from dynamics CRM online using OData connector, after entering user id it tries to redirect for adfs credentials but instead of blank page I get error as shown below, Let me know if you have work around for this.

    I even tried to add odata service url to intranet setting (IE -> Internet Options -> security -> Intranet) but faced same error



    Tuesday, August 19, 2014 7:04 AM
  • We were able to resolve this by adding our dns as a local intranet site...

    Internet Options > Security > Local intranet > Sites > Advanced

    then add these websites:

    http://*.yourdomainname.com

    https://*.yourdomainname.com

    Friday, September 5, 2014 2:07 AM
  • Hi

    That solved the problem for me as well

    Thank you so much for sharing this workaround

    /Erik

    Wednesday, September 17, 2014 7:10 PM