locked
Sharepoint workflow VS 2010 deployment RRS feed

  • Question

  • Hi, I am following some msdn samples and try to delpoy a workflow project using Sharepoint 2010 workflow template. I get an error 'Feature ID "{...}" not deployed, I am not sure from all my investigations if I want to work the default Init and Assosiation forms and not build my own ( I just want to assign a task automatically from the workflow and sendmail and so on) should I be able to deploy my workflow or I still should be adding some ID's and forms into the xml files?????

    Why is this all so scattered???

    THX in advance , your reply will have me a lot!! 

    Monday, November 15, 2010 1:23 AM

All replies

  • Your Feature is most likely failing to deploy due to a bug in your code.  Commonly, this can be a typing mistake in a namespace.  So you should double check all your XML and make sure it currectly refers to the assembly containing your code. 

    You should also try the following to debug:

    1) Review your Windows Application Log looking for errors

    2) Review your ULS Logs (Default Location:

    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS)

    You can use http://code.msdn.microsoft.com/ULSViewer to make reviewing the logs much easier.

    3) You can also try setting a break point and stepping through your code since you are using Visual Studio 2010.  This is known as F5 Build and Debugging Support for SharePoint Development in Visual Studio 2010.  It is a much welcomed enhancement.


    Dennis Bottjer | Follow Me: @dbottjer | Blog: Dennis Bottjer.com
    Monday, November 15, 2010 4:51 AM
  • Your Feature is most likely failing to deploy due to a bug in your code.  Commonly, this can be a typing mistake in a namespace.  So you should double check all your XML and make sure it currectly refers to the assembly containing your code. 

    You should also try the following to debug:

    1) Review your Windows Application Log looking for errors

    2) Review your ULS Logs (Default Location:

    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS)

    You can use http://code.msdn.microsoft.com/ULSViewer to make reviewing the logs much easier.

    3) You can also try setting a break point and stepping through your code since you are using Visual Studio 2010.  This is known as F5 Build and Debugging Support for SharePoint Development in Visual Studio 2010.  It is a much welcomed enhancement.


    Dennis Bottjer | Follow Me: @dbottjer | Blog: Dennis Bottjer.com


    I see I will try all this. But my question was can I deploy with success when I don't have Init and assosiation forms and I don't edit my workflow.xml and feature.xml file in Vs since I want to use the default forms provided by Sharepoint lists?

    Thanks, please help with this questions!!! 

    Monday, November 15, 2010 5:53 AM
  • Thanks a lot but please see my quote below. I need no know if I don't use my own Initiation and assosiation forms,. and don't edit the feature.xml and workflow.xml in VS can I deploy with success to a Sharepoint site??? Or I need to edit the xml files above with new GUID's and forms locations??

    THX much. Really need to understand this, it is not much info for a beginner with Sharepoint on 2010 Sharepoint and  workflow, many refer to 2007 instead.     

    Monday, November 15, 2010 5:58 AM