none
Project Server Migration from 2010 to 2013 RRS feed

  • Question

  • Hi,

    Please let me know the migration steps and prerequisites of migration, also by doing migration what are all the things will be migrated.

    All the Users,groups, custom fields will be included in the migration?


    K.Gokulraj

    Friday, December 19, 2014 6:25 PM

Answers

All replies

  • K.Gokulraj --

    Please give a thorough reading of all the TechNet articles at the following URL:

    http://technet.microsoft.com/en-us/library/gg502590(v=office.15).aspx

    After participating in a Project Server 2010 to 2013 migration at my former employer, I can tell you the key to a successful migration is PLANNING.  Hope this helps.


    Dale A. Howard [MVP]

    Friday, December 19, 2014 7:56 PM
    Moderator
  • Hi Dale,

    I am planning and testing a migration from 2010 to 2013 now, and I got 2013 environment up and running to be ready for the migration.

    When I restored the 2010 datafiles onto the new environment, and started the Test and Mount Content database, I got the following errors, which made me rethink again how the 2013 env should be setup:

    Category        : SiteOrphan
    Error           : True
    UpgradeBlocking : False
    Message         : Database [WSS_Content] contains a site (Id =
                      [717d3894-622f-438d-b0dc-999e61dfc9de], Url = [/]) whose url
                      is already used by a different site, in database (Id =
                      [24f99c8a-cb4d-47bd-876a-950f438f62ec], name =
                      [WSS_Content_PWA]), in the same web application. Consider
                      deleting one of the sites which have conflicting urls.
    Remedy          : The orphaned sites could cause upgrade failures. Try detach
                      and reattach the database which contains the orphaned sites.
                      Restart upgrade if necessary.
    -----------------------------------------------------------------------------------------------------------------------------

    This error seemed to say that I should not have the WSS_CONTENT_PWA setup in 201. Is that correct?

    But if I don't have WSS_CONTENT_PWA setup, then does it mean we should not have a PWA for 2013 up and running before the migration?

    -------------------------------------------------------------------------------------------------------------------------------

    Category        : MissingSetupFile
    Error           : True
    UpgradeBlocking : False
    Message         : File [Features\ReportServer\ReportViewer.dwp] is referenced
                      [12] times in the database [WSS_Content], but is not
                      installed on the current farm. Please install any
                      feature/solution which contains this file.
    Remedy          : One or more setup files are referenced in the database
                      [WSS_Content], but are not installed on the current farm.
                      Please install any feature or solution which contains these
                      files.

    This error in the other hand says that Report Server not found in new 2013 env. I have installed Excel Services, and Secure Store following the instruction of

    https://social.technet.microsoft.com/Forums/projectserver/en-US/25e256fc-bb07-4535-9cb8-15402c0f217f/configure-reporting-for-project-server-2013?forum=projserv2010setup

    but looks like this is not resolved.

    Any idea on how these steps should be done?

    Thank you very much

    Hung

    Friday, April 17, 2015 5:33 PM