locked
Slow Win 7 boot RRS feed

  • Question

  • Hello,

    since last Saturday, my Windows is booting slower than before: It stays at the "starting Windows" screen for ~20 seconds, before it succeeds to the login screen.
    The past 10 months it immediately showed the login screen, after the Windows logo was built.

    The day before this problem occured, I disconnected my SSD from the motherboard for a few minutes (power/electricity was turned off, of course). Might this be the cause?

    I already re-installed Windows yesterday, but it didn't help.

    I also changed/deleted a few things in the registry in order to shorten the context menu (delete the WMP entries), but since importing the registry backup nor re-installing Windows helped, I guess that's not the reason of this problem.

    I have the latest BIOS driver, and it's also set to AHCI.
    I also have the latest graphics card driver.

    According to the Event Viewer, it's caused by the SMSSInit which takes around 20 seconds, which is exactly the time it takes longer to boot now.
    The value of Session Manager's "BootExecute" in the registry is "autocheck autochk *"

    This is my "boot_BASE+CSWITCH+DRIVERS+POWER_1.etl": http://www.mediafire.com/download/a2w4m2ijgbb7h13/

    Thanks in advance.


    • Edited by AgePee Tuesday, August 6, 2013 7:02 PM
    Tuesday, August 6, 2013 6:33 PM

Answers

  • WinLogonInt is slow:

    the WinLogonInit is slow because you need to long to insert your password:

    So type in the password faster.

    The SMSSInit delay is caused indeed by autochk.exe:


    "A programmer is just a tool which converts caffeine into code"

    • Proposed as answer by Andre.Ziegler Thursday, August 8, 2013 7:14 PM
    • Marked as answer by Cloud_TS Sunday, August 18, 2013 1:36 PM
    Tuesday, August 6, 2013 8:12 PM
  • run chkdsk yourself for drive C: and remove the autochk entry from BootExecute if nothing works.

    "A programmer is just a tool which converts caffeine into code"

    • Proposed as answer by Andre.Ziegler Thursday, August 8, 2013 7:14 PM
    • Marked as answer by Cloud_TS Sunday, August 18, 2013 1:36 PM
    Wednesday, August 7, 2013 5:49 AM
  • Hi,

    By default, the BootExecute value of the registry key HKLM\System\CurrentControlSet\Control\Session Manager is set to autocheck autochk *. This value causes Windows, at startup, to check the file-system integrity of your hard disks if your system has been shut down abnormally. It is possible for other programs or processes to add themselves to this registry value. (Note: Microsoft warns against deleting the default BootExecute value)

    If you want to prevent Autochk.exe from running on specific volumes or from running at all to speed up the boot, please use Chkntfs.exe. enter chkntfs at the command prompt.

    More information about Chkntfs, please refer to the following page:

    Chkntfs

    http://technet.microsoft.com/en-us/library/bb490877.aspx

    BootExecute

    http://technet.microsoft.com/en-us/library/cc963230.aspx

    Regards,

    Yolanda

    • Marked as answer by Cloud_TS Sunday, August 18, 2013 1:36 PM
    Thursday, August 8, 2013 9:32 AM

All replies

  • WinLogonInt is slow:

    the WinLogonInit is slow because you need to long to insert your password:

    So type in the password faster.

    The SMSSInit delay is caused indeed by autochk.exe:


    "A programmer is just a tool which converts caffeine into code"

    • Proposed as answer by Andre.Ziegler Thursday, August 8, 2013 7:14 PM
    • Marked as answer by Cloud_TS Sunday, August 18, 2013 1:36 PM
    Tuesday, August 6, 2013 8:12 PM
  • The WinLogonInt should be negligible then.
    It might just have been caused by some BSODs I encountered when tracing the boot using the Windows Performance Tools Kit, or because I went afk while the Kit was working.

    So how can I fix the SMSSInit delay? What could have caused it?

    Shouldn't the reinstallation of Windows have fixed this?
    Could it be caused by a Windows Update? I remember my PC booting normally (no 20s delay), 1 or 2 times, after I reinstalled Windows yesterday.


    • Edited by AgePee Tuesday, August 6, 2013 8:34 PM
    Tuesday, August 6, 2013 8:33 PM
  • run chkdsk yourself for drive C: and remove the autochk entry from BootExecute if nothing works.

    "A programmer is just a tool which converts caffeine into code"

    • Proposed as answer by Andre.Ziegler Thursday, August 8, 2013 7:14 PM
    • Marked as answer by Cloud_TS Sunday, August 18, 2013 1:36 PM
    Wednesday, August 7, 2013 5:49 AM
  • run chkdsk yourself for drive C: and remove the autochk entry from BootExecute if nothing works
    Thanks for your help.
    chkdsk /f didn't fix it, so I removed the autochk entry and now it boots as fast as it should.
    Could I experience some disadvantages now that I removed it?
    Wednesday, August 7, 2013 12:53 PM

  • Could I experience some disadvantages now that I removed it?
    I have no idea what happens after time. You should regularly do a chkdsk.

    "A programmer is just a tool which converts caffeine into code"

    Wednesday, August 7, 2013 8:09 PM
  • Hi,

    By default, the BootExecute value of the registry key HKLM\System\CurrentControlSet\Control\Session Manager is set to autocheck autochk *. This value causes Windows, at startup, to check the file-system integrity of your hard disks if your system has been shut down abnormally. It is possible for other programs or processes to add themselves to this registry value. (Note: Microsoft warns against deleting the default BootExecute value)

    If you want to prevent Autochk.exe from running on specific volumes or from running at all to speed up the boot, please use Chkntfs.exe. enter chkntfs at the command prompt.

    More information about Chkntfs, please refer to the following page:

    Chkntfs

    http://technet.microsoft.com/en-us/library/bb490877.aspx

    BootExecute

    http://technet.microsoft.com/en-us/library/cc963230.aspx

    Regards,

    Yolanda

    • Marked as answer by Cloud_TS Sunday, August 18, 2013 1:36 PM
    Thursday, August 8, 2013 9:32 AM