locked
Exchange 2003 - Word 2007/2010 slow selecting user from GAL RRS feed

  • Question

  • Hi All,

    I’m trying to help a friend with some strange behaviour with their Exchange server 2003.
    They have a Word Document they modify and email to customers using the
    "send to mail recipient" feature in Word.

    When they click the "From" button to select a generic user from the Global
    Address List sometimes there is a 20 - 30 second delay. It happens every day
    randomly. Not every time but sometimes and at least a few times a day.

    I haven't been able to find any information on the internet with similar issues around
    slow GAL access via Word. GAL access via Outlook is completely fine.

    Any help is greatly appreciated.

    Thanks


    Wednesday, October 3, 2012 10:59 PM

Answers

  • I guess when you access GAL via Outlook. the session had been connected when you launch Outlook app.
     
    However, when you send to mail recipient via Word, the process would be a bit more complex which included using Simple MAPI, establish session, access GAL and etc. If your Outlook is not running under background or disconnect to Exchange server, this behavior would be as expected.

    In addition, this behavior also might be caused by AVG/firewall, please turn off it for further testing. Thanks.

    Tony Chen

    TechNet Community Support

    • Marked as answer by Tony Chen CHN Tuesday, October 16, 2012 2:00 AM
    Friday, October 5, 2012 9:57 AM

All replies

  • I guess when you access GAL via Outlook. the session had been connected when you launch Outlook app.
     
    However, when you send to mail recipient via Word, the process would be a bit more complex which included using Simple MAPI, establish session, access GAL and etc. If your Outlook is not running under background or disconnect to Exchange server, this behavior would be as expected.

    In addition, this behavior also might be caused by AVG/firewall, please turn off it for further testing. Thanks.

    Tony Chen

    TechNet Community Support

    • Marked as answer by Tony Chen CHN Tuesday, October 16, 2012 2:00 AM
    Friday, October 5, 2012 9:57 AM
  • Hi Tony,

    They do have Outlook running in the background when they are sending these emails from Word. I have tried Outlook configured with cache mode and without cache mode, but the issue still appears for both modes.

    It's a strange issue. I will try disabling the AV/Firewall and let you know.

    Thanks 

    Tuesday, October 23, 2012 12:50 AM