none
Unable to connect to exteral data source (OData) RRS feed

  • Question

  • Hi,

    I am trying to create an external data connection to Project Online (O365).  I am following all the instructions to enter the data source name xxx/_api/ProjectData/

    I then receive the following error message:

    We couldn't get data from the Data Model.  Here's the error message we got:

    The remote name could not be resolved:'webisa.xxxxx.com.au'

    I am at my wits end with trying to get the connection to work, so I can create some reports for Project Server.

    Any help would be really appreciated.

    With Thanks

    Tuesday, March 22, 2016 9:42 AM

All replies

  • Hi,

    Try to hit the OData URL via internet explorer and check if returns any xml, if it does then your URL is correct, if not then you get the error in excel?


    Cheers, Badal Ratra MCTS

    Tuesday, March 22, 2016 11:03 AM
  • I agree with Badal,

    Try to see what happens when you use the URL in IE, Edge or any browser to see the resulting XML. If the result is very short the URL is incorrect, if the result is good there might be an issue with the Excel client log in. Keep in mind that OData is CAPS sensitive.

    Just to check:

    Do you log in as a user that has the right permissions? (admin, portfolio manager, portfolio viewer in SharePoint Permissions mode and anyone that has the "Access Project Server Reporting Service" right).


    • Proposed as answer by Badal Ratra Wednesday, March 23, 2016 12:18 PM
    • Edited by Erik van Hurck Thursday, March 24, 2016 7:41 AM changed the name of the setting to be the correct one.
    Wednesday, March 23, 2016 5:56 AM
  • Hi Badal,

    I know that my query is correct and returns data, as it works when I use Power Query (in Excel).  I can return all project data.

    When I try to just use a connection (not Power query), I receive errors (mostly 403 forbidden errors).  Is there something that I am missing??

    Thursday, March 24, 2016 12:52 AM
  • I login as the Administrator.  If I use Power query it works fine.  If I use connections (external data feed) it does not.
    Thursday, March 24, 2016 12:53 AM
  • Hi Cathy,

    I agree with "Erik van Hurck) Mostly 403 forbidden error is unAuthorized access. Error may happen in below situation too.

    1) If you are Delegating as someone (Team members) in the PWA and trying to run the report.

    2) Sometime the "Antivirus" or a Security Software may block this.

    Also please check once again the "Access Project Server Reporting Service" is marked Allow for the respective group (Project Manager, Portfolio Manager).

    Hope this helps you.


    -SNKBalaji


    • Edited by SNKBALAJI Thursday, March 24, 2016 4:40 AM
    Thursday, March 24, 2016 4:39 AM
  • SNKBalaji triggered two possible reasons why Excel gives the 403 errors and Power Querry doesn't:

    Have you tried "switch account" in Excel so that the only account that is active is the one you are using in combination with Project Online? You might need to clean up your user fault in windows as well...

    And have you tried opening Excel as an administrator? I'm hearing some clients recently that have experienced this issue and solving it with the "open as an administrator" action.

    Maybe it's a good idea to take a closer look at the exact OData string that you use (you can leave out the part before .../pwa_Api...).

    Hope this helps,

    Erik

    Thursday, March 24, 2016 7:46 AM
  • Hi Cathy,

    Are you in SharePoint permissions mode or Project permissions mode? If you are in SharePoint permissions mode, add yourself to the Portfolio Viewers or the Portfolio Managers group. Those groups have permissions to use the OData feed. At the very least, it would eliminate a potential issue.

    I've also moved away from using Excel for Project Online reporting. Too many gremlins in the machine. Power BI Desktop has been much easier and much less problematic to use with Project Online. It can also be free to use as well.

    Hope all of this helps!

    Treb Gatte, Project MVP | Blog | Twitter | Academy

    Thursday, March 24, 2016 8:04 AM
    Moderator
  • I am in Project Permission mode and nothing is working.

    All the info available says that the out of the box reports should work, yet I cannot get them to refresh (either in Excel 2013 or Excel Online).  This is getting very frustrating.....

    I am Admin level user and have enabled the PWA reporting with Excel.

    Any ideas where I should go from here

    Tuesday, April 5, 2016 5:44 AM
  • Maybe you should have Microsoft have a look. You can raise a call with them through your admin center on your office 365 environment.

    Let us know if Microsoft is able to solve it oke?

    Tuesday, April 5, 2016 7:28 AM
  • Have you tried defining the 'Report' you will be using?  e.g. I have just been pulling my hair out and when I completed the URL with [en-us] it all worked "....../_api/projectdata/[en-us]"

    Nigel Parsons

    Tuesday, May 10, 2016 12:52 PM