none
Error when trying to create KPI, scorecard, or any other item in the SharePoint 2010 - Dashboard Designer RRS feed

  • Question

  • I have installed SharePoint 2010 on Windows 2008 r2 Enterprise and MS SQL 2008 r2. The SharePoint site works fine, however, when I try to create a new KPI, scorecard, or any other item in the SharePoint 2010 - Dashboard Designer I get the following error:

    "Dashboard Designer"

    "Cannot connect to PerformancePoint Services. Contact the administrator for more details."

    I looked into the SharePoint "Central Administration -> Services on Server" and the PerformancePoint Services are shown "Started".

    I checked to see if it is the firewall problem, by turning off the firewall, but it still gives the same error.

    What would be the problem?

    Sunday, July 4, 2010 11:39 AM

Answers

  • Had the same problem. Here was my solution:

    1)      Open the SharePoint Central Administration Web Application by navigating to the URL.

    2)      Click “Application Management” in the Quick Launch bar

    3)      Under “Service Applications” click “Configure service application associations”

    4)      Click “default” in the “Application Proxy Group” column

    5)      Ensure that “PerformancePoint” is selected

    6)      Click “OK”

     

    Tuesday, August 10, 2010 4:09 AM
  • As said before you need to configure Services applications in Central Administrator. After configuring Service Store you need to configure PerformancePoint Service Application.

    Point 3. is very valid other thing you can check is on the bottom left corner of Dashboard Designer does it shows 'connected to ...' or not.

    Unless you fix point 3. you would not be able to do much on the designer.


    http://dailyitsolutions.blogspot.com/
    Tuesday, July 27, 2010 10:24 AM

All replies

  • Have you setup the secure store within SharePoint yet?

    To check this go to (Central Administration | Application Management | Manage Service Applications) Highlight the Secure Store Service and click on 'Manage'.

    Do you have a Key generated and an application?  If not then you'll need to setup a secure store application.

    Here is a good article to help with the setup of the secure store:
    http://technet.microsoft.com/en-us/library/ee806866.aspx

    Let me know how that goes for you!


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, July 6, 2010 4:06 PM
    Moderator
  • Hello BI_Explorer,

    Also, are you going through an NLB when trying to connect to Dashboard Designer? Does Dashboard Designer work on the Server and not on a client machine?

    Thanks,
    Jon Thomas


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, July 14, 2010 4:04 PM
    Moderator
  • Kristofer and Jon,

    Thanks to both of you for the responses. However, the problem still exists. To answer the points you mentioned:

    Kristofer> Have you setup the secure store within SharePoint yet?

    Answer> I did, and I also generated a key for the secure store. But, the error message still pops-up.

     

    Jon> Are going through a NLB.

    Answer> No. The server has one connection with no network load balancing (virtual or physicial).

     

    I was suspecting a firewall issue, but I did disable Symantect AV/Firewall with no positive result.

    I also tried to launch the PerformancePoint application from a client and also from the server directly, and I'm getting the same error message "Cannot connect to PerformancePoint Services. Contact the administrator for more details."

    More detals about the problem:

    1. I installed the SharePoint 2010 with no special configuration, and after finishing the installation, I ran the wizard to create the necassary services and application. I created a BI site through the wizard, and I added my AD account as Admin.
    2. I'm able to view the site and change configurations with no issues, it is only when I launch the PerformancePoint application and then I try to create a new Item (by right clicking on PerformancePoint > New >  KPI (or any other item) > OK
    3. An interesting finding is, when I click on the MS Office Icon (top left of the PerformancePoint application) and then click on "Designer Options" > "Server" > OK (without changing anything in the "SharePoint URL Text box that has the site address", I get the following error message: "The URL is not available, does not reference a SharePoint site, or you do not have permission to connect. http://172.16.???.???"
    Sunday, July 25, 2010 1:25 PM
  • The "PerformancePoint application" that I kept mentioning in my last post is the "Dashboard Designer" application. Sorry for the confusion.
    Sunday, July 25, 2010 1:34 PM
  • As said before you need to configure Services applications in Central Administrator. After configuring Service Store you need to configure PerformancePoint Service Application.

    Point 3. is very valid other thing you can check is on the bottom left corner of Dashboard Designer does it shows 'connected to ...' or not.

    Unless you fix point 3. you would not be able to do much on the designer.


    http://dailyitsolutions.blogspot.com/
    Tuesday, July 27, 2010 10:24 AM
  • Had the same problem. Here was my solution:

    1)      Open the SharePoint Central Administration Web Application by navigating to the URL.

    2)      Click “Application Management” in the Quick Launch bar

    3)      Under “Service Applications” click “Configure service application associations”

    4)      Click “default” in the “Application Proxy Group” column

    5)      Ensure that “PerformancePoint” is selected

    6)      Click “OK”

     

    Tuesday, August 10, 2010 4:09 AM
  • Kristofer, Jon and Umair,

    Thank you for you responses. The problem was in not configuring Service Store, and once I configured it, it worked fine.

    Monday, September 13, 2010 9:41 AM
  • Yeah.  after several search I came to this.  This is an important miss and should be added to the Performance Point setup page. this worked for me.

    Setup and started Performance Point Application Service and Secure Store Service with unattended account still not enough.  look like by default,  Performance Point service is not added to the default Application Proxy group so you will need to manually add it.

    Thanks for sharing this.

    Swanl


    Swanl

    Thursday, April 21, 2016 9:08 PM