locked
Error 0xc000000e when booting Vista in dual boot configuration RRS feed

  • Question

  • Hi guys!,

    Ok this is the situation. I've had XP and vista in two different partitions booting nice using acronis OS selector for the past few days until XP locked up. I restarted the PC and chkdisc ran and corrected a few indexing errors. Then I found I couldn't boot in either OS. After a while I managed to get things setup again with acronis OSS. XP can boot from OSS but vista isn't listed. If I disable OSS and just try to boot Vista as if XP doesn't exist I receive the winload.exe is missing /corrupt with code: 0xc000000e. Using vista to browse the vista partition i found that the file does exist in the correct folder

    Now I read this forum and someone said try to to point the path in bcdedit to \windows\system32\boot\winload.exe since it also exists there and this should fix it if it is indeed corrupt

    I tried but it said it couldn't find the file. I know it is there so instead I renamed the winload.exe in the sytem32 folder and then copied over the version from the boot folder. I rebooted (bypassing OSS) and windows boot manager displays the same error. I know a lot of people say oh i've tried everything etc etc.. but I have literally gone through pages and pages of google results and each method I have found doesn't work.

    I did notice that if I boot with the vista DVD and run repair it finds the vista installation on F:
    Then if I use the console to browse C:\  I find that C: isn't associated with XP but with one of my IDE drives that I use for storage.

    FYI this is what bcdedit reads

    Windows boot manager

    identifier {bootmgr}
    device partition=C:
    display order {default}
    timeout 30

    Windows boot loader

    identifier {default}
    device partition=F:
    path \Windows\system32\winload.xe
    description Windows Vista
    OSdevice partition=F:
    sysroot \Windows

    I'm not too familiar with these details I presume they're right or should device partition and OSdevice also read C: ? 

    I think this is the problem that is causing OSS not to be able to detect Vista. does anyone have any ideas? I don't know what else to try, it took me ages to setup Vista before... please help!  Sad

    [just to add:  I have also tried using the repair facility, it made a few corrections the first time around but didn't solve the boot error]
    Tuesday, April 17, 2007 8:42 AM

All replies

  • I just checked my IDE drive and it appears bootmgr and the boot folder is on that drive... it's not supposed to be there.  I think WBM is looking at this drive when it's booting and not my sata.  Is there a way to remove the boot record on the IDE drive so that it only looks for the sata's boot record?  I'm sure this would fix it.
    Tuesday, April 17, 2007 12:20 PM
  • Scratch that , I unplugged the IDE drive and still I gtet the same error...  And I seem to be talking to my self in this post...
    Tuesday, April 17, 2007 5:07 PM
  • Ok think I've fixed it now I used vistbootpro to restore the bootloader.. that it self didn't fix it but it allowed me try other things that did.. anyway I'm not gonna tell you how I did it cos wquite frankly no one posted any interest!
    Tuesday, April 17, 2007 6:24 PM
  • Hi Baggio!

    I have the very same situation like you, I would like to hear your idea about it.

    1) I tried to redirect the path to windows/system32/boot/winload.exe, but it is not work out.

    2) I have installed the vistabootpro 3.1, how does it work to fix the problem?


    Thank you!



    vk
    Wednesday, May 9, 2007 11:59 AM
  • Thursday, May 10, 2007 10:18 PM
  • What an A***hole! You are not better than the others! Maybe they didn't know the answer? But you just decided not to help others THOUGH you can.
    Saturday, August 1, 2009 9:50 PM
  • I'm not sure that failing to get a response within 10 hours of your initial post consititutes lack of interest. 10 hours is just not that much time. 

    Remember, these boards are a benifit to the community, not just your own private army of on-demand techs.

    Witholding your solution just seems rediculous and completely petty.

    (Notice it took me almost two and a half years to get back to you on this one)
    Monday, August 31, 2009 3:16 PM