locked
MAPI or an unspecified service provider. ID no: 00000000-0000-00000000 RRS feed

  • Question

  • I am having a problem and would like to know if you all could assist me with it? 

    Problem:

    I am trying to move a mailbox from Exchange 2003 to Exchange 2007 and I get the following error:

     

    Unable to move mailbox 'username'.

    Error: Failed to copy messages to the destination mailbox store with error:

    MAPI or an unspecified service provider.

    ID no: 00000000-0000-00000000

     

    I have been able to move several mailboxes before and after this mailbox.  I have users on both Exchange 2003 and Exchange 2007 and everything seems to be functioning well.  This is the only mailbox that I have encountered this error (so far). 

    Tuesday, May 22, 2007 3:31 PM

All replies

  •  

    Hi,

     

    I have the same problem and I can't find a solution. The Error only appears on one of 50 mailboxes.

    All normal tasks did not help (all fixes, reboot, googled, ...)

     

     

    thx

    Joerg

     

    Friday, November 9, 2007 9:28 AM
  • Same here

     

    Problem is on about 20 maiboxes.  I get this error when i try the Import-Mailbox cmd

     

    00000000-0000-00000000, error code: -1056749164

     

    Any ideas?

     

    Brad

     

    Tuesday, January 8, 2008 5:55 PM
  • Create a new OU with blocked inheritance.  Do not modify and permissions or rights on this OU just block inheritance.   Move the users accounts associated with the mailboxes that are giving you this error to this new OU.  Wait for AD to update then try to move the mailboxes again.  Hope this helps!

     
    Wednesday, January 9, 2008 3:26 PM
  • I had the same problem. It turned out to be a folder in the users mailbox that had explicit permissions removed for everyone.  When I deleted this folder I was able to migrate the mailbox successfully.

     

    Easiest way to confirm is to watch the progress of the migration and note down the point at which the failure occurs.  Also in my case there was an message in the event viewer saying which folder had the issue.

     

    Thursday, January 17, 2008 11:25 PM
  • It might be you are you missing the Rcieve-As Rights with that Admin Account. Type "Get-MailboxDatabase -identity "YOUREXCHANGESERVERNAME\First Storage Group\Mailbox Database" | Add-ADPermission -user "YOURDOMAIN\YourAdminAccount" -ExtendedRights Receive-As" in an Exchange Powershell". Hope this helps

     

    Friday, April 4, 2008 6:23 AM
  • Get-RoutingGroupConnector | Set-RoutingGroupConnector -MaxMessageSize 10MB

    http://technet.microsoft.com/en-gb/library/bb738125(EXCHG.80).aspx

    Try...
    And this
    http://support.microsoft.com/kb/843279
    Tuesday, April 8, 2008 11:28 AM
  • This is true for importing PST files created using ExMerge from Exchange 5.5, 2000, or 2003. In addition to having the required Exchange Administrator rights, you also need to run this command from an Exchange Powershell prompt:

     

    Code Snippet

    Get-Mailbox | Add-MailboxPermission -User "<YourUserName>" -AccessRights FullAccess

     

     

    After successful completion, try to run the import commands again.  Also, make sure the PSTs are local to the machine you are running these commands from.  Good Luck.

    • Proposed as answer by Motoki1 Thursday, July 15, 2010 12:59 PM
    Saturday, April 12, 2008 7:20 PM
  •  

    I received this error while importing .pst's recently.  It turned out that the .pst I was importing didn't contain and contacts (had been exported so as to not include contacts).  However, I was unaware of this, and so to reduce contact flooding in the user's mail profile, I was using the -excludefolders \contacts tag on the import process.  As soon as I removed the excludefolders it worked fine.
    Friday, August 29, 2008 5:21 PM
  • After pulling our hair out for hours we had discovered that particular users has limits set on their individual mailboxes even though we removed all limits on the new exchange database.  I also ran the administrator permissions cmdlt but i think it was the limits holding us back.

    Monday, September 15, 2008 3:14 AM
  • I had this problem when I tried to move one user from ex 2003 to ex 2007.
    I tried to set the fullaccess right,
    reset my exchange admin's role, download the rollup4 from MS, reset the user quota/limit..., anyway I can find online.

    none of them worked for me.

    So I just exported the .pst file. and deleted the old account,and created a new one on 2007, and import the .pst file.

    It worked finally.
    Wednesday, April 8, 2009 8:19 PM
  • This is true for importing PST files created using ExMerge from Exchange 5.5, 2000, or 2003. In addition to having the required Exchange Administrator rights, you also need to run this command from an Exchange Powershell prompt:

     

     

    Code Snippet

    Get-Mailbox | Add-MailboxPermission -User "<YourUserName>" -AccessRights FullAccess

     

     

    After successful completion, try to run the import commands again.  Also, make sure the PSTs are local to the machine you are running these commands from.  Good Luck.


    Thank you, this was the solution to my error:

    Failed to copy messages to the destination mailbox store with error:
    MAPI or an unspecified service provider.
    ID no: 00000000-0000-00000000, error code: -1056749164
    At line:1 char:54
    bleh
    Wednesday, April 29, 2009 12:12 PM
  • Using ex 2k7 sp1 commandline tool and moved mailbox from 2k3 sp2 after using

    Get-Mailbox <useraccount> | Add-MailboxPermission -User "<YourUserName>" -AccessRights FullAccess
    • Proposed as answer by Jeff Shaffer Friday, December 3, 2010 2:07 AM
    Saturday, September 26, 2009 1:13 AM
  • In my case I had a few users who had user quotas instead of the normal database default limits.  I temporarily increased their quotas past what they currently had, and then moved their mailboxes to Exchange 2007 using the -PreserverMailboxSizeLimit.  Once they were successfully migrated over I changed their quotas back to what they were before the migration.
    Sunday, April 11, 2010 2:33 PM
  • This worked for me as well.  It is important to note the solution above posted by Yuri will add the FullAccess permissions for ALL mailboxes within your environment.  For this reason I would go with chrisb's solution as it is mailbox specific.

    Jeff
    Friday, December 3, 2010 2:09 AM
  • To grant full access to a mailbox, use the Add-MailboxPermission cmdlet and specify FullAccess for the AccessRights parameter. For example, if Admin01 needs to export data from John's mailbox to a mailbox called Export, you must first run the following commands:
    Add-MailboxPermission -Identity john -User Admin01 -AccessRights FullAccess
    Add-MailboxPermission -Identity Export -User Admin01 -AccessRights FullAccess
    Wednesday, December 15, 2010 3:00 PM
  • I m still facing this issue..any idea
    Friday, January 7, 2011 7:15 AM
  • I was able to solve this.  We have a domain policy set that forces outlook cached mode.  Once i deleted the policy key for Outlook in the registry on my workstation and cleared out any orphaned mail profiles from failed imports it completed successfully. 

    Tuesday, March 1, 2011 8:36 PM
  • Right on the money - Thank you Microtom, you just saved me many hours of work - 
    Thursday, September 8, 2011 4:54 PM
  • Thanks so much everyone.  Adding the account permissions worked.
    David Jenkins
    Saturday, October 22, 2011 9:59 PM
  • This is true for importing PST files created using ExMerge from Exchange 5.5, 2000, or 2003. In addition to having the required Exchange Administrator rights, you also need to run this command from an Exchange Powershell prompt:

     

    Code Snippet

    Get-Mailbox | Add-MailboxPermission -User "<YourUserName>" -AccessRights FullAccess

     

     

    After successful completion, try to run the import commands again.  Also, make sure the PSTs are local to the machine you are running these commands from.  Good Luck.

    I also had the same problem and this solution helped me. It was a permission problem. When I granted the right permissions to my user ussing this cmdlet I was able to export mailboxes. Thanks!
    Tuesday, February 12, 2013 11:40 AM
  • Thank you! This was my solution also:

    Get-Mailbox | Add-MailboxPermission -User "<YourUserName>" -AccessRights FullAccess

    I was exporting mailboxes from Small Business Server 2008 and getting this error for some mailboxes:

    Failed to copy messages to the destination mailbox store with error:
    MAPI or an unspecified service provider.
    ID no: 00000000-0000-00000000, error code: -1056749164

    Thursday, October 16, 2014 8:03 PM
  • Adding to the above.. The admin account should have mailbox associated with it..

    Even after giving full permissions on mailbox I was not able to export mailbox. Then tried exporting mailbox with an admin account which is associated with mailbox. Finally issue resolved for me !!!!!! :-) 

    Wednesday, October 14, 2015 7:26 AM