locked
Unable to add Exchange 2007 UM role RRS feed

  • Question

  • Hi,

    I'm trying to add UM role on an existing exchange 2007 sp3 server running on Windows 2008 SP2.
    Desktop-Experience is already installed ! and i get the following error ::

    "This computer requires Windows Media Audio Voice Codec. Install the Desktop
    -Experience component via Server Manager"

    Any idea ?
    DV

    -------------------

    exsetup /m:install /r:UM

    Welcome to Microsoft Exchange Server 2007 Unattended Setup
    The following server roles will be installed
        Unified Messaging Server Role

    Performing Microsoft Exchange Server Prerequisite Check

        Unified Messaging Role Checks    ......................... FAILED
         This computer requires Windows Media Encoder. Install the Desktop-Experienc
    e component via Server Manager.

         This computer requires Windows Media Audio Voice Codec. Install the Desktop
    -Experience component via Server Manager.

    The Exchange Server Setup operation did not complete. For more information, visi
    t http://support.microsoft.com and enter the Error ID.

    Saturday, December 22, 2012 4:03 PM

Answers

    • Marked as answer by Sharon.Shen Wednesday, January 2, 2013 9:46 AM
    Saturday, December 22, 2012 4:39 PM
  • Hi,Dvi,

    Did you restart the server after you installed the Desktop Experience?The server must be restarted for the changes to take effect.

    If not the case,please verify that the Desktop Experience installed correctly,You can try to uninstall it,reboot server then reinstall it and reboot again to check if it works.Also please make sure have Windows Media player and the latest encoder installed on this server.

    Regards,

    Sharon


    Sharon Shen
    TechNet Community Support

    ************************************************************************************************************************

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.


    • Edited by Sharon.Shen Monday, December 31, 2012 8:25 AM remove improper greetings
    • Marked as answer by Sharon.Shen Wednesday, January 2, 2013 9:45 AM
    Monday, December 24, 2012 9:27 AM

All replies

    • Marked as answer by Sharon.Shen Wednesday, January 2, 2013 9:46 AM
    Saturday, December 22, 2012 4:39 PM
  • Hi,Dvi,

    Did you restart the server after you installed the Desktop Experience?The server must be restarted for the changes to take effect.

    If not the case,please verify that the Desktop Experience installed correctly,You can try to uninstall it,reboot server then reinstall it and reboot again to check if it works.Also please make sure have Windows Media player and the latest encoder installed on this server.

    Regards,

    Sharon


    Sharon Shen
    TechNet Community Support

    ************************************************************************************************************************

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.


    • Edited by Sharon.Shen Monday, December 31, 2012 8:25 AM remove improper greetings
    • Marked as answer by Sharon.Shen Wednesday, January 2, 2013 9:45 AM
    Monday, December 24, 2012 9:27 AM