none
Custom Flag field show's blank value by default instead of yes or no RRS feed

  • Question

  • Hi TechNet users.

    I see this behaviour in a number of my environments (RTM, CU April, ProjectOnline). I have a Flag custom field on task level, these should alway's have a value (No or Yes).

    So I create a Project schedule using the browser and add some auto scheduled tasks by just filling in the taskname column. I can view the flag field being populated with a No. Now I publish this project and check it in to the server.

    If I now look at that new project schedule using the PWA interface and I do not edit the project but just view the schedule with that flag column I just see a blank cell with the new task.

    If I edit the project and Manually change the flag field to say No and publish/check in the project the value is correctly displayed.

    But is this by design? To my knowledge a flag field always have a "No" value by default and should be "No" already when I just fill in the task name field. I think this is something the Schedule webpart on PPM doesn't do correctly? Can any of you reproduce the situation?

    Friday, July 11, 2014 9:40 AM

Answers

  • Hello Erik

    Until you choice a value, the value is NULL.

    cheers!


    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Website http://www.WhartonComputer.com
    Blog http://MyProjectExpert.com contains my field notes and SQL queries

    • Marked as answer by Erik van Hurck Thursday, November 13, 2014 8:11 AM
    Monday, July 14, 2014 3:16 AM
    Moderator

All replies

  • Hello Erik

    Until you choice a value, the value is NULL.

    cheers!


    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Website http://www.WhartonComputer.com
    Blog http://MyProjectExpert.com contains my field notes and SQL queries

    • Marked as answer by Erik van Hurck Thursday, November 13, 2014 8:11 AM
    Monday, July 14, 2014 3:16 AM
    Moderator
  • Thanks Michael, Sorry for the late reply but this was indeed the case. I checked it in the SQL tables and found the NULL values there.

    We fixed this by creating a look up table with values: Not Selected, Yes and No. Setting the Not Selected to the default.

    Thursday, November 13, 2014 8:13 AM