none
Kubuntu 18.04 installation error RRS feed

  • Question

  • Cannot install MRO 3.5.1 

    Logs copied from dependencies.txt. Other two logs do not have error information included.

    Reading package lists...
    Building dependency tree...
    Reading state information...
    less is already the newest version (487-0.1).
    libgomp1 is already the newest version (8-20180414-1ubuntu2).
    libsm6 is already the newest version (2:1.2.2-1).
    libxt6 is already the newest version (1:1.1.5-1).
    curl is already the newest version (7.58.0-2ubuntu3.2).
    libpango1.0-0 is already the newest version (1.40.14-1ubuntu0.1).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Setting up microsoft-r-open-mro-3.5.1 (3.5.1.1029) ...^M
    3.5.1^M
    ln: failed to create symbolic link '/usr/bin/R': File exists^M
    ln: failed to create symbolic link '/usr/bin/Rscript': File exists^M
    dpkg: error processing package microsoft-r-open-mro-3.5.1 (--configure):^M
     installed microsoft-r-open-mro-3.5.1 package post-installation script subprocess returned error exit status 1^M
    Errors were encountered while processing:^M
     microsoft-r-open-mro-3.5.1^M
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    ~                                                        


    Tuesday, August 28, 2018 1:33 PM

Answers

  • The error message above indicates that the links '/usr/bin/R' and '/usr/bin/Rscript' already exist.

    I would try renaming the above links and then try running the installer again.

    Let us know, if that fixes the problem.

    • Marked as answer by liu tytytyty Tuesday, September 4, 2018 5:30 PM
    Wednesday, August 29, 2018 11:26 PM

All replies

  • Did you download libpng12 as mentioned in our installation docs?  This is required on Ubuntu systems:

    On Ubuntu 18.04, you must also install libpng12 from the Linux Kernel archives, as it is no longer part of the Ubuntu distribution, as follows:

    wget https://mirrors.kernel.org/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.54-1ubuntu1_amd64.deb dpkg -i libpng12-01_1.2.54-1ubuntu1_amd64.deb

    This package is no longer supplied on newer versions of Ubuntu, so you need to install it first.

    Tuesday, August 28, 2018 5:51 PM
  • Here is the link to the online install documentation:

    https://mran.microsoft.com/documents/rro/installation

    Tuesday, August 28, 2018 5:51 PM
  • Did you download libpng12 as mentioned in our installation docs?  This is required on Ubuntu systems:

    On Ubuntu 18.04, you must also install libpng12 from the Linux Kernel archives, as it is no longer part of the Ubuntu distribution, as follows:

    wget https://mirrors.kernel.org/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.54-1ubuntu1_amd64.deb dpkg -i libpng12-01_1.2.54-1ubuntu1_amd64.deb

    This package is no longer supplied on newer versions of Ubuntu, so you need to install it first.

    I already installed this package 
    Wednesday, August 29, 2018 12:35 PM
  • The error message above indicates that the links '/usr/bin/R' and '/usr/bin/Rscript' already exist.

    I would try renaming the above links and then try running the installer again.

    Let us know, if that fixes the problem.

    • Marked as answer by liu tytytyty Tuesday, September 4, 2018 5:30 PM
    Wednesday, August 29, 2018 11:26 PM